Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache Websrv stellt Seite Falsch da. Lokal ist alles richtig.

Frage Linux Apache Server

Mitglied: 99008

99008 (Level 1)

11.05.2011 um 12:49 Uhr, 4848 Aufrufe, 3 Kommentare

Lokal (Apache auf Win-PC) wir die Website richtig angezeigt, im IE und im Firefox.
Wenn die Seite jedoch auf dem Webserver liegt, wird die Seite im Firefox noch richtig geladen, aber nicht im IE.

Hallo,

lokal auf einem Win-PC läuft unter Apache eine Website. Diese wird perfekt im IE und im Firefox angezeigt.
Wenn die Seite jedoch auf den Websrv kopiert wird, zerschießt der IE die Seite und diverse Funktionen funkionieren auch nicht mehr (z.b. Kalender Eingabefeld).
Mit dem Firefox funktioniert weiterhin alles bestens.
In den Apache Einstellung habe ich nichts gefunden das das hätte beinträchtigen können...

Hier mal ein Bild wie das ganze ausshieht:
http://h-4.abload.de/img/unbenannt3qc9.png

So wie rechts im Firefox sollte es eher sein... Woran kann das liegen?
Welche Apache Einstellung kann solche auswirkungen haben? Denn ansich funktioniert der Quelltext ja lokal auch im IE...

Vielen Dank im Voraus!!

Gruß
robin.boos
Mitglied: tonabnehmer
11.05.2011 um 13:01 Uhr
Ich würde den Quelltext der Seite a) IE lokal und b) IE extern vergleichen. Sind im IE ggf. Einstellungen, die dynamische Inhalte im Internet blockieren und nur lokal erlauben?
Bitte warten ..
Mitglied: richardfrick
11.05.2011 um 13:45 Uhr
das einzige was ich mir spontan so vorstellen könnte wäre ein nicht korrekter Pfad eines includes von css, oder javascript, der FF noch irgendwie interpretieren kann, IE aber nicht.


ich bin eher mit IIS bewandert, aber auf sowas hat ein Webserver (meines Wissens) keinen Einfluss.
Bitte warten ..
Mitglied: Snowman25
11.05.2011 um 14:15 Uhr
Hallo 99008,

Es wäre möglich, dass du im Dokument keine Zeichenkodierung angegeben hast und deni Apache und der Webserver unterschiedliche Standardkodierungen verwenden.
Dadurch kann der IE veranlasst sein, in den Quirks-Modus zu verfallen, da die Website seiner Meinung nach nicht richtig aufgebaut ist.
Im Quirks-Modus werden Seiten u.U. so dargestellt, als würdest du sie mit einem älteren Browser aufrufen. Dadurch kann es zu erheblichen Problemen beim CSS-Parsing kommen.

Überprüfe die Zeichenkodierung (unicode, utf-8, etc..) und teste auch ältere Browser zur Einschränkung des Problems.

Gruß
Snow
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Seit Zeitverschiebung falsche Zeit in Domäne (4)

Frage von honeybee zum Thema Windows Server ...

Apache Server
Apache2 als Reverse Proxy liefert die falsche Seite zurück

Frage von liquidbase zum Thema Apache Server ...

Windows Netzwerk
Seite Intranet wird als lokaler Computer "erkannt" (2)

Frage von SchiDie zum Thema Windows Netzwerk ...

CMS
gelöst PhpMyAdmin Login-Seite wird nicht dargestellt (3)

Frage von Static zum Thema CMS ...

Neue Wissensbeiträge
Mac OS X

Apple hat macOS High Sierra veröffentlicht

(1)

Information von Frank zum Thema Mac OS X ...

Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

(4)

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(7)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows 10
gelöst Netzwerkkarte schaltet sich erst nach dem Logon ein (24)

Frage von DerWoWusste zum Thema Windows 10 ...

Windows Server
Seit IP Umstellung DC DNS Fehler (22)

Frage von Yaimael zum Thema Windows Server ...

Grafik
gelöst CAD Arbeitsplätze (17)

Frage von Diddi93 zum Thema Grafik ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (16)

Frage von Voiper zum Thema Weiterbildung ...