Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache Websrv stellt Seite Falsch da. Lokal ist alles richtig.

Frage Linux Apache Server

Mitglied: 99008

99008 (Level 1)

11.05.2011 um 12:49 Uhr, 4701 Aufrufe, 3 Kommentare

Lokal (Apache auf Win-PC) wir die Website richtig angezeigt, im IE und im Firefox.
Wenn die Seite jedoch auf dem Webserver liegt, wird die Seite im Firefox noch richtig geladen, aber nicht im IE.

Hallo,

lokal auf einem Win-PC läuft unter Apache eine Website. Diese wird perfekt im IE und im Firefox angezeigt.
Wenn die Seite jedoch auf den Websrv kopiert wird, zerschießt der IE die Seite und diverse Funktionen funkionieren auch nicht mehr (z.b. Kalender Eingabefeld).
Mit dem Firefox funktioniert weiterhin alles bestens.
In den Apache Einstellung habe ich nichts gefunden das das hätte beinträchtigen können...

Hier mal ein Bild wie das ganze ausshieht:
http://h-4.abload.de/img/unbenannt3qc9.png

So wie rechts im Firefox sollte es eher sein... Woran kann das liegen?
Welche Apache Einstellung kann solche auswirkungen haben? Denn ansich funktioniert der Quelltext ja lokal auch im IE...

Vielen Dank im Voraus!!

Gruß
robin.boos
Mitglied: tonabnehmer
11.05.2011 um 13:01 Uhr
Ich würde den Quelltext der Seite a) IE lokal und b) IE extern vergleichen. Sind im IE ggf. Einstellungen, die dynamische Inhalte im Internet blockieren und nur lokal erlauben?
Bitte warten ..
Mitglied: richardfrick
11.05.2011 um 13:45 Uhr
das einzige was ich mir spontan so vorstellen könnte wäre ein nicht korrekter Pfad eines includes von css, oder javascript, der FF noch irgendwie interpretieren kann, IE aber nicht.


ich bin eher mit IIS bewandert, aber auf sowas hat ein Webserver (meines Wissens) keinen Einfluss.
Bitte warten ..
Mitglied: Snowman25
11.05.2011 um 14:15 Uhr
Hallo 99008,

Es wäre möglich, dass du im Dokument keine Zeichenkodierung angegeben hast und deni Apache und der Webserver unterschiedliche Standardkodierungen verwenden.
Dadurch kann der IE veranlasst sein, in den Quirks-Modus zu verfallen, da die Website seiner Meinung nach nicht richtig aufgebaut ist.
Im Quirks-Modus werden Seiten u.U. so dargestellt, als würdest du sie mit einem älteren Browser aufrufen. Dadurch kann es zu erheblichen Problemen beim CSS-Parsing kommen.

Überprüfe die Zeichenkodierung (unicode, utf-8, etc..) und teste auch ältere Browser zur Einschränkung des Problems.

Gruß
Snow
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Soziale Netzwerke
Na da freue ich mich doch auf die Zukunft (8)

Link von Knorkator zum Thema Soziale Netzwerke ...

Informationsdienste
NSA-Ausschuss: Wikileaks stellt 90 Gigabyte an Akten ins Netz (3)

Link von Frank zum Thema Informationsdienste ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...