Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Apache2 SSL Verschlüsselung geht auf einer seite nicht

Frage Linux Apache Server

Mitglied: tobsi224

tobsi224 (Level 1) - Jetzt verbinden

28.04.2011, aktualisiert 10:37 Uhr, 4723 Aufrufe, 1 Kommentar

Hi Leute,

ich habe ein Problem. Und zwar versuche ich momentan auf meinem Server eine SSL verschlüsselung einzubinden. Auf der Hauptseite geht das soweit auch nur auf einer Unterseite nicht. Wenn ich die Seite ansurfe zeigt mein Firefox in der Adressleiste ganz kurz an das eine Verschlüsselung da ist aber diese ist dann auch schnell wieder weg bevor die seite zuende geladen hat. In meinen Apache error.log steht folgendes:


[Thu Apr 28 08:26:43 2011] [info] Subsequent (No.2) HTTPS request received for child 0 (server example.com:443)
[Thu Apr 28 08:26:43 2011] [debug] mod_deflate.c(615): [client 212.204.68.178] Zlib: Compressed 16001 to 4761 : URL /startpage.php
[Thu Apr 28 08:26:58 2011] [debug] ssl_engine_io.c(1843): OpenSSL: I/O error, 5 bytes expected to read on BIO#e77dd40 [mem: e785430]
[Thu Apr 28 08:26:58 2011] [info] [client 212.204.68.178] (70007)The timeout specified has expired: SSL input filter read failed.
[Thu Apr 28 08:26:58 2011] [debug] ssl_engine_kernel.c(1772): OpenSSL: Write: SSL negotiation finished successfully
[Thu Apr 28 08:26:58 2011] [info] [client 212.204.68.178] Connection closed to child 0 with standard shutdown (server example.com:443)


Meine Vhost Konfiguration sieht so aus:

<VirtualHost example.com:80>
Redirect /startpage https://example.com/startpage.php
ServerName example.com
ServerAlias example.com
ServerAdmin admin@example.com
DocumentRoot /var/www/
</VirtualHost>

<IfModule mod_ssl.c>
<VirtualHost example.com:443>
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/server.cert
SSLCertificateKeyFile /etc/apache2/ssl/server.key
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
ServerName example.com
DocumentRoot /var/www/
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>
LogLevel debug
</VirtualHost>
</IfModule>

Also wenn ich nun " https://example.com " ansurfe funktioniert die SSL verschlüsselung nur bei " https://example.com/startpage " nicht genauso wie auf " https://example.com/startpage.php ".
Woran kann das liegen?

Grüße

Tobi
Mitglied: dog
28.04.2011 um 22:35 Uhr
Du hast mod_deflate aktiviert, der die Server-Ausgabe komprimiert.
Da gab es mal irgendeinen einen Bug im Zusammenhang mit PHP, wenn das ein leeres Ergebnis geliefert hat (so genau hab ich das aber nicht mehr im Kopf).
Bitte warten ..
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Apache Server
gelöst Probleme mit Apache2 und SSL bzw getssl (1)

Frage von Henere zum Thema Apache Server ...

Apache Server
gelöst Probleme mit Apache2 beim Versuch auf SSL umzustellen (5)

Frage von Henere zum Thema Apache Server ...

Ubuntu
SSL Zertifikat für Webmin (2)

Frage von ClepToManix zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (17)

Frage von Driphex zum Thema Exchange Server ...

Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...