Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Apache2 verhindert Aktualiserung der Website

Frage Linux Apache Server

Mitglied: eXtremeTK

eXtremeTK (Level 1) - Jetzt verbinden

02.12.2009, aktualisiert 03.12.2009, 4546 Aufrufe, 6 Kommentare

Website wird nicht zeitnah aktualisiert. Kein Reaktion auf Änderungen per FTP.

Moin Zusammen.

Ich habe da ein sehr merkwürdiges Problem mit meinem neuem System.
Es handelt sich um das neueste Debian mit ISPConfig und Apache 2. Den
Server möchte ich fürs Intranet benutzen.

Der Server funktioniert prima, kann dort z.B. Joomla sofort einspielen und
es läuft stabil und problemlos.

Dann habe ich per FTP alles aus dem Web Verzeichnis entfernt und eine
index.html reingeladen.
Wenn ich nun im Browser mit die Website wieder anzeigen lasse, schreibt er
dass er bestimmte Ordner nicht finden konnte. Er sucht somit immer noch nach
den alten Joomla Dateien?!
Darauf hin habe ich den Server neugestartet. Danach habe ich die index.html erreicht.

Gut, also per FTP die index.html wieder gelöscht und ein anderes Redaktionssystem eingespielt.
Nun kriege ich trotzdem immer noch die index.html angezeigt.

Ich habe das Gefühl, dass sich der Webserver eine Art Cache anlegt und diesen immer nur sporadisch,
auf Kommando (aber welchen?) oder nach einem Zeitintervall löscht.

Ich habe in einem anderen Thread etwas von einem Cache gelesen, den Apache nur alle 30 Tage löschen
tut, was mich jedoch arg verwundert.
Jetzt stehe ich jedenfalls mit einem super OS und dem ISPConfig wieder vor einem "Scherbenhaufen".

Hat jemand da einen Idee?
Diesen Thread habe ich gefunden, konnte dort jedoch nichts für mich verständliches entnehmen:
http://www.administrator.de/index.php?content=107423

Mein Fehler sieht dann übrigens immer so aus:
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Gruß & Danke!
Tobias
Mitglied: kaiand1
02.12.2009 um 22:28 Uhr
Schon mal dran gedacht das dein Browser auch einen Cache hat und auch Seiten Cachet...
Daher nimmt der Browser meist die Daten aus seinen Cache und zeigt sie dir an...
Stell am besten die Seiten mit einen Datum ein bzw deaktivere überall den Cache denn hast du nciht das Problem..
Bitte warten ..
Mitglied: eXtremeTK
03.12.2009 um 07:20 Uhr
Hi,
ja daran habe ich gedacht. Das wäre ja auch die einfachste Lösung. Habe es an 4 verschiedenen Rechnern probiert.
2 davon hatte noch nie die Seite aufgerufen.
Am Browser liegts somit nicht. Cache deaktivieren im Browser, oder in der Server Config?

Mein Fehler sieht dann immer so aus:
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Bitte warten ..
Mitglied: Arano
03.12.2009 um 12:52 Uhr
Achtung, Halbwissen !

Was seht den in den Logfiles des Apaches ?
Die Fehlermeldung sagt ja auch, das es einen Fehlergab (z.B. 410-Gone) die entsprechende Fehlerseite aber nicht gefunden wurde (Additionally, a 404 Not Found...).

Wie sieht es mit den Benutzer und den Rechten aus ?
Wenn der Apache keine Rechte zum lesen an der Datei hat, kann er diese logischerweise auch nicht ausliefern.

~Arano
Bitte warten ..
Mitglied: eXtremeTK
03.12.2009 um 20:09 Uhr
Hi Arano,
welche Apache Logfiles brauchst du da? Ich habe da leider noch relativ wenig Kenntnisse. Das ist das mein Problem.

Benutzer Rechte, hm, von welchem Ordner genau?

Was mich auf jedenfall auch verwundert ist, dass die Allgemeine Ansprechbarkeit per IP Adresse eher unzuverlässig funktioniert.
Lege ich z.B. eine zweite Website an, weisen beide Domainadressen auf die IP des Servers. Mal ist der phpmyadmin dann nicht aufrufbar,
mal erreiche ich nur eine Domain. Da scheint irgendwo wieder etwas durcheinander geraten zu sein. Vorgestern lief noch alles stabil und
ich hatte die Probleme. Hat eigentlich erst mit dem einspielen des CMS Contenido begonnen

Gruß
Tobias
Bitte warten ..
Mitglied: Arano
04.12.2009 um 00:06 Uhr
Naja, ich bin auch recht unerfahren auf dem Gebiet !

welche Apache Logfiles brauchst du da?
Das Fehlerlog, da kann man ggf. mehr erfahren.
Bei mir ligt das im "[Apacheverzeichnis]/logs", allerdings habe ich meinen Apache selber kompiliert.
Bei einer installation aus den Paketquellen könnten die in "/var/logs.... liegen" Aber das ist nur eine Vermutung

Benutzer Rechte, hm, von welchem Ordner genau?
Von dem in dem die Website liegt (also das DocumentRoot) und allen unterhalb, inklusive der Dateien !
Wie gesagt, der Webserver muss Leserechte auf alle Dateien haben und auf Ordnern Ausführrechte meine ich. Denn wenn er z.B. keinen zugriff auf das DocumentRoot hat, kann er loischerweise auch keine Dateien unterhalb anzeigen, ausführen, ect.

Gerade beim Upload per FTP kann dies durcheinander geraten: Z.B. Benutzer "webadmin" läd die neuen Dateien hoch, dan ist der Besitzer dieser Dateien "webadmin" und die Recht stehen möglicherweise auf 0700 (nur der Besitzer hat Vollzugriff) so kann Apache (Benutzer www-data) die Dateien nicht lesen.

Wie das nun bei dir ist weiss ich auch nicht weil du ja unteranderem ISPConfig verwendest das (glaube ich) das ganz "managed" und so eigentndlich funktionieren sollte.

Aber erstmal in den Fehlerlogs und nach den Benutzerrechten schauen.


~Arano
Bitte warten ..
Mitglied: eXtremeTK
25.12.2009 um 17:10 Uhr
Hi Arano,

habe anscheinend eine Lösung gefunden. Das Problem lag anscheinend nicht beim Linux Server, sondern bei unseren Windows DNS Server. Dieser hat anscheinend die Website im Cache behalten. Haben nun die Aktualisierung der DNS Auflösung auf 10 Sekunden gestellt und nun funktioniert es komischerweise. Naja, dann nehmen wir das erstmal so hin. Und laufen tut der gute Server nun auch schon seit fast einem Monat.

Gruß & Danke
Tobias
Bitte warten ..
Ähnliche Inhalte
Apache Server
Anzeige der falschen Website Apache2 vHotsts
gelöst Frage von m.reegerApache Server3 Kommentare

Hallo zusammen, ihr habt mir hier schon viel geholfen und meine Probleme immer gelöst. Nun stehe ich gerade auch ...

Apache Server
Apache2 Umleitung von Verzeichnis mit Alias
gelöst Frage von banane31Apache Server9 Kommentare

Guten Morgen, ich habe da mal eine Frage zum Apache2.4 mit einer Verzeichnis Umleitung. Meine Webseiten liegen alle unter ...

Windows Server
Richtline verhindert Verbindung mit Druckerwarteschlange
gelöst Frage von HanutaWindows Server3 Kommentare

Hallo Zusammen, ich habe ein Sehr komisches Phänomään Alle Druckerwarteschlangen lassen sich ausnahmslos und einwandfrei verbinden. Bis auf eine ...

Windows Server
Gruppenrichtlinie verhindert Verbindung zum Proxy
Frage von Kenny91Windows Server4 Kommentare

Hallo Zusammen, ich habe hier ein Problem welches ich nicht mehr verstehen kann. Wir haben eine kleine Domäne mit ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 19 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 21 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.