Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Arbeitsspeicher wird unter 64bit OS nicht erkannt

Frage Microsoft Windows 7

Mitglied: Damien180

Damien180 (Level 1) - Jetzt verbinden

21.09.2014 um 09:44 Uhr, 1599 Aufrufe, 24 Kommentare

Hallo zusammen,

ich habe ein meiner Meinung nach kurioses Problem mit einem HP-PC. Installiert war bis vor Kurzem ein Windows 7 Pro 32bit OS, mit insgesamt 4GB Arbeitsspeicher. Zunächst habe ich den Arbeitsspeicher erhöht auf ingesamt 16GB, was soweit auch kein Problem war. Der gesamt RAM wird von Windows erkannt, es sind aber, wie erwartet, nur ca. 3,5 GB verwandbar.
Wenn ich nun das Betriebssystem ändere (Windows 7 Pro 64bit), erwarte ich eigentlich, dass ich alle 4 Riegel voll verwenden kann. Stattdessen bleibt der PC bei "Windows wird gestartet" stehen und es passiert nichts mehr. Jedes Mal. Baue ich nun wieder bspw. einen 2GB Riegel RAM ein, ist alles gut. Windows startet.
Ich habe schon unterschiedliche Platten, PCs (baugleich) und OS' (Win7 Pro 32bit) verwendet, daher schließe ich einen defekten RAM aus.

Habt ihr einen Rat, wie ich hier vorgehen kann?

Vielen Dank im Voraus.
Mitglied: keine-ahnung
21.09.2014 um 09:49 Uhr
Moin,
Wenn ich nun das Betriebssystem ändere
wie ändert man ein Betriebssystem?

Wenn der RAM im BIOS erkannt wird, wird Dein Problem nicht beim RAM liegen. Da musst Du andere Ursachen suchen ...

LG, Thomas
Bitte warten ..
Mitglied: Damien180
21.09.2014 um 10:05 Uhr
Hallo Thomas,

man ändert ein Betriebssystem, indem man es neu installiert. Habe die 64bit Version hier vorliegen und kann sie im Moment mit dem 2GB-Riegel nutzen. Ich vermute zur Zeit auch kein Problem im RAM, da dieser sowohl durch das BIOS, als auch durch ein 32bit-OS voll erkannt wird.

Danke für die Antwort!
Bitte warten ..
Mitglied: jsysde
21.09.2014 um 10:08 Uhr
Moin.

Installier mal die aktuellste BIOS-Version und setze das BIOS auf die Default-Werte zurück. Just to be sure.

Versteh ich das richtig: Mit 16GB RAM kannst du W7 64Bit insallieren, es startet dann aber nicht. Ziehst du die 16GB raus und steckst stattdessen nur 2GB rein, bootet genau diese Installation ohne Probleme?

Cheers,
jsysde
Bitte warten ..
Mitglied: Damien180
21.09.2014 um 10:11 Uhr
Das habe ich eben nicht erwähnt:
Die Installation funktioniert mit gesteckten 16GB ebenfalls nicht. Dort bleibt die Installation ebenfalls bei "Starting Windows" hängen. Der Modus "Windows is loading files" wird noch abgearbeitet. Die Installation kann nur mit weniger RAM vorgenommen werden, aber eben nicht mit bspw. 2 Modulen der 16GB.

Danke für die Antwort.
Bitte warten ..
Mitglied: jsysde
21.09.2014 um 10:13 Uhr
Moin.
Zitat von Damien180:
Die Installation funktioniert mit gesteckten 16GB ebenfalls nicht.

Nimm mal ein anderes Installationsmedium oder falls du Zugang zu MSDN/VLSC hast, lad dir ne aktuelle ISO und brenne diese auf ne DVD/zieh sie auf nen USB-Stick und versuche es damit.

Cheers,
jsysde

P.S.:
BIOS-Update/-Einstellungen?
Bitte warten ..
Mitglied: wiesi200
21.09.2014 um 10:18 Uhr
Hallo,

Mach mal einen Memtest.
Das wenn die Installation nicht klapp so Tricks wie nachträglich rein stecken nicht klappen wird sollte eigentlich klar sein. Das hat schon einen Grund warum es sich nicht installieren lässt.

Dann das Handbuch schon angesehen ob die Module auch passen?
Bitte warten ..
Mitglied: Damien180
21.09.2014 um 10:52 Uhr
Laut Handbuch können bis zu 16GB aufgenommen werden, bei insgesamt 4 Steckplätzen. Der Speicher passt der Spezifikation zu Urteilen nach für meinen PC.
Bitte warten ..
Mitglied: wiesi200
21.09.2014 um 10:58 Uhr
Und der Memtest?
Bitte warten ..
Mitglied: Lochkartenstanzer
21.09.2014 um 11:09 Uhr
Moin,

  • Boote mal ein Live-Linux wie z.B. knoppix.
  • Erstmal einen memest davon starten udn speicher testen.
  • falls alles gutgeht das linux selbst starten udn schauen, ob alles erkannt wird. sudo dmidecode sollte anzeigen, welche Module das BIOS erkannt hat und mit welchen Parametern es initialiert wurde.
  • free zeigt dann an, wieviel speicher tatsächlch genutzt wird.

Damit stellst Du erstmal fest, ob die 16GB in Deiner Kiste überhaupt funktionieren.

Danach kann man drangehen, zu schauen, welches Windows-Problem es sein köntne.

lks

PS: BIOS-Update und default-BIOS-Werte (keine optimized!) sind auch ganz sinnvoll.
Bitte warten ..
Mitglied: Damien180
21.09.2014 um 11:14 Uhr
Der Memtest lief nun rund 20 Minuten und hat keine Fehler ausgegeben. Es war nur ein 2GB-Riegel verbaut. Habe vorher ein BIOS-Update durchgeführt und teste das gleich mal durch.
Bitte warten ..
Mitglied: Lochkartenstanzer
21.09.2014 um 11:41 Uhr
Zitat von Damien180:

Der Memtest lief nun rund 20 Minuten und hat keine Fehler ausgegeben. Es war nur ein 2GB-Riegel verbaut.

Udn was soll das bringen nur die 2GB statt den 16 zu testen?

lks
Bitte warten ..
Mitglied: keine-ahnung
21.09.2014 um 13:28 Uhr
Moin,
Udn was soll das bringen nur die 2GB statt den 16 zu testen?
rein mathematisch gesehen ist Sonntag eigentlich auch nix anderes als Freitag + 2!

LG, Thomas
Bitte warten ..
Mitglied: Pjordorf
21.09.2014 um 13:34 Uhr
Hi,

Zitat von Lochkartenstanzer:
Udn was soll das bringen nur die 2GB statt den 16 zu testen?
Weils es bedeutend Schneller geht
Und wenn Die Zwei gehen, geht doch auch der Rest, oder?
Bitte warten ..
Mitglied: RPU-RPU
21.09.2014 um 17:43 Uhr
Hi,

welchen Chipsatz hat dein Board ?
Alternativ bitte die genaue Boardbezeichnung....

Gruß Ralf
Bitte warten ..
Mitglied: Lochkartenstanzer
21.09.2014 um 19:34 Uhr
Zitat von RPU-RPU:

Hi,

welchen Chipsatz hat dein Board ?
Alternativ bitte die genaue Boardbezeichnung....


Haben wir hier von ihm auch schon nicht erfahren.

lks
Bitte warten ..
Mitglied: wiesi200
21.09.2014 um 19:46 Uhr
Wenn ich mir die Vorgeschichte so anhöre dann ist meiner Meinung einfach der RAM defekt und er will es einfach nicht glauben.
Jetzt versucht er mit allen Triks das zum Laufen zu bekommen.

Wenn ich sowas schon lese:" nachdem schritt für schritt die Riegel eingebaut worden sind ist die RAM Tabelle richtig aktualisiert worden."
Bitte warten ..
Mitglied: RPU-RPU
21.09.2014 um 20:25 Uhr
Hi,

oder er hat RAM, der außerhalb der JEDEC Spezifikation läuft und die benötigte Spannung passt nicht......
Warten wir mal ab, ob Memtest auch mit den 16GB komplett funktioniert.

Gruß Ralf
Bitte warten ..
Mitglied: Damien180
22.09.2014 um 09:17 Uhr
Guten Morgen,

der MEM-Test brachte leider keine Ergebnisse, bzw. war nicht erfolgreich. Ich habe die 4x4GB Riegel nun in einen anderen Rechner eingebaut: Dort wird er erkannt und Windows startet und arbeitet damit (ebenfalls Windows 7 Pro, 64bit, nicht baugleich). Damit ist ein Defekt des RAMs ausgeschlossen, wiesi200.
Ich fürchte, dass das Board nicht mit dem Arbeitsspeicher umgehen kann, eine andere Erklärung habe ich leider nicht. Eingebaut sind nun 2x2GB, die problemlos funktionieren.
Bitte warten ..
Mitglied: Lochkartenstanzer
22.09.2014 um 09:39 Uhr
Zitat von Damien180:

der MEM-Test brachte leider keine Ergebnisse, bzw. war nicht erfolgreich.

was heißt das genau? hat er fehler gemeldet oder klief er gar nicht erst los?


>Ich habe die 4x4GB Riegel nun in einen anderen Rechner eingebaut: Dort wird er erkannt und Windows startet und arbeitet damit (ebenfalls Windows 7 Pro, 64bit, nicht baugleich). Damit ist ein Defekt des RAMs ausgeschlossen, wiesi200.

Es kann imemr noch sein, daß die Spezifikation falsch ist. und diese daher nicht in dem vorgesehenen Board arbeiten. Oder das BIOs stellt die Parameter falsch ein, was man z.B. mit dmidecode oder memtest bei einem live-linux überprüfen könnte.

Ich fürchte, dass das Board nicht mit dem Arbeitsspeicher umgehen kann, eine andere Erklärung habe ich leider nicht.

Oder der Speiche rentspricht ncijht der Spezifikation des Boards!

Eingebaut sind nun 2x2GB, die problemlos funktionieren.

Dann soltlest Du versuchen, damit grlücklich zu werden oder noch zwei weitere baugleiche 2GB-Module dazustecken, damit du wenigstens 8GB hast.

lks
Bitte warten ..
Mitglied: jsysde
22.09.2014 um 13:41 Uhr
Moin.
Zitat von Damien180:
eine andere Erklärung habe ich leider nicht.
Ich hätte da so ne Vermutung - aber ohne Spezifikationen von RAM und Mainboards bleibt es eben eine....

Cheers,
jsysde
Bitte warten ..
Mitglied: RPU-RPU
22.09.2014 um 21:35 Uhr
Hi,

vielleicht sind die Informationen hinsichtlich Board, Chipsatz und RAM ja geheim und er hat davor Angst, dass die böse NSA diese Informationen liest....
Ich jedenfalls bin raus - das ist mir zu albern und ich habe keine Lust um Informationen betteln zu müssen.



Gruß Ralf
Bitte warten ..
Mitglied: infowars
23.09.2014, aktualisiert um 09:52 Uhr
Moin.
Ich tippe auf Inkompatibilität mit deinem Board.
Auch die 32-bit Version von Win7 kann mehr als 4GB, bei manchen ist nur eine Sperre verbaut, z.B. bei Win7 Starter Edition 2 GB.
Welche Edition hast du denn nun ? Die Pro ? Pro und aufwärts kann von Haus aus 4GB.
Lässt sich aber auch patchen. Stichwort /PAE, RAM-Disk, etc.
http://www.chip.de/news/Windows-32-Bit-Mehr-als-4-GByte-Speicher-nutzen ...
(Sorry für den Link zu chip.de)
Liste doch mal detailliert deine Hardware auf. Möglicherweise verhakt sich da ein Treiber.
Mit freundlichen Grüßen
Bitte warten ..
Mitglied: wiesi200
23.09.2014 um 10:26 Uhr
Ja, da musst du dich eigentlich wirklich für den Link entschuldigen.
Der Arbeitsspeicher wird da ja auch nicht wirklich als solches verwendet.
Also der Link hilft dir nicht zu mehr Arbeitsspeicher.

32-bit kann nur unter der Verwendung von PAE mehr Speicher benutzen und das ist tatsächlich gesperrt und nur den großen Server Editionen vorbehalten.
Bzw. Linux kann's.

Und das Patchen wird dir Lizenzärger bringen.

Die 2GB grenze ist nur bei der Starter Edition vorhanden und die war ja eh nur Netbook's
Bitte warten ..
Mitglied: infowars
23.09.2014, aktualisiert um 11:30 Uhr
1. Gib ich dir Recht mit dem chip.de Link.
2. Gesperrt, aber möglich.
3. Lizensärger ja, aber technisch gesehen möglich, deshalb tippe ich ja auch auf Inkompatibilität mit dem Board oder den Treibern.
Da der Ersteller nichts konkretes zum Board/Speicher/BIOS/OS sagt, muss man halt raten mit welcher Konfiguration er das Problem hat.
Aber er scheint sich ja eh nicht mehr weiter dazu zu äussern, bzw. hat ja selbst die Vermutung geäussert. bzgl. Inkompatibilität.
Mit freundlichen Grüßen.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Festplatten, SSD, Raid
Prüfung von HDDs - ohne installiertes OS (11)

Frage von quattroM-Techniker zum Thema Festplatten, SSD, Raid ...

Linux
SW-Verteilung und unattended OS Installation

Frage von winlin zum Thema Linux ...

Sonstige Systeme
Kaspersky OS: Kaspersky stellt eigenes Betriebssystem vor (2)

Link von tomolpi zum Thema Sonstige Systeme ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...