Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ARP-Problem bei 1 IP mit welchselnden MACs

Frage Netzwerke

Mitglied: kathaba

kathaba (Level 1) - Jetzt verbinden

17.10.2006, aktualisiert 18.10.2006, 3411 Aufrufe, 2 Kommentare

Ein PC weist in einer Produktion mehrer Geräte eine MAC zu und testet die Geräte anschließend. Nach ein paar Geräten funktioniert die Verbindung nicht mehr (auch Ping nicht mehr.)

Hi zusammen,

wir entwickeln für eine andere Firma ein netzwerkfähiges Gerät. Von dieser Firma haben wir auch ein Programm zur Verfügung gestellt bekommen, das nach der Produktion einen abschließenden Test durchführt und dem Gerät eine MAC-Adresse aus einem uns zur Verfügung stehenden Pool zuweist.

Das Gerät wird über ein Cross-Kabel an den PC mit Win2000 Prof angeschlosen.

Der ganze Vorgang schaut so aus:

1) Gerät anstecken
2) Gerät erhält IP von DHCP-Server (immer die gleiche IP!)
3) Diverse Tests
4) MAC-Adresse neu zuweisen & Neustart des Gerätes
5) Gerät erhält IP von DHCP-Server (immer die gleiche IP!)
6) Netzwerktest
7) Nächster durchlauf.
(Der eigentliche Aufbau ist etwas komplexer, da das Gerät mehrere Ethernet-Ports hat und über einen integrierten Switch verfügt, das sollte aber hier irrelevant sein.)

Vor Testbeginn haben alle Geräte die selbe MAC, danach jedes natürlich eine eigene.

Das klappt soweit auch. Aber nach ein paar Durchläufen ist das Gerät nicht mehr erreichbar, lässt sich auch nicht pingen.
Unter WinXP ließ sich das Problem durch Registry-Einträge zum ARP-Caching beheben, unter Win2000 aber nicht. (Für gewöhnlich klappen so zwischen 2 bis 7 Durchläufe, bis es zu Problemen kommt)

Hat jemand einen Rat für mich?

Danke,
Armin
Mitglied: filippg
17.10.2006 um 15:37 Uhr
Hallo,

ein W2K habe ich gerade nicht da um nachzuschauen. Aber soweit ich das in Erinnerung habe ist das arp-Dienstprogramm da identisch mit dem in WinXP. Und da wiederum muss man nur "arp -d *" eingeben, um den ARP-Cache zu löschen.

Filipp
Bitte warten ..
Mitglied: kathaba
18.10.2006 um 07:09 Uhr
Hi Filipp,

Danke für deine Antwort!
Ja, das haben wir auch schon probiert. Leider hat das aber auch nix gebracht. Wir haben auch ein kleines Script geschrieben, dass sozusagen den Cache in einer Endlosschleife leert. Ebenfalls ohne Verbesserung.

Ciao,
Armin
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

LAN, WAN, Wireless
Buffolo AccessPoint IP vergessen - herausfinden (9)

Frage von staybb zum Thema LAN, WAN, Wireless ...

Netzwerkgrundlagen
Multi NAT Problem (9)

Frage von Gr33n93 zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst ZIP-Archive nach Dateien durchsuchen und Pfade ausgeben (33)

Frage von evinben zum Thema Batch & Shell ...

Router & Routing
Routingproblem in Homerouter-Kaskade mit Raspi (19)

Frage von Oldschool zum Thema Router & Routing ...

Server
Freenas schlechte Schreib Performance bei NFS (16)

Frage von janosch12 zum Thema Server ...

LAN, WAN, Wireless
Buffolo AccessPoint IP vergessen - herausfinden (9)

Frage von staybb zum Thema LAN, WAN, Wireless ...