Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ARP-Request über WLAN schlägt fehl

Frage Apple

Mitglied: cney11

cney11 (Level 1) - Jetzt verbinden

29.03.2011 um 09:56 Uhr, 4856 Aufrufe, 3 Kommentare, 1 Danke

Guten Morgen,

vielleicht kann mir von euch jemand bei folgendem Problem helfen:

Ich habe einen iMac per WLAN in mein Netzwerk aufgenommen, der iMac ist auch per Ping erreichbar, jedoch habe ich ein seltsames Phänomen. Nachdem der iMac einige Zeit mit dem WLAN verbunden ist reagiert dieser nicht mehr auf Ping-Anfragen, der iMac kann jedoch von sich aus auf das Netzwerk zugreifen. Bei genauerem Hinsehen habe ich festgestellt, dass der iMac nicht mehr auf ARP-Requests antwortet, denn solange der Client noch die MAC-Zuordnung gespeichert hat funktioniert der Ping, ist die Zuordnung entfernt (weil einige Minuten keine Datenpakete versendet wurden), so geht der Ping nicht mehr durch. Erst wenn ich nun eine statische Zuordnung hinzufüge kann ich den iMac wieder anpingen.

Das ganze passiert mit zwei verschiedenen iMacs und zwei verschiedenen WLAN-APs, verwendet wird ein RADIUS-Server für die Authentifizierung am WLAN, Verschlüsselung ist WPA2.

Hat jemand eine Ahnung oder ähnliche Erfahrungen gemacht?

Viele Grüße,
cney11
Mitglied: aqui
29.03.2011 um 15:07 Uhr
Auf einen eingehenden ARP Request muss der Mac in jedem Falle antworten. Der fehler müsste dann auch analog im LAN auftauchen wenn es ein OS Bug wäre. Das ist aber stark zu bezweifeln, denn damit wäre dann kein normaler IP Traffic mehr möglich. Für einen mac recht ungewöhnlich und damit wohl auch utopisch.
Steht dann nur zu vermuten das die Authentifizierung da irgendwie Mist macht und die ARPs im WLAN nicht forwardet.
Hast du mal mit dem Wireshark geprüft ob die ARPs am Mac via WLAN Interface ankommen ?
Bitte warten ..
Mitglied: cney11
29.03.2011 um 15:12 Uhr
Ich hatte den Fehler auch erst auf den WLAN-AP geschoben, jedoch wundert es mich, dass es bei zwei verschiedenen APs passiert und dass zudem andere Geräte die am gleichen AP sind dieses Problem nicht haben. Wireshark wollte ich morgen mal auf dem iMac installiert und das überprüfen, bisher habe ich lediglich das Wireshark auf meinen Notebook getestet und festgestellt, dass die ARP Requests zwar per Broadcast rausgehen jedoch keine Antworten zurückkommen.
Bitte warten ..
Mitglied: aqui
30.03.2011 um 16:11 Uhr
Kann natürlich ein Firmware Bug sein, aber auch das wäre sehr gravierend, denn das würde eine korrekte IP Kommunikation verhindern. Sowas grundlegendes passiert nicht einmal bei dem allerbilligsten Taiwan Schrott.
Bedenke das dein AP niemals selber auch ARPs antwortet. Ein AP ist aus Netzwerk Sicht eine simple Layer 2 Bridge die diese Pakete nur forwardet aber nie selbst an der Session teilnimmt.
Die ARP Antwort sendet logischerweise immer das angesprochenen Endgerät !
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Installation
Windows Upgrade schlägt fehl (11)

Frage von ratzekahlx zum Thema Windows Installation ...

Exchange Server
Migration Exchange 2007 zu 2013 schlägt fehl (1)

Frage von zimlars zum Thema Exchange Server ...

Windows 10
Win 10 Build 1607 OEM Key Aktivierung schlägt fehl (7)

Frage von STITDK zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...