Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ARP-Request über WLAN schlägt fehl

Frage Apple

Mitglied: cney11

cney11 (Level 1) - Jetzt verbinden

29.03.2011 um 09:56 Uhr, 4926 Aufrufe, 3 Kommentare, 1 Danke

Guten Morgen,

vielleicht kann mir von euch jemand bei folgendem Problem helfen:

Ich habe einen iMac per WLAN in mein Netzwerk aufgenommen, der iMac ist auch per Ping erreichbar, jedoch habe ich ein seltsames Phänomen. Nachdem der iMac einige Zeit mit dem WLAN verbunden ist reagiert dieser nicht mehr auf Ping-Anfragen, der iMac kann jedoch von sich aus auf das Netzwerk zugreifen. Bei genauerem Hinsehen habe ich festgestellt, dass der iMac nicht mehr auf ARP-Requests antwortet, denn solange der Client noch die MAC-Zuordnung gespeichert hat funktioniert der Ping, ist die Zuordnung entfernt (weil einige Minuten keine Datenpakete versendet wurden), so geht der Ping nicht mehr durch. Erst wenn ich nun eine statische Zuordnung hinzufüge kann ich den iMac wieder anpingen.

Das ganze passiert mit zwei verschiedenen iMacs und zwei verschiedenen WLAN-APs, verwendet wird ein RADIUS-Server für die Authentifizierung am WLAN, Verschlüsselung ist WPA2.

Hat jemand eine Ahnung oder ähnliche Erfahrungen gemacht?

Viele Grüße,
cney11
Mitglied: aqui
29.03.2011 um 15:07 Uhr
Auf einen eingehenden ARP Request muss der Mac in jedem Falle antworten. Der fehler müsste dann auch analog im LAN auftauchen wenn es ein OS Bug wäre. Das ist aber stark zu bezweifeln, denn damit wäre dann kein normaler IP Traffic mehr möglich. Für einen mac recht ungewöhnlich und damit wohl auch utopisch.
Steht dann nur zu vermuten das die Authentifizierung da irgendwie Mist macht und die ARPs im WLAN nicht forwardet.
Hast du mal mit dem Wireshark geprüft ob die ARPs am Mac via WLAN Interface ankommen ?
Bitte warten ..
Mitglied: cney11
29.03.2011 um 15:12 Uhr
Ich hatte den Fehler auch erst auf den WLAN-AP geschoben, jedoch wundert es mich, dass es bei zwei verschiedenen APs passiert und dass zudem andere Geräte die am gleichen AP sind dieses Problem nicht haben. Wireshark wollte ich morgen mal auf dem iMac installiert und das überprüfen, bisher habe ich lediglich das Wireshark auf meinen Notebook getestet und festgestellt, dass die ARP Requests zwar per Broadcast rausgehen jedoch keine Antworten zurückkommen.
Bitte warten ..
Mitglied: aqui
30.03.2011 um 16:11 Uhr
Kann natürlich ein Firmware Bug sein, aber auch das wäre sehr gravierend, denn das würde eine korrekte IP Kommunikation verhindern. Sowas grundlegendes passiert nicht einmal bei dem allerbilligsten Taiwan Schrott.
Bedenke das dein AP niemals selber auch ARPs antwortet. Ein AP ist aus Netzwerk Sicht eine simple Layer 2 Bridge die diese Pakete nur forwardet aber nie selbst an der Session teilnimmt.
Die ARP Antwort sendet logischerweise immer das angesprochenen Endgerät !
Bitte warten ..
Ähnliche Inhalte
Firewall
Barracuda VPN Client - Installation schlägt fehl (3)

Frage von netzwerkschlumpf zum Thema Firewall ...

Windows 10
gelöst Windows 10 Pro Installation Hyper-V schlägt fehl (21)

Frage von Dominik-EUNES zum Thema Windows 10 ...

Windows Tools
gelöst DotNet Installation schlägt fehl (1)

Frage von emeriks zum Thema Windows Tools ...

Windows Server
TeamViewer 11 MSI Installation schlägt fehl (13)

Frage von Ghost108 zum Thema Windows Server ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (18)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...