Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

AS3: Ich verstehe nicht warum 1 nicht 1 ist!!!

Frage Entwicklung

Mitglied: B-free

B-free (Level 1) - Jetzt verbinden

04.07.2013, aktualisiert 05.07.2013, 1537 Aufrufe, 4 Kommentare, 1 Danke

Hallo Leute,

Ich habe grad son klitzekleines Problem:

01.
stop (); 
02.
 
03.
(...) 
04.
 
05.
var fest:int = 0; 
06.
 
07.
(...) 
08.
 
09.
// Entweder:  
10.
// var fest = 0; 
11.
// oder 
12.
// var fest = 1; 
13.
 
14.
(...) 
15.
 
16.
movieClip_2.addEventListener(MouseEvent.MOUSE_DOWN, fl_ClickToDrag_3); 
17.
 
18.
function fl_ClickToDrag_3(event:MouseEvent):void 
19.
20.
	movieClip_2.startDrag(); 
21.
22.
 
23.
movieClip_2.addEventListener(MouseEvent.MOUSE_UP, fl_ReleaseToDrop_3); 
24.
 
25.
function fl_ReleaseToDrop_3(event:MouseEvent):void 
26.
27.
	movieClip_2.stopDrag(); 
28.
	if (fest == 1) {  
29.
		movieClip_1.x = movieClip_2.x; 
30.
		movieClip_1.y = movieClip_2.y; 
31.
		trace ("1");                                                  // Das hier wird nie ausgespukt, egal ob er mir vorher gesagt hat, "fest=1" 
32.
33.
		 
34.
	else { 
35.
		movieClip_1.x = ausgangsPosX; 
36.
		movieClip_1.y = ausgangsPosY;		 
37.
		trace ("0");                                                  // Dafür kommt die Zeile hier immer!!! 
38.
39.
}
Ich denke mal, der Code erleutert alles ganz gut.

Trotzdem nochmal kurz:
01.
Var fest:int = 0; 
02.
(...) 
03.
var fest = 1; 
04.
(...) 
05.
if (fest==1) { 
06.
trace ("1") 
07.
08.
else { 
09.
trace ("0") 
10.
}
Er spukt aus:
01.
 0 
Bei fragen... ach ihr wisst schon.
Ich Freue mich über zahlreiche, aber vor allem gute Antworten,
Tschau

B-Free
Mitglied: Snowman25
04.07.2013, aktualisiert um 16:01 Uhr
Hallo B-free,

ActionScript hat nun wirklich nichts mit JavaScript zu tun, oder?

Du versucht, eine Variable ein 2. mal zu initialisieren (var in Zeile 3 deiner Kurzfassung).
Nimm das var weg und es sollte klappen.

Und mach doch mal das mit deinem Trace:
01.
trace("1"+ fest)
Gruß,
Snowman25
Bitte warten ..
Mitglied: B-free
05.07.2013 um 10:37 Uhr
Heyy Danke!

ActionScript hat nun wirklich nichts mit JavaScript zu tun, oder?

Hast du irgendwo in dieser langen liste mit Themenfeldern AS gesehn??? womöglich 3??? ich nicht.
;)

Ansonsten Danke für die Antwort.
Ich war das Alles nohc von BATCH gewöhnt. jedes mal "set....."

Tschau
B-free
Bitte warten ..
Mitglied: Snowman25
05.07.2013, aktualisiert um 10:41 Uhr
Entwicklung Allgemein oder Webentwicklung wären noch akzeptabel
ist dein problem gelöst? Falls ja, bitte FAQ Nr. 32 beachten. Danke
Bitte warten ..
Mitglied: B-free
05.07.2013, aktualisiert um 10:55 Uhr
sry!

Entwicklung Allgemein oder Webentwicklung wären noch akzeptabel

supi! fürs nächste mal!
(und es kommt bestimmt! )


*edit:
Es ist schon eingestellt!!! :D
Bitte warten ..
Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (20)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (19)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (17)

Frage von Pandreas zum Thema Windows Userverwaltung ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...