Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Astaro UTM SNMP Traps werden nicht versendet

Frage Netzwerke Monitoring

Mitglied: harrier21a

harrier21a (Level 1) - Jetzt verbinden

29.08.2013 um 09:58 Uhr, 3389 Aufrufe, 8 Kommentare

Hallo Community,

ich habe in meinem Heimnetzwerk eine Astaro v8 (Homelizenz) und möchte diese per SNMP überwachen.

Hatte SNMPv3 aktiviert und die UTM hat die Traps korrekt versendet. Allerdings hat mein Empfänger diese nicht korrekt verarbeitet. Habe daher testweise auf SNMPv2c umgestellt. Seit dieser Umstellung schlägt der Trapversand von Seiten der UTM fehl. Hab mitlerweile wider auf v3 gewechselt aber ohne Erfolg.

Dem System-Log der UTM ist folgende zu entnehmen:
"snmpd: send_trap: Failure in sendto (Operation not permitted)"

Laut Systemauskunft über die Konsole läuft der SNMP Dienst.

/usr/sbin/snmpd -c /etc/snmpd.conf -LSid udp:161 udp6:161


Ich wäre für hilfreiche Tips dankbar.
Mitglied: manuel1985
29.08.2013 um 10:03 Uhr
Moin,

haste die UTM mal neu gestartet?
Bitte warten ..
Mitglied: aqui
29.08.2013, aktualisiert um 10:15 Uhr
SNMPv3 erfordert eine detailierte und funktionierende Authentisierung am Trap Receiver !
Um das überhaupt erstmal sicher und einfach zu testen solltest du erstmal mit v1 oder v2 arbeiten, denn da ist die Authentisierung nicht erforderlich zum Trap Versand.
Achte darauf das deine SNMP Community sowohl am Sender als auch Empfänger stimmt.
Dann zuallererst mit einem Wireshark Sniffer checken ob die Astaro auch wirklich SNMP Traps ins Netz sendet !
Wenn das der Fall ist kannst du die z.B. mit snmptrapd und den net-snmp Tools mit einem Rasperry_Pi empfangen und verarbeiten oder was auch immer du nutzen wollst für die SNMP Daten.
Bitte warten ..
Mitglied: harrier21a
29.08.2013 um 11:41 Uhr
Die Astaro sendet definitiv keine Traps, da vor der Umstellung die gesendeten Traps im Log der UTM verzeichnet wurden.

Neustart der UTM wurde bereits durchgeführt ohne Erfolg.
Bitte warten ..
Mitglied: aqui
29.08.2013, aktualisiert um 12:08 Uhr
OK, dann ist das definitiv einzig ein Problem der Astaro !!
Da hast du dann 2 Optionen:
  • Fehlkonfiguration des SNMP Settings auf der Astaro selber
  • Bug in der Astaro Firmware. Neueste Firmware sollte eingespielt sein !! Ansonsten Bug Case mit Astaro eröffnen !
Hast du denn überhaupt mal mit den Net-SNMP Tools z.B. und einem snmpwalk -v2 -c trapname hostname mal geprüft ob die Astaro generell auf SNMP Anfragen antwortet ?
Das kostenlose Paessler SNMP Tool macht das auch grafisch: http://www.de.paessler.com/tools/snmptester
Bitte warten ..
Mitglied: Dobby
29.08.2013 um 12:30 Uhr
Hallo,

es wäre ja auch einmal nur zu nett zu wissen was Du denn genau für das Empfangen der SMNP Nachrichten benutzt!
mitunter muss man dann auch noch einen Benutzernahmen und ein Passwort angeben und/oder die Ports auf einander abgleichen!
Also nicht das Deine Astaro v8 auf 161 sendet und Dein was auch genutztes Programm immer auf Port 162 lauscht!

- Ist das eine Astaro v8 Hardware oder Softwarelösung?
- Was nutzt Du denn um die SMNP Nachrichten auszulesen bzw. zu empfangen?
- hast Du alternativ mal ein anderes Programm getestet um die SMNP Nachrichten zu empfangen?

Gruß
Dobby
Bitte warten ..
Mitglied: harrier21a
29.08.2013, aktualisiert um 12:55 Uhr
Die Astaro antwortet auf aktive SNMP anfragen.
UTM läuft als Hardware.

Habe zwei Trapreceiver im Einsatz einmal Net-SNMP im Linuxbereich, dieser soll die Traps dann weiterverarbeiten.

Testweise habe ich auf einem Windows Host einen MIB-Browser installiert, welcher einen TrapReceiver enthält.
Der MIB-Browser empfängt Traps vom Net-SNMP Client der Astaro aber keine von der UTM selbst.

Werd mal mittels WireShark checken was generell von der UTM ghesendet wird.
Bitte warten ..
Mitglied: Dobby
29.08.2013, aktualisiert um 13:00 Uhr
Versuch mal den PRTG von Paessler so wie @aqui es auch schon vorgeschlagen hat, der bringt einen MIB Konverter mit
und ist auch bis 10 Sensoren kostenlos!

Gruß
Dobby

UTM läuft als Hardware.
Und was heißt das jetzt?
Hast Du ein Gerät von Astaro gekauft oder nur Software von denen auf eigener Hardware installiert?
Der Unterschied ist für gekaufte Hardware gibt es meistens MIB Dateien, für die Software mitunter aber eher selten!
Bitte warten ..
Mitglied: harrier21a
29.08.2013, aktualisiert um 15:29 Uhr
Hatte den PRTG von Prässler bereits im Einsatz doch er ist für unsere Anforderungen icht geeignet, hab aktuell Icinga in Kombination mit EventDB.
Wenn Net-SNMP bereits keine Traps bekommt kann EventDB auch nicht abrufen.

Laut Wireshark meldet der Trapsender:

"Privkey unknown"

Die logs der UTM melden mir ebenfalls "authentication failed"

Habe die Keys kontrolliert und sie stimmen überein.

Hab momentan testweise auf SNMPv2c umgestellt und die Traps kommen korrekt an.
Bitte warten ..
Ähnliche Inhalte
Monitoring
gelöst SNMP Traps gehen nicht (mehr) (4)

Frage von Ex0r2k16 zum Thema Monitoring ...

Firewall
gelöst Welche Sophos UTM Hardware? (11)

Frage von Freak-On-Silicon zum Thema Firewall ...

Router & Routing
gelöst Sophos UTM hinter Fritzbox 7390 (4)

Frage von eegg125 zum Thema Router & Routing ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(8)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Heiß diskutierte Inhalte