Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Der Aufruf eines ELORulesets scheint nicht korrekt abzulaufen, was dazu führt das der ELOas beim entsprechnden Ruleset den Status (Wait...) nicht verlässt

Frage Entwicklung JavaScript

Mitglied: Mesaou

Mesaou (Level 1) - Jetzt verbinden

17.06.2013, aktualisiert 18.06.2013, 3542 Aufrufe

Ich habe in den letzten Wochen mehrfach das Beispiel-Archiv aus dem Online HowTo im ELO importiert (jeweils in einem frischen Archiv) leider funktioniert es trotzdem nicht. Ich habe mir natürlich auch die ganzen Scripte mal angeschaut und diese nach Anleitung geändert. Als das nicht den gewünschten Erfolg gebracht hat habe ich mir kleine Messageboxen eingefügt um zu testen an welche Stellen des Skripts ich komme. Manche der essentiellen Stellen werden nicht erreicht. Ich habe die Vermutung dass es irgendwas mit der open(cmd,url,true) Funktion zu tun hat

In meinem Fall sieht dass dann so aus:

function createRequest(ruleset, param1, param2, param3, handler) {
var name = (handler != null && typeof handler === 'function') ? extractName(handler) : "default";
try {
request[name] = new XMLHttpRequest();
} catch (e){
try{
request[name] = new ActiveXObject("Msxml2.XMLHTTP");
} catch (e){
request[name] = null;
}
}

if (request[name] == null) {
alert("Error creating request object!");
} else {
var url = ELO_PARAMS.ELOAS_PATH + "?cmd=get&name=" + ruleset + "&" + "param1=" + param1 + "&" + "param2=" + param2 + "&" + "param3=" + param3;
request[name].open("GET", url, true); hier ist der Aufruf der open()-Funktion
request[name].onreadystatechange = (handler != null && typeof handler === 'function') ? handler : handleRequest;
if(name == "default") {
asreq = request[name];
}
request[name].send(null);
}
}
Die Variablen "ruleset" und "param 1"(-3) werden der Funktion übergeben

Die entstehende url lasse ich mir ausgeben (http:*Servername*:*Port*/as-*Archivname*/as?cmd=get&name=UrlaubsantragDB&param1=&param2=9&param3=). Servername, Port und Archivname sind korrekt, die UrlaubsantragsDB ist das Ruleset, das in der Theorie die Daten für die Felder liefern soll ... wie gesagt in der Theorie. Wenn ich den ELO-Admin Application Server öffne und mir anschaue was der ELOas gerade macht hat mein Urlaubsantrag folgende Einträge:

Excecuted Name Next Run Run Status
27 Urlaubsantrag *hier steht ne Zeitangabe* Stop

0 Kalender Trigger Direct
4 UrlaubsantragDB Trigger Direct Wait...
Ich weiß nicht auf was das Ruleset "UrlaubsantragDB" wartet, vermute aber, dass hier das Problem liegen könnte da ja erst wenn das Ruleset "fertig" ist die Wertte korrekt eingetragen werden. Hatte jemand von euch schon mal das Problem und kennt eine Lösung? (Ich freue mich genauso über Lösungen von euch wenn ihr das Problem noch nicht hattet)
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
gelöst Freigabe führt nicht zur Schreib-Berechtigung (11)

Frage von ElmaCx zum Thema Windows Server ...

Windows Server
gelöst Clients erhalten keine Updates obwohl WSUS "korrekt" konfiguriert (11)

Frage von takvorian zum Thema Windows Server ...

Windows Netzwerk
gelöst PC scheint in Domäne zu sein, ist es aber laut Eventlog nicht wirklich (5)

Frage von psch1991 zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...