Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Der Aufruf eines ELORulesets scheint nicht korrekt abzulaufen, was dazu führt das der ELOas beim entsprechnden Ruleset den Status (Wait...) nicht verlässt

Frage Entwicklung JavaScript

Mitglied: Mesaou

Mesaou (Level 1) - Jetzt verbinden

17.06.2013, aktualisiert 18.06.2013, 3582 Aufrufe

Ich habe in den letzten Wochen mehrfach das Beispiel-Archiv aus dem Online HowTo im ELO importiert (jeweils in einem frischen Archiv) leider funktioniert es trotzdem nicht. Ich habe mir natürlich auch die ganzen Scripte mal angeschaut und diese nach Anleitung geändert. Als das nicht den gewünschten Erfolg gebracht hat habe ich mir kleine Messageboxen eingefügt um zu testen an welche Stellen des Skripts ich komme. Manche der essentiellen Stellen werden nicht erreicht. Ich habe die Vermutung dass es irgendwas mit der open(cmd,url,true) Funktion zu tun hat

In meinem Fall sieht dass dann so aus:

function createRequest(ruleset, param1, param2, param3, handler) {
var name = (handler != null && typeof handler === 'function') ? extractName(handler) : "default";
try {
request[name] = new XMLHttpRequest();
} catch (e){
try{
request[name] = new ActiveXObject("Msxml2.XMLHTTP");
} catch (e){
request[name] = null;
}
}

if (request[name] == null) {
alert("Error creating request object!");
} else {
var url = ELO_PARAMS.ELOAS_PATH + "?cmd=get&name=" + ruleset + "&" + "param1=" + param1 + "&" + "param2=" + param2 + "&" + "param3=" + param3;
request[name].open("GET", url, true); hier ist der Aufruf der open()-Funktion
request[name].onreadystatechange = (handler != null && typeof handler === 'function') ? handler : handleRequest;
if(name == "default") {
asreq = request[name];
}
request[name].send(null);
}
}
Die Variablen "ruleset" und "param 1"(-3) werden der Funktion übergeben

Die entstehende url lasse ich mir ausgeben (http:*Servername*:*Port*/as-*Archivname*/as?cmd=get&name=UrlaubsantragDB&param1=&param2=9&param3=). Servername, Port und Archivname sind korrekt, die UrlaubsantragsDB ist das Ruleset, das in der Theorie die Daten für die Felder liefern soll ... wie gesagt in der Theorie. Wenn ich den ELO-Admin Application Server öffne und mir anschaue was der ELOas gerade macht hat mein Urlaubsantrag folgende Einträge:

Excecuted Name Next Run Run Status
27 Urlaubsantrag *hier steht ne Zeitangabe* Stop

0 Kalender Trigger Direct
4 UrlaubsantragDB Trigger Direct Wait...
Ich weiß nicht auf was das Ruleset "UrlaubsantragDB" wartet, vermute aber, dass hier das Problem liegen könnte da ja erst wenn das Ruleset "fertig" ist die Wertte korrekt eingetragen werden. Hatte jemand von euch schon mal das Problem und kennt eine Lösung? (Ich freue mich genauso über Lösungen von euch wenn ihr das Problem noch nicht hattet)
Ähnliche Inhalte
Python
gelöst Python 2.6 oder 3.6 wer führt aus? (2)

Frage von peterpa zum Thema Python ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (18)

Frage von montylein1981 zum Thema Windows Server ...

Webbrowser
Firefox - Seitenquelltext anzeigen führt zur Startseite (1)

Frage von imebro zum Thema Webbrowser ...

Monitoring
gelöst Smartmontools - Aufruf per Kommandozeile - Übergabe an Zabbix (4)

Frage von Knorkator zum Thema Monitoring ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit Shorewall, ISC-DHCP Server konfigurieren für Android Devices (24)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Hardware
16-20 Port POE Switch mit VLAN (16)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
Exchange HyperV Prozessorlast (16)

Frage von theoberlin zum Thema Windows Server ...