Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ausführung von xcopy.exe mit system() aus PHP5 unter IIS6 nicht möglich.

Frage Entwicklung PHP

Mitglied: datasearch

datasearch (Level 2) - Jetzt verbinden

11.02.2010, aktualisiert 13:27 Uhr, 3706 Aufrufe

Hallo Forum,

ich habe hier eine Anforderung via Weboberfläche neue Ordner auf einigen Servern anzulegen. Leider gibt die Funktion

01.
<? 
02.
system("c:\\windows\\system32\\xcopy.exe /E /I /H /K /O ordnervorlage1 test1") 
03.
?>
nichts zurück. Versuche ich andere Programme, zum Beispiel c:\windows\system32\mem.exe kann ich die Ausgabe korrekt sehen. Das Kopieren von Dateien mit dem cmd.exe eigenem "copy" Befehl funktioniert problemlos. Gibt es eine Art Schutzfunktion die verhindert das bestimmte Programme ausgeführt werden können? Eine cmd.exe mit dem Parameter /C [befehl] habe ich auch bereits versucht. exec und shell_exec reagieren identisch.

Die Website läuft in einem getrennten AppPool. Für den Pool wurde ein Benutzer angelegt der entsprechende Rechte zum kopieren der Vorlage und zum Lesen der entsprechenden Systemordner hat. Die Absicherung erfolgt über IP-Einschränkungen auf dem virtuellen Host. Der Server selbst ist nur intern erreichbar. PHP läuft als ISAPI-Erweiterung in der Version 5.2.10. eine Aktualisierung ist derzeit leider noch nicht möglich. Die Plattform ist Windows Server 2003R2 SP2 Standard Edition, Hotfix-Stand 01.02.2010.

Warum das Ganze? Das System muss Ordner basierend auf Vorlagen mit relativ komplexen Rechtestrukturen über eine Weboberfläche auf mehreren Servern in verschiedenen Domänen anlegen können.


Wer kann helfen? Es muss auch nicht zwingend in PHP umgesetzt werden.
Ähnliche Inhalte
Windows Userverwaltung
Java Ausführung nur als lokaler Admin möglich?
gelöst Frage von crack24Windows Userverwaltung1 Kommentar

Hallo, ich habe hier eine Mitarbeiterin, die über ein Java Applet von der IHK Website diverse Azubi Anmeldungen erledigen ...

Apache Server
Ubuntu Apache2 MySQL PHP5 .
gelöst Frage von KaStarkerApache Server11 Kommentare

Hallo Leute, ist unter Euch jemand, der sich mit den Themen wirklich gut auskennt? Ich benötige asap jemanden der ...

Batch & Shell
Probleme bei der Ausführung eines VB-Scriptes
Frage von AuricGoldfingerBatch & Shell1 Kommentar

Hallo zusammen, ich habe folgendes Script geschrieben: Leider bekomme ich bei der Ausführung den Fehler Was mache ich falsch?? ...

Windows 7
OEM-System - Systemabbild wiederherstellen nicht möglich
Frage von erich-JWindows 717 Kommentare

Hallo, ich habe einen Panasonic CF-53 und habe mir gerade alle Programme und co installiert und anschließend ein Systemabbild ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 StundeWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 2 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 14 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 20 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...