Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sie können nicht zu dem ausgewählten Datensatz springen

Frage Microsoft Microsoft Office

Mitglied: Maik87

Maik87 (Level 2) - Jetzt verbinden

18.12.2006, aktualisiert 20.12.2006, 4035 Aufrufe, 4 Kommentare

Hallo Kollginnen, hallo Kollegen,

ich brauch mal wieder eure Hilfe. Ich habe letzte Woche eine Datenbank zusammengebastelt (1 Tabelle, 1 Abfrage zur Filterung, 2 Formulare). Diese lief auch 1A. Seit heute Morgen erscheint jedoch die o.g. Fehlermeldung, wenn ich ein Formular öffne. Die Formulare beziehen sich auf die Abfrage. Ändere ich es auf die Tabelle, so läuft es, jedoch fehlen mir dann die Filterungen.

Habe schon gegoogelt, da steht ich soll komprimieren und reparieren machen - bringt nix.

Erstelle ich das Formular neu, läuft es paar mal, dann ist wieder schluss.


Danke für eure Mühen!!
Mitglied: Biber
18.12.2006 um 19:07 Uhr
Moin Maik,

das Problem wird sein, dass Du zu dem Zeitpunkt, wenn Du in dem Formular den Filter setzt, Dich in der Tabelle manchmal auf einem Satz befindest, der nicht im Filter enthalten ist.

Du musst dich also in der Tabelle "bewegen" mit rs.skip(0) oder ähnlichem.

Vielleicht hast Du noch irgendwo einen expliziten Verwis auf den "Satz 1" der Tabelle drin.

Wir sollten mal den Ablauf an der Stelle näher beleuchten.

Und ggf. dein Filter-Statement mal sezieren.

Gruß
Biber
Bitte warten ..
Mitglied: Maik87
18.12.2006 um 22:29 Uhr
Hallo Biber,

danke für deine Antwort. Ich filtere ja in einer Abfrage und nehme dieses Ergebnis erst in das Formular, falls das was zum Problem beitut. Die Synthome treten auf, wenn ich nach Datensätzen filtere die es gibt unddie es nicht gibt. Also immer!!
Bitte warten ..
Mitglied: Maik87
19.12.2006 um 08:52 Uhr
Hallo,
neues Problem!! Ich kann in meiner Abfrage keine Datensätze mehr hinzufügen.Die Zeile ist weg und das Symbol inaktiv.

Was hab ich wieder getan??

Gibts nicht Access auch für Linux, vllt komm ich da besser mit klar
Bitte warten ..
Mitglied: Maik87
20.12.2006 um 09:59 Uhr
Sache ist bereinigt, aber danke für die Hilfe.

Die Abfrage selbst machte mucken, ich konnte also keine Datensätze hinzufügen, weil ich ein paar aus der Tabelle gelöscht hatte, und jetzt nur noch unsaubere drinwaren (durch Eingaben ohne den Standartwert, der automatisch in bestimtme Felder gesetzt werden sollte). Habe die dann also mal rausgehauen, zwei manuell sauber reingemacht und es geht wieder!
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Microsoft Office
Serienbrief Nächster Datensatz Wenn (2)

Frage von Druide83 zum Thema Microsoft Office ...

Microsoft Office
Excel 2007: Sortierung ohne ins Datenblatt zu springen (2)

Frage von JoSiBa zum Thema Microsoft Office ...

Datenbanken
gelöst Datensatz hinzufügen, nicht überschreiben Access (19)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...