Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Authentifizierung über Telnet und AUTH NTLM funktioniert nicht

Frage Internet

Mitglied: speedy05

speedy05 (Level 1) - Jetzt verbinden

10.05.2010, aktualisiert 11:50 Uhr, 10679 Aufrufe, 9 Kommentare

Hallo,

ich habe eine Grundsätzliche Frage.

Wir haben bei uns einen Exchange Server 2003 und ich möchte per Telnet eine email über diesen versenden.
Ich mache folgendes:
telnet exchangeserver 25

220 exchangeserver Microsoft ESMTP MAIL Service ready at Mon, 10 May 2010 10:20:21 +0200
ehlo localhost
250-exchangeserverl Hello [192.168.1.84]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250 XRDST

AUTH NTLM ??????????????

So und jetzt sitze ich fest.

Was genau b.z.w. wie muß ich mich hier anmelden?
Den Benutzername in der Domäne (user@test.de) und dann dass Kennwort ? Getrennt durch ??

Das ganze mit Base64 verschlüsseln ist klar.

Ich habe bisher immer nur gelesen wie das über AUTH LOGN geht.
Das möchte ich aber gar nicht auf unseren Exchange Server umstellen. Oder geht das gar nicht über diesen Weg ?

Für jede Hilfe bin ich dankbar
Mitglied: aqui
10.05.2010 um 10:46 Uhr
Versuchs mal so:
telnet mail.exchange.de 25

HELO microsoft.com

MAIL FROM: <bill.gates@microsoft.com>

RCPT TO: <speedy05@exchange.de>

DATA

Subject: Mail per Telnet
Hi,

Das ist ein Test mit Telnet Mail
. (Punkt muss ein !)

quit

...das sollte dann klappen...
Bitte warten ..
Mitglied: speedy05
10.05.2010 um 10:57 Uhr
Hi,

das löst mein Problem leider nicht.
Der Exchange Server will unbedingt eine Identifizierung haben:

mail from: test@domäne.de
530 5.7.1 Client was not authenticated

Ist ja auch in Ordnnung, aber wie bekomme ich das mit AUTH NLTM hin ?

Muß doch irgendwie gehen. Wir haben bei uns auch mehrere Multifunktionsgeräte stehen, mit denen wir
auch eingescannte Dokument über diesen Exchange Server senden. Da haben wir auch Benutzer und Kennwort eingeben. (über ein Web-Interface)
Die müssen dann doch in ihren Programm das auch irgendwie über NTLM verarbeiten.
Bitte warten ..
Mitglied: GuentherH
10.05.2010 um 11:02 Uhr
Hallo.

Ist ja auch in Ordnnung, aber wie bekomme ich das mit AUTH NLTM hin ?

Glaube es mir, über Telent willst du das sicher nicht machen

Da haben wir wir auch Benutzer und Kennwort eingeben

In welcher Form habt ihr die Authentifizierung eingegeben. Korrekt wäre Domain\User

LG Günther
Bitte warten ..
Mitglied: aqui
10.05.2010 um 11:10 Uhr
Wenn dein RCPT Client aus der gleichen Domäne kommt wie den Exchange sollte es auch ohne Auth klappen...
Bitte warten ..
Mitglied: speedy05
10.05.2010 um 11:18 Uhr
Hallo,

habe schon alles probiert:

test.@domäne.local --> Dömänenbenutzer
test.test@domäne.de --> email Account

domäne.local\testuser ---> Base64: ZG9t5G5lLmxvY2FsXHRlc3R1c2Vy

Ich glaube da muß auch irgendwie das Kennwort mit in diese Zeile einfügen - getrennt duch ?
Im augenblik sieht es so aus:

auth ntlm ZG9t5G5lLmxvY2FsXHRlc3R1c2Vy
535 5.7.3 Authentication unsuccessful


oder so:

auth ntlm
334
ZG9t5G5lLmxvY2FsXHRlc3R1c2Vy
535 5.7.3 Authentication unsuccessful
Bitte warten ..
Mitglied: GuentherH
10.05.2010 um 17:29 Uhr
Hallo.

Du sollst nicht mit Telnet herum experimentieren, da kommst du nicht weit, lass dir das einfach sagen.

Gib den korrekten Benutzernamen mit Passwort beim Scanner ein. Wenn der User etwas "krux" angelegt wurde, dann versuche es mit folgendem Syntax bei der Authentifizeirung:

Domain\Benutzeranmeldename\Postfach

wobei der

Benutzername = Benutzeranmeldename (Prä-Windows 2000)
Postach = ExchangeAlias

wenn es dann immer noch nicht geht, dann kannst du immer noch im virtuellen SMTP die IP des Drucker für den SMTP Zugriff frei schalten.

LG Günther
Bitte warten ..
Mitglied: speedy05
11.05.2010 um 10:06 Uhr
Hallo,

beim Scanner geht es ja. Das ist nicht das Problem. Hier ist der Benutzer und das Kennwort eingetragen und er sendet auch fleißig die emails.

Wir haben hier eine andere Schnittstelle, mit der wir emails versenden wollen, ohne eine zusätzliche Software.
Mit anderen Tools habe ich es ja auch hinbekommen und dort habe ich auch nur Benutzer und Kennwort eingegeben. (ohne Domäne - ohne Postfach)
Dort muß es doch auch irgendwie verarbeitet werden.

Es muß doch auch über auth ntlm gehen (Wozu gibt es das sonst überhaupt). Google mich irgendwie schon tot und kann nicht glauben dass das keiner weiß.
Am Ende ist es wieder so einfache und man ägert sich tot..

Ich möchte eigentlich nicht den virtuellen SMTP freischalten, wenn es auch anders geht.

Hat nicht noch einer eine Idee ?


Gruß


Speedy
Bitte warten ..
Mitglied: speedy05
11.05.2010 um 11:24 Uhr
Habe jetzt noch eine Seite gefunden:
http://www.maxim-ic.com/app-notes/index.mvp/id/4015
Das bezieht sich wohl aber auf POP3 und ich liege hier wohl etwas falsch oder ? kann es sein das AUTH NTLM nur für POP3 ist ?

Habe das mal ausprobiert: AUTH NTLM eingegeben und dann folgendes:
TlRMTVNTUAABAAAAB7IAAAUABQAgAAAABQAFACUAAABzZWVuaXNlZW5p und der Server antwortet mit :

TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAA8ADwBwAAAACgAKAH8AAAAKAAoAiQAAAAUABQCTAAAABwICAFadILoghkFeli66HycIYmjpnmm6XToht7yzrLzrNb8CV7gLSwRScY1FQQ86d+hWnm1haWwuZG9tYWluLmNvbXMAZQBlAG4AaQBzAGUAZQBuAGkAZHVtbXJ

Wenn ich das Erste mit BASE64 decodiere kommt folgendes raus: NTLMSSP² %seeniseeni
Beim Zweiten NTLMSSP@Xp  ‰“V º †A^–.º'bhéžiº]:!·¼³¬¼ë5¿W¸ KRqEA:wèVžmail.domain.comseeniseenidummr

Kann da jemand was mit anfangen ?

Gruß

Speedy
Bitte warten ..
Mitglied: speedy05
17.05.2010 um 09:12 Uhr
Hallo,

keiner eine Idee ?


Gruß

Speedy
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Telnet auf Switch funktioniert nicht
Frage von 118400Netzwerke9 Kommentare

Ich möchte mittels Telnet auf einen Switch zugreiffen. Ich bekomme jedoch immer den folgenden Fehler: es konnte keine verbindung ...

Exchange Server
Exchange 2007 - Windows-Authentifizierung (NTLM) nicht mehr möglich (EWS, Autodiscover und Anywhere)
Frage von ribiku.sithExchange Server16 Kommentare

Hallo mal wieder in die Runde, erstmal einen guten Morgen, hatte ja vor kurzem dieses Problem: Was zwar wie ...

Windows Netzwerk
NTLM in Domäne deaktivieren
Frage von StefanK007Windows Netzwerk

Hallo, wir haben vor Kurzem unsere Windows 2008 R2 Domänencontroller durch Windows 2012 R2 DCs ersetzt und schauen nun ...

Outlook & Mail
Outlook Netzwerksicherheit NTLM verstellt sich immer wieder
Frage von pastorOutlook & Mail

Hallo ich bräuchte mal etwas hilfe ;-) Folgende Umgebung vorhanden: - Server 2008 - Exchangeserver 2010 Client: - Outlook ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 4 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 8 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 8 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 11 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...