Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Autodiscover - virtuelles IIS verzeichnis neu erstellen

Frage Microsoft Exchange Server

Mitglied: Cardinal

Cardinal (Level 1) - Jetzt verbinden

06.10.2010 um 13:08 Uhr, 18274 Aufrufe, 7 Kommentare, 1 Danke

Hallo zusammen,

da es mit Exchange 2010 Standard leider Probleme mit Autodiscover (Out of Office) gab, die sich nicht mit DNS einträgen, URL Korrekturen oder korrekten ZErtifikaten lösen ließen, habe ich versucht das Verzeichnis zu entfernen, und wieder neu zu erstellen.

Entfernen:
01.
[PS] C:\Windows\system32>Remove-AutodiscoverVirtualDirectory -Identity "SERVER1\Autodiscover (Default Web Site)"
Neu erstellen:
01.
 [PS] C:\Windows\system32>New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -WindowsAuthentication $true - 
02.
BasicAuthentication $true
Leider erhalte ich folgende Fehlermeldung, an der ich nun seit 5 Stunden verzweifle. Ich bekomme das Verzeichnis nicht wieder erstellt:

01.
Das Active Directory-Objekt für das virtuelle Verzeichnis 'IIS://SERVER1.local.domain.com/W3SVC/1/ROOT/Autodisco 
02.
ver' auf 'SERVER1' konnte nicht erstellt werden. Möglicherweise ist es bereits in Active Directory vorhanden. Entferne 
03.
n Sie das Objekt aus Active Directory, und erstellen Sie es anschließend neu. 
04.
    + CategoryInfo          : InvalidOperation: (SERVER1\Autodiscover (Default Web Site):ADObjectId) [New-Autodiscove 
05.
   rVirtualDirectory], InvalidOperationException 
06.
    + FullyQualifiedErrorId : 804814BA,Microsoft.Exchange.Management.SystemConfigurationTasks.NewAutodiscoverVirtualDirectory
Das es leider nicht viel personen gibt, die davon im Internet berichteten, und keiner, der eine für mich adäquate Lösung dafür hatte, wende ich mich an euch.

Es handelt sich um einen Exchange Server 2010 Standard, in einer 2-Server DAG, unter Windows-Server 2008R2 Enterprise.

Ich hoffe sehr das ihr mir einen Tip geben könnt wie ich Autodiscover wieder in IIS bekomme.

Danke!
Mitglied: hengel
25.01.2011 um 11:58 Uhr
Hallo,
ich hatte ein ähnliches Problem. Bis auf die AD Fehlermeldung war es das gleiche.
Bei mir war dies, warum auch immer eine Fehlerhafte .Net4 Installation. Habe .Net4 neu installiert und schon lief es. Denk nur dran das die DCs einen Moment brauchen um zu kapieren das du das Verzeichnis neu erstellt hast.

Gruß
Bitte warten ..
Mitglied: Cardinal
25.01.2011 um 12:03 Uhr
Hallo,

danke für die Rückmeldung.
Ich habe das Problem in meinem Fall inzwischen durch manuelles anlegen der Verzeichnisse und Pfade lösen können.

.Net Framework 4 kommt in meiner Umgebung nicht zum Einsatz.
Bitte warten ..
Mitglied: 85807
04.04.2011 um 22:51 Uhr
Hallo,
Schon zwar etwäs älter, aber kann mir wer posten wie er das manuell gemacht hat!? Gibts da was von MIcrosoft :D
Bitte warten ..
Mitglied: Cardinal
11.04.2011 um 08:13 Uhr
Sorry das habe ich leider nicht dokumentiert, und daher vergessen :s

Da es sich um eine DAG aus 2 Servern handelte habe ich aber einfach den zweiten Server als Vorlage genommen, und mir dort die IIS Ordner und Apps sowie Einstellungen abgeschaut.

Microsoft lässt einen bei der Problematik in dieser Konstellation afaik leider im Stich. Aber villeicht hat sich da in den letzten Monaten ja noch etwas getan.
Ich habe ohnehin immer das Gefühl, dass ich sehr viele Windows Fehler als erster Mensch auf dem Planeten entdeckt habe
Bitte warten ..
Mitglied: hengel
11.04.2011 um 09:35 Uhr
Öffne die "Exchange management Shell" und gib folgnden Befehl ein.

New-AutodiscoverVirtualDirectory (Einfacher geht's wenn du New-Auto eingibst und die TAB Taste drückst, dann verfolständigt er den Befehl automatisch)

Ein weiterer fehler der bei mir im zusammenhang mit Autodiscover aufgetreten ist war: fehler hafte SSL Konfiguration im IIS. Ich hatte die Einstellungen auf "Client Zertifikate akzeptieren" es muss aber "Client Zertifikate Ignorieren" sein.

Gruß Holger
Bitte warten ..
Mitglied: fxsession
14.11.2012, aktualisiert um 14:15 Uhr
Hallo!

Ich möchte auch den autodiscover-Eintrag im ISS erstellen da dieser unter "Default Web Site" nicht vorhanden ist. Beim Ausführen des Befehls "New-AutodiscoverVirtualDirectory" erscheint jedoch folgende Ausgabe:

New-AutodiscoverVirtualDirectory : Das virtuelle Verzeichnis 'Autodiscover' ist bereits unter 'server.domain.local/Default Web Site' vorhanden.


Ist dies ein bekannter Bug im ISS7?
Bitte warten ..
Mitglied: Dirk.J
16.05.2013, aktualisiert um 18:16 Uhr
Wir hatten gerade bei der letzten Migration (SBS2003->SBS2011) das gleiche Problem.

Entfernen mit:
Remove-AutodiscoverVirtualDirectory -Identity "SERVER1\Autodiscover (Default Web Site)"
funktionierte.

Neuanlegen aber nicht.

Lösung:
IIS Metabase Explorer starten und unter:
W3SVC/1/ROOT/ schauen, ob Autodiscover noch drin steht. Wenn ja, umbenennen.

Dann mit:
New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -WindowsAuthentication $true
neu erzeugen.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
IIS Fehler beim Autodiscover Test
Frage von Michael2812Exchange Server1 Kommentar

Hallo, habe ein kleines Problem. System: WindowsServer 2008 R2 Enterprise, Exchange 2010 und IIS 6. Beim Test des Autodiscover ...

Microsoft
Mit VBA-Code ein Verzeichnis erstellen
gelöst Frage von DockMaster-deMicrosoft2 Kommentare

Hallo, ich habe mit MS Access 2010 eine Datenbank und ein Frontend. Daten werden über ein Formular eingegeben. Ich ...

Windows 8
Virtuelle Laufwerke lassen sich nicht erstellen
Frage von ShinubariaWindows 88 Kommentare

Moin liebe Community Seit ich Win 8 auf meine Laptop habe, wird mir mein Laufwerk nichtmehr angezeigt. Dieses Problem ...

Virtualisierung
Technologie zum erstellen von virtuellen Prozessoren?
gelöst Frage von M.MarzVirtualisierung10 Kommentare

Hallo zusammen, wie nennt man die Technologie, die es einem CPU ermöglicht virtuelle Prozessoren zu erstellen? Zb. kann ein ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser7 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 3 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...