Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Autofilter liefert kein Ergebnis

Frage Entwicklung VB for Applications

Mitglied: Maik87

Maik87 (Level 2) - Jetzt verbinden

22.09.2010 um 09:51 Uhr, 3909 Aufrufe, 5 Kommentare

Hallo zusammen,

folgendes Problem:

Ich setze mit folgender Zeile einen Autofilter in eine externe Exceltabelle:

.Cells(1, 1).AutoFilter Field:=SpaltePersNrVergWoche + 1, Criteria1:="#NV"

Wenn ich nun in die Tabelle schaue, sehe ich, dass ein Autofilter gesetzt ist, der aber keine Ergebnisse liefert. Wenn ich nun den Filter öffne, mir unter Benutzerdefiniert die Einstellungen ansehe, ist alles ok. Drücke ich jetzt auf OK OHNE Änderungen vorzunehmen, so krieg ich mein gewünschtes Ergebnis.

Was ist hier los?
Mitglied: ShitzOvran
22.09.2010 um 10:05 Uhr
evtl, weil du kein Wert hast der "#NV" ist...

versuch einfach mal nicht das Kriterium ="#NV" sondern suche nach "#N/A" , wenn du nach errors suchst.
Bitte warten ..
Mitglied: Maik87
22.09.2010 um 10:08 Uhr
Hey,

"#NV" ist definitiv vorhanden. Hab ich sogar zum Test extra von Hand eingebaut. Mit "#N/V" funktioniert es garnicht. Dann bekomme ich selbst bei dem Neuaufruf von Hand kein Ergebnis.
Bitte warten ..
Mitglied: ShitzOvran
22.09.2010 um 10:09 Uhr
soll ja auch "#N/A" sein

ansonsten könnte es noch an deiner Fieldbezeichnung liegen... was is denn, wenn du "Field:=2" oder sowas eingibst?
Bitte warten ..
Mitglied: Maik87
22.09.2010 um 10:23 Uhr
SpaltePersNrVergWoche ist einfach eine Variable, die 10 enthält. Wird also Field 11 angesprochen. Funtzt eig. auch, weil ja, wenn ich von Hand gucke im richtigen Feld der richtige Filterwert eingetragen ist. Es kommt halt nur nichts beim Filtern raus. Wenn ich den Filter von Hand öffne und schließe klappts.

Filter ich nach "1130" funtzt es. Muss also wirklich an dem Wert "#NV" liegen.
Bitte warten ..
Mitglied: Maik87
22.09.2010 um 10:51 Uhr
"#N/A" war es, DANKE!!

Aber schon toll, dass "#NV" zwar richtig als "#NV" übernommen wird, aber erst ausgeführt, wenn man es von Hand "startet".
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
Outlook Suche liefert kein Ergebnise mehr (9)

Frage von Bjoern-B zum Thema Outlook & Mail ...

Windows Server
gelöst Suche liefert keine Ergebnisse - SharePoint Foundation 13 (1)

Frage von erdmelone zum Thema Windows Server ...

Neue Wissensbeiträge
Viren und Trojaner

Link: Neues Botnetz über IoT-Geräte

Information von certifiedit.net zum Thema Viren und Trojaner ...

Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
Frage zu Server Rack (11)

Frage von rainergugus zum Thema Windows Server ...

Windows Installation
Windows 10 neu installieren (10)

Frage von imebro zum Thema Windows Installation ...

Switche und Hubs
gelöst VLAN für Gäste WLAN einrichten über FritzBox und Switch (10)

Frage von Elo-14 zum Thema Switche und Hubs ...