Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Automatische Anmeldung an OWA

Frage Entwicklung HTML

Mitglied: geTuemII

geTuemII (Level 3) - Jetzt verbinden

01.04.2009, aktualisiert 10:31 Uhr, 10028 Aufrufe, 6 Kommentare

Kalenderzugriff über OWA auf meinem Kiosk-System läuft plötzlich nicht mehr

Hallo @all,

ich habe seit langem einen Kioskrechner mit SteadyState in einem zentralen Bereich stehen. Hier können die Mitarbeiter z.B. nachmal schnell nachsehen, welchen Besprechungsraum oder Geschäftswagen sie gebucht haben oder auch direkt buchen. Zu diesem Zweck nutze ich OWA mit automatischem Login nach diesem Beitrag.

Seit kurzen/einiger Zeit funktioniert das nicht mehr. Da ich solcherlei Fehler nicht unbedingt zeitnah erfahre, kann ich nicht sagen, ob da ein evtl. MS-Update reinlangt.

Mein Script sieht so aus:

01.
  
02.
<html> 
03.
   <head> 
04.
   	<title>Gesch&auml;ftswagen</title> 
05.
      <script language="javascript"> 
06.
         function anmelden(){ 
07.
            window.document.logonForm.submit(); 
08.
09.
      </script> 
10.
   </head> 
11.
   <body onload="anmelden()"> 
12.
      <form action="https://fqn-servername/exchweb/bin/auth/owaauth.dll" method="POST" name="logonForm"> 
13.
         <input type="hidden" name="destination" value="https://fqn-servername/exchange/auto/kalender/?cmd=contents"> 
14.
         <input type="hidden" name="flags" value="0"> 
15.
         <input type="text" name="username" value="auto"> 
16.
         <input type="password" name="password" value="autopassword"> 
17.
         <input type="submit" value="Anmelden" name="SubmitCreds"> 
18.
         <input checked type="radio" name="trusted" value="0"> 
19.
         <input name="trusted" type="radio" value="4"> 
20.
      </form> 
21.
   </body> 
22.
</html>
Momentan stochere ich im Finstern. Hat jemand von euch eine Idee?

Gruß, geTuemII
Mitglied: godlie
01.04.2009 um 13:10 Uhr
Hm welcher exchange? ne version wär evtl brauchbar
Bitte warten ..
Mitglied: geTuemII
01.04.2009 um 13:26 Uhr
Microsoft Exchange Server 2003 SP2 Version: 6.5.7638.1
Bitte warten ..
Mitglied: godlie
01.04.2009 um 13:42 Uhr
Kannst du mir bitte mal den Quelltext der Anmeldeseite zukommen lassen?
Also von der vom OWA selbst am besten per pn.
Bitte warten ..
Mitglied: geTuemII
01.04.2009 um 15:49 Uhr
Am Quelltext der OWA wurden keinerlei Änderungen vorgenommen, ist als ganz normaler 2003er Standard.
Bitte warten ..
Mitglied: Pedant
01.04.2009 um 21:56 Uhr
Hallo ge TuemlII,

auf Deine Bitte hin habe ich mir mein altes und Dein aktuelles Skript noch mal angesehen.
Allein aus den Skript ist nicht zu erkennen warum es nicht mehr funktionieren sollte.

Da der Rechner auf dem es läuft "SteadyState" ist, ist die Ursache eher beim Server zu suchen.
Mit Exchangeservern kenne ich mich leider gar nicht aus.
Mein damaliger Lösungsansatz war sehr allgemein entwickelt und hat offenbar auch beim Exchangeserver funktioniert.

Ist denn die Kombination "auto" / "autopassword" denn noch ein gültiger Login?
Vielleicht scheitert es ja nur daran, dass die Rechte abgelaufen sind oder sowas in der Art.

Gruß Frank
Bitte warten ..
Mitglied: geTuemII
02.04.2009 um 14:59 Uhr
Hallo alle miteinander,

ich vermelde hiermit Vollzug, es läuft wieder.

Nachdem ich nun meine Zähne auch wieder aus der Tischkante gepult habe, hier die Erklärung:

  • Bei Tests einer neuen Software vor ca. 4 Wochen, die auf Exchange zugreift, erhielt ich Login Timeouts.
  • Nach Rücksprache mit dem Hersteller habe damals ich die formularbasierte Authentifizierung abgeschaltet.
  • Meine User melden gerne mal Probleme "besonders zeitnah", ich dachte natürlich mit keinem Wort mehr an die Einstellung von damals.
  • Nachdem ich die Änderung rückgängig gemacht habe, funktioniert mein KioskScript auch wieder.

Exchange System Manager --> Server --> %servername% --> Protokolle --> HTTP --> Virtueller Exchange-Server --> rechte Maus --> Eigenschaften --> Register Einstellungen --> Bereich Outlook Web Access --> Formularbasierte Authentifizierung aktivieren --> Haken rein --> OK

Vieln Dank an alle Mitrat^H^H^Hhelfer.

Gruß, getuemII
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung!

(1)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Linux Desktop
gelöst Linux Mint automatische Anmeldung deaktivieren (4)

Frage von laster zum Thema Linux Desktop ...

Microsoft
Keine Anmeldung mehr möglich (Server 2012 R2) (4)

Frage von Shnuuu zum Thema Microsoft ...

Windows 7
gelöst Automatische User Abmeldung nach Inaktivität (30s) (10)

Frage von IT-Blondi zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...