Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Automatischer Task führt Bat-File nicht aus

Frage Microsoft

Mitglied: Darth-Caedus-84

Darth-Caedus-84 (Level 1) - Jetzt verbinden

30.11.2009, aktualisiert 12:34 Uhr, 5718 Aufrufe, 4 Kommentare

Hallo zusammen

Habe beim Einrichten eines automatischen Task mit Server 2K8 ein kleines Problem und zwar, dass das verknüpfte Bat-File nicht ausgeführt wird.

Problem:
Habe für den automatischen Import eines ASCII-Files in die ABACUS Business Software drei verschiedene Bat-Files erstellt. Alle funktioniert auch einwandfrei. Gemäss Kundenwunsch habe ich diese nun abschliessend in einen automatischen Task (Server 2K8) eingebunden. Kontrolliert man jeweils nach der Ausführung des Tasks das entsprechende Protokoll, so wird angegeben, dass zwei der drei Aufgaben ausgeführt werden konnten, die dritte aber mit Startfehler abgebrochen worden sein. Kontrolliert man aber anschliessend bei den zwei Applikationen, bei welchen das Ganze gemäss Task funktioniert haben sollte die Daten, sieht man, dass auch hier der Import und somit das Bat-File nicht ausgeführt wurde.
Ich habe bereits diverse Tests (siehe Aufstellung weiter unten) durchgeführt und dieses Verhalten intern abgeklärt. Bei Server 2K3 musste man sich jeweils nur an der Console des Servers annmelden (nicht aber einlogen) und die Tasks konnten ausgeführt werden. Dies hat aber bei meinem Problem auch nichts gebracht.

Meine bereits durchgeführten Tests:
- Bat-File manuell ausgeführt => funktioniert
- Automatischer Task manuell ausgeführt => funktioniert
- Via RDP-Verbindung auf dem Server eingelogt und dann Task ausführen lassen => funktioniert

Hat von euch noch jemand eine Ahnung oder Vermutung, was die Ursache dieses komischen Verhaltens sein könnte.

Greez
Dario
Mitglied: SamTrex
30.11.2009 um 12:42 Uhr
Hi,
hast du für den Task auch ein Benutzerkonto gewählt?
Wenn keiner am Server angemeldet ist sollte der Task ja trotzdem laufen.

Gruß Sam
Bitte warten ..
Mitglied: Tommy70
30.11.2009 um 12:50 Uhr
Ich hatte bei einem W2k8 Server mal genau das gleiche Problem. Bei mir machte die Benutzerkontensteuerung das Problem.
Manuell lief alles planmäßig. Aber über den geplanten Task nicht.
Bitte warten ..
Mitglied: Darth-Caedus-84
30.11.2009 um 12:54 Uhr
Hey

Jep, als Benutzer habe ich den Administrator eingetragen. Wahrscheinlich hängt es irgendwie damit zusammen, wenn man die Antwort von Tommy70 anschaut.
Bitte warten ..
Mitglied: Darth-Caedus-84
30.11.2009 um 12:55 Uhr
Hey Tommy70

Danke für die Antwort. Werde dies mal mit dem Netzwerkverantwortlichen des Kundens anschauen. Tönt auf alle Fälle vielversprechend deine Antwort..
Bitte warten ..
Ähnliche Inhalte
Windows Server
Geplante Tasks starten nicht automatisch

Frage von TiTux zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 R2 - Automatische Tasks starten nicht (4)

Frage von TiTux zum Thema Windows Server ...

Entwicklung
gelöst Hilfe bei .bat script (1)

Frage von RUBEN123 zum Thema Entwicklung ...

Neue Wissensbeiträge
Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(1)

Information von DerWoWusste zum Thema Microsoft ...

Humor (lol)

Wohnt jemand in Belgien und kann nicht mehr ruhig ausschlafen?

(6)

Information von LordGurke zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Hosting & Housing
Mailserver Software Empfehlungen (21)

Frage von sunics zum Thema Hosting & Housing ...

Voice over IP
DeutschlandLAN IP Voice Data M Premium, Erfahrung mit Faxgeräte? (16)

Frage von liquidbase zum Thema Voice over IP ...

TK-Netze & Geräte
TK-Anlage VoIP - DECT Erweiterung (15)

Frage von Lynkon zum Thema TK-Netze & Geräte ...