Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Automatisches Markieren von Eingabefeldern in Windows 7

Frage Microsoft Windows 7

Mitglied: diwaffm

diwaffm (Level 2) - Jetzt verbinden

17.04.2012 um 12:38 Uhr, 3907 Aufrufe, 9 Kommentare

Hi Leute,

bei diversen Programmen mit Eingabemasken wird evtl. vorhandener Inhalt in den Textfeldern beim Springen von Feld zu Feld mit der Tab-Taste unter Windows XP automatisch komplett markiert.

Ist das gleiche Programm unter Windows 7 installiert, so springt die Einfügemarke ans Ende des Texts - markiert ist nichts.

Ist das ein "Feature" von Windows 7. Kann man das irgendwo umschalten, so dass sich die Eingabemaske unter Windows 7 wie unter Windows XP verhält?

ciao

dirk
Mitglied: BekkZter
17.04.2012 um 12:55 Uhr
Moin moin,

sage doch mal bei welchem Programm du das Problem hast ...


Was passiert denn wenn du die Einfügentaste "EINFG" drückst und dann in das Feld springst ...

Gruß
Bitte warten ..
Mitglied: NetWolf
17.04.2012 um 13:02 Uhr
Moin Moin,

nein, das hat i.d.R. nichts mit Windows 7 zu tun.

Der Programmierer bestimmt, welchen Code er für die Aktion nutzt. Einiges lässt sich auch per Grundeinstellung ändern (z.B. in Access).
Programme die auf globale Bibliotheken zugreifen (z.B. .Net, Java etc.), können natürlich auf unterschiedliche - je nach Windows-Version - stoßen.

Aber da du hier ein geheimes Programm nutzt, kann man wenig dazu sagen. Sehr wichtig wäre auch zu wissen, welche Windows Version du nutzt.

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: DerWoWusste
17.04.2012 um 14:42 Uhr
-offtopic-
Hallo Netwolf
Ich möchte nicht unnötig rumpupen, aber eins erklär mir bitte: Du schreibst in viele Postings, die ich mitlese, die Bitte rein, die Version von Windows zu nennen. Warum? In den seltensten Fällen kann ich den Nutzen erkennen. Warum wäre es in diesem Fall sehr wichtig, die Version (=Edition?) von Win7 zu kennen?
Mein Einwand ist nicht aus Jux: Wenn andere unbedarftere Nutzer solche Beiträge lesen, werden sie verleitet zu glauben, dass die Editionen (=Versionen?) von Windows anders gestrickt sind, was sie definitiv nicht sind - somit legen sie auch kein anderes Verhalten an den Tag. Es sind lediglich einige Features bestimmten Editionen vorbehalten, was aber bei Problemen wie diesem und allen, die ich in letzter Zeit mit Deiner Beteiligung gelesen habe, überhaupt nicht interessiert.

Klar, es frisst kein Brot, diese Infos gleich mitzugeben und ich mache es auch immer (damit der Beitrag nicht mit unnötigen Rückfragen zugespammt wird), aber danach zu fragen und es als "sehr wichtig" einzustufen? Das sollte man als Fachmann nicht tun. Wenn ich ein Problem mit meinem Auto habe, würde ich sehr an einer Werkstatt zweifeln, die mich ständig nach dem Hersteller meiner Nummernschilder fragt und das auch noch als "sehr wichtig zu wissen" bezeichnet.

Verstehst Du jetzt unter der Version jedoch tatsächlich den Unterschied non-SP ("gold") versus SP1, dann gebe ich Dir vollkommen Recht (und wegen der Frage nach dem verwendeten Programm sowieso )
Bitte warten ..
Mitglied: 106009
17.04.2012 um 15:01 Uhr
[OT]
Hi, DWW,

ich möchte auch nicht unnötig rumpupen, aber dein Einwand ist überflüssig und imo unangebracht.

Regel Nr. 2: Beiträge und Kommentare
•Notwendige problemspezifische Angaben bereitstellen (Betriebssystem-, Servicepack-, Software-Version, Hersteller- und Gerätebezeichnungen etc.).

und damit ist alles zur Begründung gesagt. Es sollte eigentlich selbstverständlch sein, dass man ungefragt Mindestangaben macht. Und zu diesen Mindestangaben gehört nun mal die vollständige Angabe des verwendeten Betriebssystems. Windows 7 in der Name einer Produktfamilie und nicht des OS.

Gruß
[/OT]
Bitte warten ..
Mitglied: NetWolf
17.04.2012 um 15:39 Uhr
Moin Moin,

auch du wirst schon festgestellt haben, dass z.B. die 32 und 64 Bit Versionen ihre Eigenheiten haben. Oder wie viele Fragen musste ich schon lesen, dass RDP nicht funktioniert, bis dann herauskam, dass eine Home-Version genutzt wurde.

Gerade hier bei der Frage ist die Version insofern wichtig, da geklärt werden sollte, ist es eine 32 oder 64 Bit Variante. Wie du weißt, sind die Bibliotheken teilweise gravierend unterschiedlich und verhalten sich häufig "eigenartig" (gerade bei der 64 Bit Version einiger Programme).

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: diwaffm
17.04.2012 um 17:06 Uhr
Das Problem tritt nachvollziehbar auf mehreren Rechner beim Programm "Seltec Team" - einer Verwaltungssoftware für die Leichtathletik - auf.
Allerdings nur unter Windows 7.
Dort allerdings sowohl unter 64 als auch unter 32 Bit-Versionen.
Einmal habe ich eine Win 7 64 Ultimate auf einer VM installiert, das andere ist ein HP-Notebook mit der 32 Bit-Version von Win 7 Business - beide mit allen Updates.

Was mich halt wundert: Unter Vista 32 Business (SP2) sowie unter Windows XP Pro SP3 (und allen anderen Versionen in den letzten 10 Jahren) wird bei der oben genannten Software (aus dem identischen Istaller) beim aktivieren des Feldes per Tab der Inhalt ausgewählt.
Wenn das eine Frage der Software ist, warum verhält sie sich dann auf den verschiedenen Plattformen unterschiedlich?

Ciao

dirk
Bitte warten ..
Mitglied: 106009
17.04.2012 um 17:32 Uhr
Hi,

Wenn du sicher bist, dass kein Hintergrundprogramm dir den Fokus klaut, sieh mal in den Systemeigenschaften nach (Leistungsinformationen und Tools > Visuelle Effekte anpassen), ob sich durch Anpassen der Einstellungen was ändern lässt.

Wenn das eine Frage der Software ist, warum verhält sie sich dann auf den verschiedenen Plattformen unterschiedlich?
Das könnte z. B. daran liegen, dass der Entwickler der Software die OS-Version abfragt und entsprechend verzweigt, und wenn er Win7 noch nicht kennt, eben Fehler passieren.

Gruß
Bitte warten ..
Mitglied: DerWoWusste
17.04.2012 um 19:42 Uhr
Moin Dirk.

Du schriebst ja zunächst "bei diversen Programmen", Es wäre nicht schlecht, wenn Du auch Programme nennen könntest, die die Allgemeinheit hier zumindest besitzen könnte, um das zu prüfen. Welche weiteren sind das?

OT
@NetWolf/ollidolli
Wir reden vielleicht aneinander vorbei: Eine Versionsangabe (siehe winver oder ver) umfasst nicht die Architektur (x86/x64), welche in der Tat von Belang ist. Die Version ist eigentlich nur vom Servicepack abhängig - auch dies sollte in jedem Thread genannt werden. Die Edition (Pro/Ultimate/Enterprise/Home) jedoch (und vielleicht hab ich da mehr vermutet, dass Du die meinst, als Du es tatsächlich tust, sorry), ist hier mit Sicherheit nicht von Belang.
Bitte warten ..
Mitglied: NetWolf
17.04.2012 um 20:01 Uhr
Ich versuche noch einmal die Gründe zu erklären:

Jede Software gibt es in unterschiedlichen Versionen. Leider schreibst du nicht welche Version du wo nutzt.
Deine erste Anlaufstelle sollte immer der Hersteller sein. Der wird dir vermutlich am schnellsten helfen können.
Es könnte also möglich sein, dass der Hersteller diese Funktion einfach umprogrammiert hat. Es kann auch sein, dass er die Funktion parametrisiert hat, d.h. dass man nun diese Funktion in den Einstellungen entsprechend einstellen kann.

Viele Programme benutzen eine Basis, auf der sie aufgebaut sind. Verständlich, denn welcher Programmierer will das Rad immer wieder neu erfinden? Ein Beispiel dafür sind z.B. die .NET Basisdateien/Bibliotheken. Schau mal bei den installierten Programmen nach, was dort alles von .NET installiert ist. Das trifft für Java, C, C+ C++ usw. ebenfalls zu.

Du wirst feststellen, dass es dort unterschiedliche Versionen pro Betriebssystem gibt. Das Gleiche gilt für viele andere Programmiersprachen. Diese Basis-Bibliotheken kommen vom Hersteller der Programmumgebung. Der normale Programmierer der diese Basis-Funktionen nutzt, hat i.d.R. keinen Einfluss darauf. Er muss also nehmen was er bekommt und sein Programm entsprechend anpassen, wenn es dort Änderungen gibt (oft ein Grund für Updates).

Für dich sieht es so aus, als wenn du das Programm ganz normal nutzt. In Wirklichkeit werden im Hintergrund aber ganz andere Module/Bibliotheken verwendet.
Wichtig ist für den Anwender, dass er immer die neuste Version nutzt. Nur die stellt i.d.R. sicher, dass die Funktionen auch in der neuen Version so funktionieren wie in vorangegangenen.

Wie ich schon vermutet hatte, verwendet Seltec Team eine Access Basis. Gerade in dem Bereich hat sich einiges getan in letzter Zeit. Solltest du in deinem Office Paket ebenfalls Access mit installiert haben, wirst du wohl die Einstellungen vom Seltec Team zerschossen haben. Schade vom Programmierer, dass es das nicht abgefangen hat.
Das lässt mich aber auch vermuten, dass auf den alten Rechnern auch ein andere Office installiert war/ist.

Thema Vergleichen:
Würdest du einen 3er BMW mit einem 5er BMW vergleichen? Vermutlich würdest du es machen, es sind ja beide von BMW!
Hast du in deinem Leben jemals exakt die gleichen Autos gesehen? Genau so ist es bei der EDV, es gibt keine zwei Geräte, die exakt gleich sind.

Solltest du also Access auf deinem PC installiert haben, öffne eine beliebige DB und stelle die Grundeinstellungen nach deinen Bedürfnissen ein.

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...