Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Automatisches Verbinden von Netzlaufwerken deaktivieren

Frage Microsoft Windows Netzwerk

Mitglied: F-Hoernchen

F-Hoernchen (Level 1) - Jetzt verbinden

30.07.2012 um 15:18 Uhr, 7189 Aufrufe, 5 Kommentare

Hallo zusammen,

ich habe folgendes Problem:

Ich bin gerade dabei unsere Firma von Novell (5.1) auf Windows-Domäne (2k8R2) zu migrieren.
Da es jedoch nich möglich ist alle hart auf einmal umzustellen wollte ich eine weiche Migration, in der ich zwar die PCs und die Benutzer nach und nach in die Domäne hole, jedoch den Novell-Client und die Novell-Laufwerke beibehalte. Quasi im Doppelbetrieb.

Zum Test hatte ich auch schon die Netzlaufwerke teilweise kopiert und unter dem gleichen Namen via GPO den Domänenclients zugewiesen. Dabei fiel dann aber auf, dass es Probleme gab, da der Novell-Client einfach die Netzlaufwerke nochmal gemappt hat:

Status Lokal Remote Netzwerk

F: \\Novell\SYS NetWare Services
OK F: \\Windows\F_Root Microsoft Windows Network
G: \\Novell\DATEN NetWare Services
OK G: \\Windows\G_Root Microsoft Windows Network

Folge davon war dann, dass ich mich entschloss die GPO wieder zu deaktivieren. OK, ich weiß ja, dass die Laufwerke dadurch nicht gelöscht werden, bzw. die GPO Einstellungen behalten werden, bis sich etwas ändert.

Aber jetzt kommt es so, dass neue PCs diese Laufwerke trotzdem haben, obwohl ich nirgends (jedenfalls nicht bewusst) diese Laufwerke per GPO oder Skript oder sonst irgendwie zuweise. Trotzdem sind sie da... Auch auf Rechnern ohne Novell erscheinen sie, was mich von der ersten Idee, dass Novell schuld sein könnte, wieder abbringt.

Hat da irgendwer eine Ahnung, oder auch nur eine Vermutung woran das liegen könnte?

Ich stehe hier echt auf dem Schlauch und dieses Problem hällt mich derzeit von der Migration ab...
Aber hier nochmal ein paar Daten zum System:

DC: W2k8R2 Domänenfunktionsebene 2008 R2
Clients Win 7 Pro
Novell-Server 5.1 | aktuellster Client für Win 7

Keine entsprechende GPO/Skripteinstellungen zu Laufwerken F und G


Danke für eure Hilfe

F-Hörnchen
Mitglied: Dirmhirn
30.07.2012 um 16:19 Uhr
HI!

Keine entsprechende GPO/Skripteinstellungen zu Laufwerken F und G
bist du dir da ganz sicher?? ev. eine andere GPO mit der du das getestet hast (immer auf User/Computer trennung achten)

hast schon mal probiert mit einer GPO F und G zu löschen?

sg Dirm
Bitte warten ..
Mitglied: lexa-lexa
30.07.2012 um 18:31 Uhr
Zitat von F-Hoernchen:
Hat da irgendwer eine Ahnung, oder auch nur eine Vermutung woran das liegen könnte?

Du hast die Shares mit Persistenz gemountet "[x] Verbindung wiederherstellen", d.h., der Windows Client will sie nach jeder User Anmeldung wieder herstellen. Dies entspricht dem Befehl:
net use X: \\server\share

Wenn man die Persistenz *nicht* möchte, muss man so mounten:
net use X: \\server\share /persistent:no

Dies entspricht "[ ] Verbindung wiederherstellen" in den Laufwerkseigenschaften im Policy Editor.

Workaround:
Nimm einfach den Haken raus. Wenn sich dann alle User mal angemeldet haben, hat sich das Problem erledigt und du kannst die Laufwerkzuordnung löschen.

Besser wäre vielleicht:
Führe an jedem Client aus:
net use * /del /yes

Damit werden alle persistenten Shares gelöscht.

Wenn der Novell Client in der Reihenfolge nach Windows mountet, kannst du den Befehl automatisiert mittels netlogon- oder Anmeldescript ausführen lassen (BAT Datei oder mittels Richtlinie -> Anmeldescript/beim Anmelden ausführen).
Bitte warten ..
Mitglied: F-Hoernchen
30.07.2012, aktualisiert um 23:35 Uhr
Hi, erst mal danke für die Antworten.

bist du dir da ganz sicher??

Aber ja, ich habe extra alle verwendeten GPOs noch einmal geprüft und nochmal und nochmal...
Mir ist da aber auch um noch sicherer zu sein eine Idee gekommen... ich werd mal einen PC in eine OU mit abgeschalteter Vererbung und ohne GPO packen und mal sehen, was dabei rum kommt. (Das ich auf die Idee nicht vorher gekommen bin... Aber wie war das Sprichwort mit dem Wald und den Bäumen noch gleich...)


Du hast die Shares mit Persistenz gemountet "[x] Verbindung wiederherstellen"

Das wäre ja zu einfach, wenn das so wäre, aber wie gesagt, das passiert direkt nach dem ich den Rechner in die Domäne aufgenommen habe. Da hab ich von Hand noch nix gemountet.
Der Novell-Client überschreibt das dann beim Login und wenn ich "net use /delete" mache löscht er auch komischerweise nur die Novell-Verbindungen. die Win-Laufwerke stehen im net use immer noch drin, nur ansprechen kann ich sie im Explorer/TotalCommander nicht.
Versuche ich die dann nochmal zu löschen sagt er mir, dass die Laufwerke nicht existieren. Kann es höchstens auch nochmal mit "*" probieren.

Ich geb auf jeden Fall Bescheid, sobald ich das getestet habe.

Nochmals Danke für die Hilfe

Gruß F
Bitte warten ..
Mitglied: Dirmhirn
31.07.2012 um 09:47 Uhr
ahja und den Richtlinienergebnissatz kannst du dir noch ansehen.
Bitte warten ..
Mitglied: F-Hoernchen
31.07.2012 um 11:18 Uhr
Moin zusammen,

so ich hab da mal getestet und den Benutzer in eine andere OU geschoben und danach die Laufwerke gelöscht. Das ging auch.
Dann dachte ich, OK, schiebste den User mal zurück und guckst mal, was der macht. Und nix passiert. Laufwerke sind noch weg.

So, machen wir es nochmal neu...

Neuer PC (VM), neuer User, selbe OU...
Ergebnis: keine Laufwerke da... Warum auch immer...
Naja, jetzt muß ich das ganze dann nochmal mit installiertem Novell-Client testen...

Melde mich dann nochmal.

Trotzdem schon mal danke ffür alle Antworten

Gruß F
Bitte warten ..
Ähnliche Inhalte
Windows Server
Netzlaufwerke verbinden sich nicht (6)

Frage von MyBRis4Shot zum Thema Windows Server ...

Windows Server
Automatischen Schlüsselwechsel nach Domänenbeitritt deaktivieren (3)

Frage von ex-166 zum Thema Windows Server ...

Microsoft
Anwendung bzw Tool zum verbinden von Netzlaufwerken (12)

Frage von LukasHo zum Thema Microsoft ...

Linux Desktop
gelöst Linux Mint automatische Anmeldung deaktivieren (4)

Frage von laster zum Thema Linux Desktop ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (19)

Frage von Syosse zum Thema Windows Server ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...

Windows Server
gelöst WSUS Updates auf iSCSI speichern (10)

Frage von lcer00 zum Thema Windows Server ...