Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autoproxy konfiguration läuft nicht!!!:-(

Frage Linux Linux Netzwerk

Mitglied: Dambi

Dambi (Level 1) - Jetzt verbinden

30.11.2004, aktualisiert 06.12.2004, 18536 Aufrufe, 2 Kommentare

Autoproxy

Hallo zusammen!

Ich muss bei der Arbeit einen Autoproxy konfigurieren. Jetzt habe ich das gemacht und auch die Artikel im Forum gelesen doch es läuft nicht! Wir haben eine IPCop Firewall und dort ist der Proxy drauf. Dann haben wir einen DHCP Server DNS Server alles auf SuSE 9.1. Wir haben ein Lokales Netz welches mein 10er Netz ist und ein DMZ welches das Netz 192.168 ist. Ich habe vieles probiert und es ist auch schon so halb geloffen. Ich habe es mit folgenden Konfiguratiionen Probiert:

function FindProxyForURL(url,host)
{
if (isInNet(host, "10.0.0.0", "255.0.0.0")) or (isInNet(host, "192.168.0.0", "255.255.0.0"))
return "DIRECT";
else
return "PROXY my.proxy.ch:8080";

}

und auch mit der konfiguration habe ich es probiert:

function FindProxyForURL(url, host)
{

var proxymode;
var proxy_admin = "PROXY my.proxy.ch:8080";
var proxy_user = "PROXY my.proxy.ch:8080";
var proxy_intra = "DIRECT";

proxymode = proxy_user;

if (
dnsDomainIs(host, "10") ||
dnsDomainIs(host, "192.168) ||
)
{
proxymode = proxy_intra;
}

if (myIpAddress() > "10.0.0.0")
{ if (myIpAddress() < "10.255.255.255")

{ proxymode = proxy_admin; }}


return(proxymode);
}


Wenn ich im Internet Explorer angib "use automatic configuration script" und dann den Pfad angebe dann geht es, aber auch nur bei der ersten konfiguration beim zweiten Script geht es nicht! Und wenn ich nichts angib dann geht es nicht obwohl ich (wie ich glesen habe) im DHCP Server das konfiguriert habe:

option wpad-curl code 252 = text; #option for autoproxy
option wpad-curl "http://server01/proxy.pac"; #path for the autoproxy file

was mache ich falsch? mit der zweiten Konfiguration geht gar nichts aber mit der ersten geht es aber nur wenn ich das Script im Internet Explorer angebe. Ich will aber das er alles selbst macht, so dass jeder Client die Proxy Konfiguration direkt mit dem DHCP bekommt.

Ich freue mich sehr auch eure Antworten (bin scho zwei Tage am ausprobieren)!!!!

Dank scho im Voraus für eure Hilfe

Gruss Dambi
Mitglied: Dambi
30.11.2004 um 16:44 Uhr
So also ich habe noch einbischen gesucht und habe es auch so geschafft!

meine konfig sieht so aus:

function FindProxyForURL(url,host)
{
if (isInNet(host, "10.0.0.0", "255.0.0.0"))
return "DIRECT";
else
return "PROXY fw.ba.labnet.ch:8080";

}

das muss auf dem apache server abgelegt sein mit dem permissions 777 und dem namen wpad.dat.
Jetzt muss man noch einen DNS Eintrag machen der so lautet:
wpad A 10.32.32.31
die IP 10.32.32.31 (server01) ist die IP des servers auf dem das File wpad.dat liegt.
Zum schluss muss man noch das in der dhpcd.conf eingeben:

? option wpad-curl code 252 = text; #option for autoproxy
? option wpad-curl "http://server01/wpad.dat"\n"; #path for the autoproxy file

das "\n" ist (habe ich gelesen) weil der IE anscheinend manchmal oder immer den letzten Teil abschneidet. und damit er dass nicht mehr macht macht man dieses kürzel dran.

Die IE einstellungen sind "automatische suche der einstellungen"

Also ich hoffe bei euch funktioniert es auch bei mir tut es das!

Gruss Dambi
Bitte warten ..
Mitglied: Dambi
06.12.2004 um 13:31 Uhr
Ich habe noch eine erweiterung der Datei wpad.dat! Wenn man noch andere Netze hat mit denen man nicht über den Proxy will. Z.B. das Netz 10.0.0.0/8 , 192.168.0.0/16 und natürlich localhost also 127.0.0.0/8. Bei so einem Netzt kann man folgendes in die wpad.dat eingeben:

function FindProxyForURL(url,host)
{
if (isInNet(host, "127.0.0.0", "255.0.0.0") ||
isInNet(host, myIpAddress(), "255.255.255.255") ||
isInNet(host, "192.168.0.0", "255.255.0.0") ||
isInNet(host, "10.0.0.0", "255.0.0.0") ||
isPlainHostName(host)
)
return "DIRECT";

else
return "PROXY my.proxy.ch:8080";
}

Ich hoff es klappt!!

Bei mir klappts!

Gruss Dambi
Bitte warten ..
Neuester Wissensbeitrag
Batch & Shell

Batch Script Editor - Programmvorstellung des Entwicklers

(11)

Tipp von wowItsDoge zum Thema Batch & Shell ...

Ähnliche Inhalte
Apache Server
gelöst Apache 2.4.7 (Ubuntu) und Virtual Hosts Konfiguration (2)

Frage von runasservice zum Thema Apache Server ...

Apache Server
gelöst Nach PHP7-Installation - PHP läuft nicht im Browsser (2)

Frage von bolshi zum Thema Apache Server ...

Windows Netzwerk
gelöst 802.1x Konfiguration (2)

Frage von michaelb123 zum Thema Windows Netzwerk ...

Exchange Server
gelöst Outlook 2016 und Exchange 2010 Verbindung funktioniert nicht, Autodiscover läuft (5)

Frage von Thorsten85 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
Anmeldung an neuen Windows Domäne Client nicht möglich (16)

Frage von FlorianN zum Thema Windows Server ...

Speicherkarten
gelöst Verschlüsselte USB-Sticks (14)

Frage von rudeboy zum Thema Speicherkarten ...

Windows Server
SBS2008 AD funktioniert nur im LAN mit bestimmter IP. wie ändern? (12)

Frage von tomeknfr zum Thema Windows Server ...

Batch & Shell
gelöst PowerShell Transpose Objects und Memoryleak (11)

Frage von agowa338 zum Thema Batch & Shell ...