Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Autostart im XP Mode soll Script ausführen

Frage Virtualisierung

Mitglied: sub-mac

sub-mac (Level 1) - Jetzt verbinden

27.03.2012 um 16:05 Uhr, 5639 Aufrufe, 4 Kommentare

Hallo zusammen,

beim Starten einer Anwendung vom Host aus, die im XP Mode installiert ist, soll ein Logon Script im Autostart der XP Mode Maschine gestartet werden.
Ich habe das Script sowohl im Autostart des Users eingestellt als auch im Autostart aller User.
Starte ich die VM wird das Script ausgeführt.
Starte ich vom Host aus aber nur eine Anwendung (Host-App?!), die im XP Mode installiert wurde, startet das Script nicht.

Per geplantem Task funktioniert es auch nicht.

Besten Dank vorab für Eure Hilfe.

Gruß,
Mac
Mitglied: Pjordorf
27.03.2012 um 16:12 Uhr
Hallo,

Zitat von sub-mac:
beim Starten einer Anwendung vom Host aus die im XP Mode installiert ist,
Also dann wenn du ein Programm im installierten XP Modus startest z.B. Notepad.exe, oder?

soll ein Logon Script im Autostart der XP Mode Maschine gestartet werden.
Und was hat das mit dem Logon Script zu tun? Das Logon Script wird wie der Name sagt beim Anmelden ausgeführt.

Ich habe das Script sowohl im Autostart des Users eingestellt als auch im Autostart aller User.
Auch diese werden NUR beim Anmelden ausgeführt. Und das passiert ja nur einmal, eben beim Anmelden.

Starte ich die VM wird das Script ausgeführt.
Korrekt, da dann der Virtuelle Rechner ja neu gestartet wird.

Starte ich vom Host aus aber nur eine Anwendung (Host-App?!), die im XP Mode installiert wurde, startet das Script nicht.
Auch korrekt. Der Virtuelle Rechner wird ja nicht gestartet. Der läuft ja schon. Und Anmelden tust du dich da auch nicht. Ist ja auch schon passiert.

Per geplantem Task funktioniert es auch nicht.
Das sollte aber gehen. Das Script mit den richtigen Parameter und es sollte laufen.

Gruß,
Peter
Bitte warten ..
Mitglied: sub-mac
27.03.2012 um 16:36 Uhr
Zitat von Pjordorf:
Hallo,

> Zitat von sub-mac:
> beim Starten einer Anwendung vom Host aus die im XP Mode installiert ist,
Also dann wenn du ein Programm im installierten XP Modus startest z.B. Notepad.exe, oder?
>Ja genau, ich möchte auf dem Host das Notepad aus der XP Maschine starten.

> soll ein Logon Script im Autostart der XP Mode Maschine gestartet werden.
Und was hat das mit dem Logon Script zu tun? Das Logon Script wird wie der Name sagt beim Anmelden ausgeführt.
>OK, kein wirkliches Logon Script. Ein Net USE Script, dass dem user im XP Mode zusätzliche Laufwerke zu denen auf dem Host gibt.

> Ich habe das Script sowohl im Autostart des Users eingestellt als auch im Autostart aller User.
Auch diese werden NUR beim Anmelden ausgeführt. Und das passiert ja nur einmal, eben beim Anmelden.
>Wer wird denn beim Start des XP-Modes angemeldet? Es sieht immer wie eine Remotesitzung aus.

> Starte ich die VM wird das Script ausgeführt.
Korrekt, da dann der Virtuelle Rechner ja neu gestartet wird.
>An der Stelle wird der User ja auch angemeldet und der Autostart abgearbeite.

> Starte ich vom Host aus aber nur eine Anwendung (Host-App?!), die im XP Mode installiert wurde, startet das Script nicht.
Auch korrekt. Der Virtuelle Rechner wird ja nicht gestartet. Der läuft ja schon. Und Anmelden tust du dich da auch nicht. Ist
ja auch schon passiert.
>Der virtuelle Rechner startet doch erst wenn ich den Start der Anwendung vom Host aus anfordere.

> Per geplantem Task funktioniert es auch nicht.
Das sollte aber gehen. Das Script mit den richtigen Parameter und es sollte laufen.
>Die Parameter sollten korrekt sein. Den Task habe ich natürlich in der VM erstellt.

Gruß,
Peter
Bitte warten ..
Mitglied: Pjordorf
27.03.2012 um 17:00 Uhr
Hallo,

Zitat von sub-mac:
Wer wird denn beim Start des XP-Modes angemeldet? Es sieht immer wie eine Remotesitzung aus.
Es ist auch eine "Remotesitzuung". Wie sollen denn sonst 2 verschiedene Betriebssysteme gleichzeitig auf einen Rechner (Windows) laufen.

Der virtuelle Rechner startet doch erst wenn ich den Start der Anwendung vom Host aus anfordere.
Nein, nicht unbedingt. Wenn der Virtuelle XP Heruntergefahren war, startet Windows dort neu und auch die Anmeldeprozedur wird durchlaufen. War der Virtuelle XP nur im "Standby" (gesichert) sow ird der aufgewckt und das Virtuelle XP macht an der Stelle weiter wo er zuletzt war. (Vorteile eine VM und oder Stromsparmodi). Da wird dann natürlich keine anmeldeprozedur wie beim Rechnerstart durchlaufen. Welcher Zustand dein Virtuelles XP eingenommen hat merkst du an der Zeit die es benötigt. In deinem Virtuellen XP mal ein CMD Fenster aufmachen und dort ein "shutdown -s -t 5 -f" eingeben. Dann dein Virtuelles XP mal neu starten. Du merkst dann den Unterschied (und alle Vor- und Nachteile die mit den unterschiedlichen Modi zusammenhängen...)

Die Parameter sollten korrekt sein. Den Task habe ich natürlich in der VM erstellt.
Wenn das Script korrekt ist, der Geplante Task auch korrekt eingerichtet ist läuft es auch korrekt und wie gewünscht ab. Bei dir läuft das Script nicht wie gewünscht ab. Was ist also deine Fehlerdiagnose?

Gruß,
Peter

(Und bitte nicht deine Antworten im Quoten einbeziehen)

{Edit]
Leerzeichen wieder eingebaut beim Quoten. Warum waren die verschwunden?
[/Edit]
Bitte warten ..
Mitglied: sub-mac
27.03.2012 um 17:50 Uhr
Hallo Peter,

sorry für das Formatchaos eben.

Ich hab die VM so eingestellt, dass sie immer herunter gefahren wird. Jetzt beim Testen bin ich nach dem Schließen der Anwendung stets auf den Desktop gewechselt und habe die Maschine manuell herunter gefahren.

Ich bin ursprünglich davon ausgegangen, dass der hinterlegte User beim Start der Anwendung, vom Host aus, auch in der VM angemeldet wird und sein Autostart oder der für Alle Benutzer abgearbeitet wird. Dem ist leider nicht so, das habe ich mit Excel getestet. Beim Speichern aus Excel (VM) heraus zeigt er mir die Laufwerke aus dem Script nicht an.

Bei dem Thema Remoteverbindung meine ich das RDP Protokoll, das auch beim Fernzugriff auf eine andere physikalische Maschine verwendet wird. Starte ich eine virtuelle Maschine läuft diese, ob VMware, Virtual PC oder Virtual Box in einer Anwendung bei der ledeglich die Eingaben bestimmter Geräte wie Tastatur und Maus in diese umgeleitet werden. Der XPMode scheint ein Mix zu sein. Starte ich die XPMode Maschine wie jede andere virtuelle Maschine verhält sie sich wie eine Anwendung. Starte ich aber nur eine Anwendung vom Host aus, sorgen die Integrationsfeatures für ein Verhalten wie beim Remote Desktop.

Ich habe wohl bei dem XP Mode noch einiges an Wissenslücken zu füllen.

Vorerst habe ich eine Batch geschrieben, die sowohl das Net USE Script als auch die gewünschte Anwendung startet. Diese Batch ist nun vom Host startbar.

Besten Dank und Gruß,
Mac
Bitte warten ..
Ähnliche Inhalte
Windows Server
Powershell Script in Script ausführen
Frage von diematrix125Windows Server2 Kommentare

Hallo! Ich habe hier momentan zwei verschiedene Skripte: 1. Skript zum Erstellen von Usern 2. Skript zum Erstellen der ...

Linux
Shell Script, Script ausführen in einem Zeitfenster
Frage von webstorLinux2 Kommentare

Hi, ich bin wieder mal lästig. ;-) ich habe ein Script das in einem Zeitraumen von als Bsp in ...

Batch & Shell
Via Powershell den Autostart-mode von Prozessen unterbinden
gelöst Frage von PinkFLuffyUnicornBatch & Shell8 Kommentare

Hi, ich habe in Google nichts dazu gefunden, wie ich den Autostart von Hintergrundprozessen unterbinden kann. Via Stop-Process oder ...

Visual Studio
Net - Autostart erst ausführen wenn Netzwerkverbindung steht
Frage von Rene1976Visual Studio6 Kommentare

Hallo, wir haben eine Client Server Anwendung in C# geschrieben. Beim Start von Win 10 Client wird über den ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 9 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 13 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware8 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...