Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autounattend.xml im Stammverzeichniss wird Ignoriert

Frage Microsoft Windows 7

Mitglied: Predalon

Predalon (Level 1) - Jetzt verbinden

11.09.2014 um 00:16 Uhr, 952 Aufrufe, 13 Kommentare

Hallo irgendwie wird meine Autounattend.xml die im Stammverzeichniss meines Windows 7 Installationsstick´s ignoriert.

Hier der Inhalt meiner XML

01.
<?xml version="1.0" encoding="utf-8"?> 
02.
<unattend xmlns="urn:schemas-microsoft-com:unattend"> 
03.
    <settings pass="windowsPE"> 
04.
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
05.
            <UserData> 
06.
                <ProductKey> 
07.
                    <Key>XXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key> 
08.
                </ProductKey> 
09.
                <AcceptEula>true</AcceptEula> 
10.
				<HideEula>true</HideEula> 
11.
                <FullName>XXXXX</FullName> 
12.
                <Organization>XXXX</Organization> 
13.
            </UserData> 
14.
            <DiskConfiguration> 
15.
                <Disk wcm:action="add"> 
16.
                    <CreatePartitions> 
17.
                        <CreatePartition wcm:action="add"> 
18.
                            <Type>Primary</Type> 
19.
                            <Size>100000</Size> 
20.
                            <Order>1</Order> 
21.
                        </CreatePartition> 
22.
                        <CreatePartition wcm:action="add"> 
23.
                            <Type>Extended</Type> 
24.
                            <Order>2</Order> 
25.
                            <Extend>true</Extend> 
26.
                        </CreatePartition> 
27.
                        <CreatePartition wcm:action="add"> 
28.
                            <Order>3</Order> 
29.
                            <Type>Logical</Type> 
30.
							<Extend>true</Extend> 
31.
                        </CreatePartition> 
32.
                    </CreatePartitions> 
33.
                    <ModifyPartitions> 
34.
                        <ModifyPartition wcm:action="add"> 
35.
                            <Label>System</Label> 
36.
                            <Letter>C</Letter> 
37.
                            <Active>true</Active> 
38.
                            <Extend>false</Extend> 
39.
                            <Format>NTFS</Format> 
40.
                            <Order>1</Order> 
41.
                            <PartitionID>1</PartitionID> 
42.
                        </ModifyPartition> 
43.
                        <ModifyPartition wcm:action="add"> 
44.
                            <Order>2</Order> 
45.
                            <PartitionID>2</PartitionID> 
46.
                            <Letter>D</Letter> 
47.
                            <Label>Daten</Label> 
48.
                            <Format>NTFS</Format> 
49.
                            <Active>false</Active> 
50.
                            <Extend>false</Extend> 
51.
                        </ModifyPartition> 
52.
                    </ModifyPartitions> 
53.
                    <DiskID>0</DiskID> 
54.
                    <WillWipeDisk>true</WillWipeDisk> 
55.
                </Disk> 
56.
                <WillShowUI>OnError</WillShowUI> 
57.
            </DiskConfiguration> 
58.
            <ImageInstall> 
59.
                <OSImage> 
60.
                    <InstallTo> 
61.
                        <DiskID>0</DiskID> 
62.
                        <PartitionID>1</PartitionID> 
63.
                    </InstallTo> 
64.
                    <WillShowUI>OnError</WillShowUI> 
65.
                </OSImage> 
66.
            </ImageInstall> 
67.
        </component> 
68.
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
69.
            <SetupUILanguage> 
70.
                <UILanguage>de-DE</UILanguage> 
71.
            </SetupUILanguage> 
72.
            <UserLocale>de-DE</UserLocale> 
73.
            <UILanguage>de-DE</UILanguage> 
74.
            <SystemLocale>de-DE</SystemLocale> 
75.
            <InputLocale>de-DE</InputLocale> 
76.
        </component> 
77.
    </settings> 
78.
    <settings pass="oobeSystem"> 
79.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
80.
            <AutoLogon> 
81.
                <Password> 
82.
                    <Value>XXXX</Value> 
83.
                    <PlainText>true</PlainText> 
84.
                </Password> 
85.
                <Enabled>true</Enabled> 
86.
                <LogonCount>1</LogonCount> 
87.
                <Username>mfiadmin</Username> 
88.
            </AutoLogon> 
89.
            <OOBE> 
90.
                <HideEULAPage>true</HideEULAPage> 
91.
                <NetworkLocation>Work</NetworkLocation> 
92.
                <ProtectYourPC>1</ProtectYourPC> 
93.
            </OOBE> 
94.
            <UserAccounts> 
95.
                <LocalAccounts> 
96.
                    <LocalAccount wcm:action="add"> 
97.
                        <Password> 
98.
                            <Value>XXXXX</Value> 
99.
                            <PlainText>true</PlainText> 
100.
                        </Password> 
101.
                        <Name>XXXXX</Name> 
102.
                        <Group>Administrators</Group> 
103.
                    </LocalAccount> 
104.
                </LocalAccounts> 
105.
            </UserAccounts> 
106.
        </component> 
107.
    </settings> 
108.
    <settings pass="specialize"> 
109.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
110.
            <ComputerName>XXX-XXxxx</ComputerName> 
111.
            <TimeZone>W. Europe Standard Time</TimeZone> 
112.
        </component> 
113.
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
114.
            <Identification> 
115.
                <JoinWorkgroup>XXXTemp</JoinWorkgroup> 
116.
            </Identification> 
117.
        </component> 
118.
    </settings> 
119.
    <cpi:offlineImage cpi:source="wim:e:/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
120.
</unattend> 
121.
 
Mitglied: Webfuchs
11.09.2014 um 08:35 Uhr
Die Antwortdatei im SIM schon geprüft? Fehler?

LG
Bitte warten ..
Mitglied: Predalon
11.09.2014 um 08:51 Uhr
Was meinst du mit SIM?

VG
Bitte warten ..
Mitglied: Webfuchs
11.09.2014 um 09:32 Uhr
Der WindowsSystem Image Manager ist ein Bestandteil des WAIK. Schau mal hier:
http://community.certbase.de/blogs/mg/archive/2009/09/30/wim-und-waik.a ...
Bitte warten ..
Mitglied: Predalon
11.09.2014 um 09:46 Uhr
So habe meine xml im dem Programm mal über Extras Überprüfen lassen und es gab keine Fehlerausgabe.
Bitte warten ..
Mitglied: Webfuchs
11.09.2014 um 12:04 Uhr
Es kann viele Gründe haben. Wo hast du die Autounattend.xml her? Selbst erstellt? Passt die Architektur x64 zum Installationsmedium? Ist es eine Professional? Ist die Win7 untouched? Versuch mal von DVD zu installieren und die XML auf den Stick oder mit auf die DVD (RW).
Hier gibts auch noch weitere Infos zu dem Problem: http://social.technet.microsoft.com/Forums/de-DE/2798e83b-32d2-4058-a63 ...
Bitte warten ..
Mitglied: Predalon
11.09.2014 um 12:09 Uhr
Die aus WAIK herraus erstellt worden. Architektur ist x64 und es handelt sich auch um Professional. Das Win7 wurde im Audit Modus eingerichtet und danach mit sysprep und den parametern generalize und oobe wieder versiegelt.
Bitte warten ..
Mitglied: colinardo
11.09.2014, aktualisiert um 12:27 Uhr
Moin Pedalon,
denke das hier ist der Fehler: Hier wird via festem Pfad auf das Image verwiesen:
<cpi:offlineImage cpi:source="wim:e:/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
Das sieht normalerweise für die XML anders aus:
http://technet.microsoft.com/en-us/library/dd799255%28v=ws.10%29.aspx
01.
<ImageInstall> 
02.
    <OSImage> 
03.
        <InstallFrom> 
04.
            <MetaData wcm:action="add"> 
05.
                <Key>/IMAGE/NAME</Key> 
06.
                <Value>Windows 7 PROFESSIONAL</Value> 
07.
            </MetaData> 
08.
... 
09.
...
Dem Image muss dazu natürlich beim Capture mit ImageX der obige Name zugewiesen worden sein! Ansonsten lässt sich das auch via Image-Index machen.

Grüße Uwe
Bitte warten ..
Mitglied: Predalon
11.09.2014 um 12:37 Uhr
Hallo Colinardo,

kann man das sonst auf relative angaben umsetzten da es ja bei jedem Rechner einen anderen LW Buchstaben hat.
Bitte warten ..
Mitglied: colinardo
11.09.2014, aktualisiert um 12:41 Uhr
Zitat von Predalon:
kann man das sonst auf relative angaben umsetzten da es ja bei jedem Rechner einen anderen LW Buchstaben hat.
siehe die Variante oben ... und im Link!
http://technet.microsoft.com/en-us/library/ff716384.aspx
Bitte warten ..
Mitglied: Predalon
17.09.2014 um 10:08 Uhr
Hallo habe das jetzt mal versucht mit den Tipps von colinardo, jedoch wird dann trotzdem die Datei Ignoriert. Ich habe die Datei jetzt mal neu erstellt mit dem SIM.

Hier einmal die neu erstellt Datei, leider wird diese aber auch noch erstelllt.

01.
<?xml version="1.0" encoding="utf-8"?> 
02.
<unattend xmlns="urn:schemas-microsoft-com:unattend"> 
03.
    <settings pass="windowsPE"> 
04.
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
05.
            <UserData> 
06.
                <ProductKey> 
07.
                    <Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key> 
08.
                    <WillShowUI>OnError</WillShowUI> 
09.
                </ProductKey> 
10.
                <AcceptEula>true</AcceptEula> 
11.
                <FullName>MFI-XFAB</FullName> 
12.
                <Organization>XFAB Itzehoe</Organization> 
13.
            </UserData> 
14.
            <DiskConfiguration> 
15.
                <Disk wcm:action="add"> 
16.
                    <CreatePartitions> 
17.
                        <CreatePartition wcm:action="add"> 
18.
                            <Type>Primary</Type> 
19.
                            <Size>100000</Size> 
20.
                            <Order>1</Order> 
21.
                        </CreatePartition> 
22.
                        <CreatePartition wcm:action="add"> 
23.
                            <Type>Extended</Type> 
24.
                            <Order>2</Order> 
25.
                            <Extend>true</Extend> 
26.
                        </CreatePartition> 
27.
                        <CreatePartition wcm:action="add"> 
28.
                            <Order>3</Order> 
29.
                            <Type>Logical</Type> 
30.
                            <Extend>true</Extend> 
31.
                        </CreatePartition> 
32.
                    </CreatePartitions> 
33.
                    <ModifyPartitions> 
34.
                        <ModifyPartition wcm:action="add"> 
35.
                            <Label>System</Label> 
36.
                            <Letter>C</Letter> 
37.
                            <Active>true</Active> 
38.
                            <Extend>false</Extend> 
39.
                            <Format>NTFS</Format> 
40.
                            <Order>1</Order> 
41.
                            <PartitionID>1</PartitionID> 
42.
                        </ModifyPartition> 
43.
                        <ModifyPartition wcm:action="add"> 
44.
                            <Order>2</Order> 
45.
                            <PartitionID>2</PartitionID> 
46.
                            <Letter>D</Letter> 
47.
                            <Label>Daten</Label> 
48.
                            <Format>NTFS</Format> 
49.
                            <Active>false</Active> 
50.
                            <Extend>false</Extend> 
51.
                        </ModifyPartition> 
52.
                    </ModifyPartitions> 
53.
                    <DiskID>0</DiskID> 
54.
                    <WillWipeDisk>true</WillWipeDisk> 
55.
                </Disk> 
56.
                <WillShowUI>OnError</WillShowUI> 
57.
            </DiskConfiguration> 
58.
            <ImageInstall> 
59.
                <OSImage> 
60.
                    <InstallTo> 
61.
                        <DiskID>0</DiskID> 
62.
                        <PartitionID>1</PartitionID> 
63.
                    </InstallTo> 
64.
                    <WillShowUI>OnError</WillShowUI> 
65.
                    <InstallToAvailablePartition>true</InstallToAvailablePartition> 
66.
                </OSImage> 
67.
            </ImageInstall> 
68.
        </component> 
69.
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
70.
            <SetupUILanguage> 
71.
                <UILanguage>de-DE</UILanguage> 
72.
            </SetupUILanguage> 
73.
            <UserLocale>de-DE</UserLocale> 
74.
            <UILanguage>de-DE</UILanguage> 
75.
            <SystemLocale>de-DE</SystemLocale> 
76.
            <InputLocale>de-DE</InputLocale> 
77.
        </component> 
78.
    </settings> 
79.
    <settings pass="oobeSystem"> 
80.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
81.
            <AutoLogon> 
82.
                <Password> 
83.
                    <Value>bQBmAGkAMQAxAHQAbwBvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value> 
84.
                    <PlainText>false</PlainText> 
85.
                </Password> 
86.
                <Enabled>true</Enabled> 
87.
                <LogonCount>1</LogonCount> 
88.
                <Username>XXXXXX</Username> 
89.
            </AutoLogon> 
90.
            <OOBE> 
91.
                <HideEULAPage>true</HideEULAPage> 
92.
                <NetworkLocation>Work</NetworkLocation> 
93.
                <ProtectYourPC>1</ProtectYourPC> 
94.
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE> 
95.
            </OOBE> 
96.
            <UserAccounts> 
97.
                <LocalAccounts> 
98.
                    <LocalAccount wcm:action="add"> 
99.
                        <Password> 
100.
                            <Value>bQBmAGkAMQAxAHQAbwBvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value> 
101.
                            <PlainText>false</PlainText> 
102.
                        </Password> 
103.
                        <Name>XXXXXXX</Name> 
104.
                        <Group>Administrators</Group> 
105.
                        <DisplayName>XXXX</DisplayName> 
106.
                        <Description>XXXXX</Description> 
107.
                    </LocalAccount> 
108.
                </LocalAccounts> 
109.
            </UserAccounts> 
110.
            <RegisteredOrganization>XXXXXX</RegisteredOrganization> 
111.
            <RegisteredOwner>XXXXXX</RegisteredOwner> 
112.
            <TimeZone>W. Europe Standard Time</TimeZone> 
113.
        </component> 
114.
    </settings> 
115.
    <settings pass="specialize"> 
116.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
117.
            <ComputerName>izh-mfixxx</ComputerName> 
118.
            <TimeZone>W. Europe Standard Time</TimeZone> 
119.
            <DoNotCleanTaskBar>true</DoNotCleanTaskBar> 
120.
            <RegisteredOrganization>MFI XFAB Itzehoe</RegisteredOrganization> 
121.
            <RegisteredOwner>IZH MFIADMIN</RegisteredOwner> 
122.
        </component> 
123.
		 <CopyProfile>true</CopyProfile> 
124.
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
125.
            <Identification> 
126.
                <JoinWorkgroup>XFABTemp</JoinWorkgroup> 
127.
            </Identification> 
128.
        </component> 
129.
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
130.
            <Home_Page>http://sp.erf.xfab.de/MFI/default.aspx</Home_Page> 
131.
        </component> 
132.
    </settings> 
133.
    <cpi:offlineImage cpi:source="catalog:D:/sources/install_Windows 7 PROFESSIONAL.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
134.
</unattend>
Bitte warten ..
Mitglied: colinardo
17.09.2014 um 10:41 Uhr
es fehlt schon wieder die InstallFrom Section .... halt dich an die Bestpractices dann lüppt das!
Bitte warten ..
Mitglied: Predalon
17.09.2014 um 12:35 Uhr
Okay fehlen mir nur wieso muss ich die dann auch nicht einbauen und außerdem wird das Image ja nicht aus dem Netz geladen sondern liegt mit auf dem Stick.

Die Install.wim die Verwendet wird ist eine angepasst wo Software schon mit vorinstalliert ist.
Bitte warten ..
Mitglied: colinardo
17.09.2014 um 12:41 Uhr
Zitat von Predalon:
Okay fehlen mir nur wieso muss ich die dann auch nicht einbauen und außerdem wird das Image ja nicht aus dem Netz geladen sondern liegt mit auf dem Stick.
??? schon klar das das nicht aus dem Netz geladen wird, trotzdem muss der Abschnitt rein ....
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
Batch & Shell
gelöst Powershellscript zum konvertieren und anpassen einer XML für Elster Import (9)

Frage von Shaijan zum Thema Batch & Shell ...

Batch & Shell
Stapelverarbeitung XML-Datein (1)

Frage von 132015 zum Thema Batch & Shell ...

MikroTik RouterOS
Mikrotik Zertifikate - Import von Private-Key wird ignoriert

Tipp von colinardo zum Thema MikroTik RouterOS ...

XML
XML Datei Fehler? (1)

Frage von Patrick-IT zum Thema XML ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...