Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Büroware 5.31 teilsweise sehr zäh

Frage Microsoft

Mitglied: Hink-L-Stein

Hink-L-Stein (Level 1) - Jetzt verbinden

25.03.2009, aktualisiert 12:02 Uhr, 11012 Aufrufe, 3 Kommentare

Hallo,
ich habe ein performance Problem mit Büroware.

Kurze beschreibung:

Büroware läuft auf einem dedizierten BW Server,
Dual Quad Opteron 2GHz
16Gb Ram
2x Raid 0
Raid 0 (1) besteht aus 2x 73Gb SAS 15K Platten
Raid 0 (2) besteht aus 2x 147Gb SAS 15K Platten

Bitte keine diskussion über Sinn und Unsinn der Raid 0 konfig.
Mir geht es darum das ich jetzt schon länger an diesem Problem rum mache
und die performance der Hardware sicher ausschliessen wollte.

Um die Kompatibilität hoch zu halten habe ich ein Server 2008 32Bit Server aufgesetzt.
Ja ich weis, von den 16Gb werden nur 4Gb genutzt. Sorry wenn ich etwas genervt wirke,
habe nur schon mehrfach gesehen das diskussionen entstehen wenn man das nicht
vorweg angibt das man die RAM problematik von 32Bit Systemen kennt.

Auf dem Server läuft eine Pervasive in der Version 8, deswegen auch der 32Bit Modus.
Auf dem Client läuft ein Win XP SP3 wurde aber auch schon mit SP2 probiert.

So aber nu zum eigentlichen Problem:
Nach dem Start von Büroware auf dem Client was auch schon nicht besondert schnell geschiet,
läuft Büroware "eigentlich" erträglich. Sollte ich aber ein Beleg erstellen in dem eine Kundenadresse
eingefügt wird, hängt das ganze Büroware für ca 20sec. Das passiert immer weider an verscheidenen
stellen in der Büroware. Hier konnte ich den Fehler aber reproduzieren.

Ich habe schon verscheidene dinge versucht um dem Fehler Herr zu werden.
HDD last in den besagten 20sec überprüft-->unter 5%
CPU last in den besagten 20sec überprüft--> schwankt zwischen 0 und 7%
Netzwerk last in den besagten 20sec überprüft--> schwankt zwischen 0 und 10%
Dieses Problem betrifft auch nur Büroware, wenn ich in der zeit in der Büroware
hängt, Dateien auf den Server kopiere habe ich volle Gbit performance.
Der Server ist auch wunderbar ansprechbar.
Starte ich die Büroware lokal auf dem Server ist der fehler nicht zu erkennen.

Bin mit meinem latein am ende, habe schon den Traffic zwischen Client und Server
gesnifft. Virenscanner deinstalliert. Neuen DC und DNS Server aufgesetzt da ich
ein DNS problem im verdacht hatte. Das Netzwerk flutsch in jedem Bereich.
Nur die Büroware macht schwierigkeiten, hatte jemand das selbe problem
schon mal und kennt eine Lösung?

Danke schon mal im vorrauß.....
Mitglied: ATSOLDNER
12.05.2009 um 21:53 Uhr
Hallo ,

Das Problem ist nicht DNS , sondern Pervasive!
Geh mal am server ins Pervasive Controlcenter , geh auf die Engine(Server) such dort die Communication Protocols
und trag dort unter Listen IP Adress: die IP des Servers ein !

Dienst stop -> start

Weiters trage auf den Clientrechnern den dort auch angegebenen Port ( bei mir ist es 1583) in's Service - File ( c:\windows\system32\drivers\etc ) ein! und um DNS zu beschleunigen trage in das Host file die IP adresse und den Netbiosnamen des BW servers ein !

Das wirkt Wunder !

LG aus ÖSILAND

@Performance: Mein Server 4 x Quad , 32GB RAM Server2003r2 sp2 64Bit 1TB Raid10 Pervasive10.1 BW 5.31 2xGBIT-Lan(balancing) 25 Clients
Bitte warten ..
Mitglied: robertft
11.10.2010 um 12:48 Uhr
Hallo!
Ist dieses Problem noch aktuell ? - Oder hat diese Einstellungssache funktioniert ?

Mir wurde z.B. empfohlen, diese Clientrechner gar nicht zu benutzen, dann ging nämlich die Performance in den Keller! Daraufhin haben wir alles auf einen Terminalserver ausgelagert, der auch gleichzeitig Datenbank-Server ist!

Die Performance stieg rasant an! Nun ist es aber technisch nicht möglich viele User auf einen TS zu bedienen (Hauptspeicherproblem) und bin gezwungen, wieder nach einer Clientlösung zu suchen!

Auch ich hatte bei der Client-Lösung den Verdacht, daß sich Pervasive-Server und der Pervasive-Client nicht richtig verstehen!

Gibt es hierzu irgendwelche Erklärungen im Netz ?

Gruß
Robert Frohn
Bitte warten ..
Mitglied: vossi31
22.12.2010 um 10:43 Uhr
Hallo,

meine Erfahrungen beziehen sich nicht auf Büroware sondern nur auf Pervasive. Seit vielen Jahren entwickle ich Software mit Magic/uniPaaS für die Pervasive Datenbank. Der typische Anwender meiner Software arbeitet mit 5 bis 20 Usern mit der Pervasive-Datenbank in einem normalen LAN und Win2000/2003/2008-Server. In einem kleinen Netz kann der Server auch unter XP laufen. Die Anwendung läuft durchweg sehr schnell und zuverlässig, so dass ich die geschilderten Erfahrungen zu Pervasive absolut nicht teilen kann. Bei der Installation kann i.d.R. mit den Standardvorgaben gearbeitet werden. Die Datenbank kann transaktional oder relational (per ODBC) angesprochen werden. Die Datenbank-Funktion auf dem Server läuft für 10 User locker so nebenbei. Allerdings sollte das Netzwerk gut ausgelegt sein, da die Clients oft große Datenmengen anfordern und diese erst auf dem Client gefiltert werden. Fazit: Performance-Probleme werden sicherlich nicht durch Pervasive ausgelöst sondern liegen wohl eher in Büroware oder Netzwerkschwächen.

Es gibt inzwischen die DB übrigens auch in 64Bit. Ich weiss allerdings nicht ob Büroware Restriktionen setzt.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...