Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bat Internetverbindung mit vbs testen

Frage Microsoft Windows Tools

Mitglied: OKIDOKI

OKIDOKI (Level 1) - Jetzt verbinden

12.03.2012, aktualisiert 18.10.2012, 3022 Aufrufe, 10 Kommentare

Guten morgen,

für einen kurzen Test, ob eine Internetverbindung vorhanden ist, komme ich leider nicht weiter. Die Ausgabe des Tests soll in einer batrch weiterverarbeitet werden, dazu wurde vorher eine vbs Abfrage erzeugt. Es passiert aber leider weiter gar nicht, außer, dass eine Datei "20" erzeugt wird, in der steht: " if i then Exit Do"
PS: Vielleicht geht es auch einfacher ohne vbs?

Hier mein bisheriger Code:

01.
  
02.
@ECHO OFF & SETLOCAL 
03.
 
04.
:: Beginn vbs 
05.
 >%temp%\msgbox.vbs ECHO Option Explicit  
06.
>>%temp%\msgbox.vbs ECHO Dim oIE  
07.
>>%temp%\msgbox.vbs ECHO Dim Test, i  
08.
>>%temp%\msgbox.vbs ECHO Set oIE = CreateObject ("InternetExplorer.Application")  
09.
>>%temp%\msgbox.vbs ECHO With oIE  
10.
>>%temp%\msgbox.vbs ECHO   .navigate "http://google.de"  
11.
>>%temp%\msgbox.vbs ECHO   .visible = False  
12.
>>%temp%\msgbox.vbs ECHO   do until .readystate=4   
13.
>>%temp%\msgbox.vbs ECHO     wscript.sleep 100  
14.
>>%temp%\msgbox.vbs ECHO     if i > 20 then Exit Do 
15.
>>%temp%\msgbox.vbs ECHO     i = i + 1  
16.
>>%temp%\msgbox.vbs ECHO   loop  
17.
>>%temp%\msgbox.vbs ECHO     Test = .readystate       
18.
>>%temp%\msgbox.vbs ECHO   .quit  'IE wird geschlossen  
19.
>>%temp%\msgbox.vbs ECHO End with  
20.
>>%temp%\msgbox.vbs ECHO Set oIE = nothing 
21.
:: ende vbs 
22.
 
23.
:: weiter im batch 
24.
"%temp%\msgbox.vbs" 
25.
SET /A "inet=%.readystate%" 
26.
del "%temp%\msgbox.vbs" 
27.
 
28.
IF %inet%==4 (GOTO :gleich) else (goto :ungleich) 
29.
 
30.
:gleich 
31.
echo läuft 
32.
pause 
33.
exit 
34.
 
35.
:ungleich 
36.
echo läuft nicht 
37.
pause 
38.
exit
Gruß OKIDOKI
Mitglied: bastla
12.03.2012 um 11:35 Uhr
Hallo OKIDOKI!

Eher so (ungetestet):
01.
@ECHO OFF & SETLOCAL 
02.
 
03.
:: Beginn vbs 
04.
 >%temp%\msgbox.vbs ECHO Option Explicit  
05.
>>%temp%\msgbox.vbs ECHO Dim oIE, i  
06.
>>%temp%\msgbox.vbs ECHO Set oIE = CreateObject ("InternetExplorer.Application")  
07.
>>%temp%\msgbox.vbs ECHO With oIE  
08.
>>%temp%\msgbox.vbs ECHO   .navigate "http://google.de"  
09.
>>%temp%\msgbox.vbs ECHO   .visible = False  
10.
>>%temp%\msgbox.vbs ECHO   do until .readystate=4   
11.
>>%temp%\msgbox.vbs ECHO     wscript.sleep 100  
12.
>>%temp%\msgbox.vbs ECHO     if i > 20 then Exit Do 
13.
>>%temp%\msgbox.vbs ECHO     i = i + 1  
14.
>>%temp%\msgbox.vbs ECHO   loop  
15.
>>%temp%\msgbox.vbs ECHO     WScript.Echo .readystate       
16.
>>%temp%\msgbox.vbs ECHO   .quit  'IE wird geschlossen  
17.
>>%temp%\msgbox.vbs ECHO End with  
18.
>>%temp%\msgbox.vbs ECHO Set oIE = nothing 
19.
:: ende vbs 
20.
 
21.
:: weiter im batch 
22.
set /a inet=-1 
23.
for /f %%i in ('cscript //nologo "%temp%\msgbox.vbs"') do SET /A "inet=%%i" 
24.
del "%temp%\msgbox.vbs" 
25.
 
26.
IF %inet%==4 (GOTO :gleich) else (goto :ungleich) 
27.
 
28.
:gleich 
29.
echo läuft 
30.
pause 
31.
exit 
32.
 
33.
:ungleich 
34.
echo läuft nicht 
35.
pause
Grüße
bastla

[Edit] Zeile 23 korrigiert [/Edit]
Bitte warten ..
Mitglied: OKIDOKI
12.03.2012 um 11:43 Uhr
Moin,

leider passiert gar nichts ...
Batch steigt gleich wieder aus!

Gruß OKIDOKI
Bitte warten ..
Mitglied: bastla
12.03.2012 um 11:52 Uhr
Hallo OKIDOKI!

Sollte jetzt gehen (Änderung ist oben bereits enthalten) ...

Grüße
bastla
Bitte warten ..
Mitglied: OKIDOKI
12.03.2012 um 12:08 Uhr
Hallo bastla,

Meldung kommt!
Ziehe ich allerdings einfach nur das Internetkabel raus, wird immer noch eine Verbindung gemeldet.

Hast du dafür auch noch eine Idee?

Gruß OKIDOKI
Bitte warten ..
Mitglied: bastla
12.03.2012 um 12:11 Uhr
Hallo OKIDOKI!

Etwa "ping"?

Grüße
bastla
Bitte warten ..
Mitglied: OKIDOKI
12.03.2012 um 12:30 Uhr
Hallo bastla,

nur wie ... ?

Gruß OKIDOKI
Bitte warten ..
Mitglied: OKIDOKI
12.03.2012, aktualisiert 18.10.2012
Hallo bastla,

hier noch ganz einfache einfache Lösung von Biber:
http://www.administrator.de/forum/vorhandensein-einer-internetverbindun ...

Damit funktioniert es bei mir super.

Danke bastla und Gruß
OKIAM
Bitte warten ..
Mitglied: bastla
12.03.2012 um 15:16 Uhr
Hallo OKIDOKI!

Die "Kurzfassung" in der zweiten Variante sollte es in den meisten Fällen auch tun, die "TTL"-Abfrage ist allerdings die noch sicherere Variante - und
ping www.google.de -n 1 2>nul|find "TTL">nul && goto :InetOK
ist ja auch nicht so dramatisch länger ...

Grüße
bastla
Bitte warten ..
Mitglied: OKIDOKI
12.03.2012 um 16:07 Uhr
Hallo bastla,

ja, das hört sich gut und würde ich der "Sicherheit" wegen auch nehmen

GrußOKIDOKI
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Outlook & Mail
MAPI-Schnittstelle testen: MAPI-Problem Outlook 2013 (3)

Frage von BirdyB zum Thema Outlook & Mail ...

Vmware
Internetverbindung auf ESXi Server (1)

Frage von ThomasMann zum Thema Vmware ...

Entwicklung
gelöst Hilfe bei .bat script (1)

Frage von RUBEN123 zum Thema Entwicklung ...

LAN, WAN, Wireless
Internetverbindung funktioniert erst nach ipconfig renew (6)

Frage von Joshh1 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...