Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bat Prozedur bricht immer nach ca. 4 min. ab

Frage Entwicklung Batch & Shell

Mitglied: snowhill

snowhill (Level 1) - Jetzt verbinden

12.12.2007, aktualisiert 13.12.2007, 3172 Aufrufe, 1 Kommentar

bild.bat

Hallo

Folgendes:
Ich habe eine Datei:

Bild.bat

mit folgenden Code:
rcp elektra:/usr/elektra/archiv99/TD_01000_8588_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8588.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8590_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8590.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8606_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8606.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8607_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8607.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8608_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8608.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8613_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8613.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8628_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8628.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_8630_0_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-8630.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9132_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9132.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9133_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9133.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9136_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9136.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9138_B_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9138.CIP
rcp elektra:/usr/elektra/archiv99/TD_01000_9139_A_01.CIP katalog:/ekat/eltis_cd/eltis_cd/cip/01-9139.CIP
..........

ca. 1000 Zeilen

ABER:
Nach 4 Minuten bricht er den Vorgang ab

Fehlermeldung:
Keine.
Der Kopiervorgang bleibt einfach stehen, die Befehlszeile zeigt er noch an aber das Bild wird nicht kopiert.

Betriebssystem Windows 2000 SP4 (bei Windows 2000 SP2 hat es funktioniert - ich weiß aber nicht ob weitere Einstellungen getätigt wurden)

Lösungsversuche:
Öffne ich ein neues CMD-Fenster und tippe den Befehl ab, bei dem er stehen geblieben ist funktioniert es ohne Probleme
Lösche ich die ersten 100 Zeilen und starte erneut, dann kommt er ungefähr 100 Zeilen weiter... d.h. er bricht immer nach einer bestimmten Zeit (ca. 4 Min. ab)

Hat jemand eine Ahnung woran das liegen könnte???

Vielen Dank - Snowhill
Mitglied: Biber
13.12.2007 um 06:52 Uhr
Moin Snowhill,

dieses Verhalten deuten ja darauf hin, dass die Befehle nicht nacheinander gestartet werden (wie es die Batchdatei suggeriert) sondern parallel.
Und dann ist natürlich irgendwann dicht - z.B. die Anzahl paralleler Download-Connections ausgereizt.

Abhilfe:
  • entweder die rcp-Aufrufen ändern in "Start /w rcp...[bla]..."-Aufrufe
  • oder, falls die rcp-Aufrufe irgendeine Bildschirmausgabe haben (z.B "...file copied.."), diese umleiten in eine Datei und erst weitermachen, wenn diese Datei da ist.

Grüße
Biber
Bitte warten ..
Ähnliche Inhalte
Exchange Server
EX 2106 Setup bricht ab (2)

Frage von akae11 zum Thema Exchange Server ...

Windows Server
gelöst Netzwerk bricht unerwartet zusammen (9)

Frage von Jan1986 zum Thema Windows Server ...

Windows Netzwerk
RDP-Verbindung bricht ab - Win 2000 als ThinClient umfunktioniert (3)

Frage von c0d3.r3d zum Thema Windows Netzwerk ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(6)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(39)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Windows 10
gelöst Windows 10 Home "Netzlaufwerk nicht bereit" (19)

Frage von Oggy01 zum Thema Windows 10 ...

SAN, NAS, DAS
+100tb Storagelösung (13)

Frage von Data-Fabi zum Thema SAN, NAS, DAS ...

LAN, WAN, Wireless
Cisco W-Lan Controller als Applicance oder Software (11)

Frage von Herbrich19 zum Thema LAN, WAN, Wireless ...

DNS
gelöst Komplette TLD Überschreiben bzw eigene Definieren (10)

Frage von Herbrich19 zum Thema DNS ...