Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch Datei wird nicht bei geplante Tasks ausgeführt

Frage Microsoft

Mitglied: d.mayer

d.mayer (Level 1) - Jetzt verbinden

17.08.2011, aktualisiert 25.08.2011, 11425 Aufrufe, 17 Kommentare

Umgebung:
Windows Storage Server 2008 Standard (englisch)

Hallo Leute

Habe für eine Sicherung einen kleines Script geschrieben so dass, die Daten einfach mit diesen Script kopiert werden.

Script:
Datei Name: sicherung.bat (habe auch schon versucht die Dateiendung auf .cmd zu ändern)
Inhalt:

cmd /k robocopy w:\ D:\Backup\ /MIR /XN /R:1 /W:10
exit

Bitte um Hilfe. Danke

Daniel
Mitglied: Logan000
17.08.2011 um 12:48 Uhr
Moin Moin

Wird der Batch denn fehlerfrei ausgeführt wenn du ihn manuell startest?

Gruß L.
Bitte warten ..
Mitglied: d.mayer
17.08.2011 um 13:57 Uhr
Ja ohne Probleme.

Daniel
Bitte warten ..
Mitglied: Logan000
17.08.2011 um 14:04 Uhr
Moin

Dann würde ich mal blind auf Berechtigungen tippen.
Unter welchem Benutzer wird der Task denn ausgeführt und hat der entsprechende Berechtigungen an den Verzeichnissen?

Hat das Benutzerkonto auch die gleichen Laufwerke (W: ist doch bestimmt ein Netzlaufwerk) wie du?

Gruß L
Bitte warten ..
Mitglied: d.mayer
17.08.2011 um 14:16 Uhr
Ja wenn ich das Script direkt am Server als Administrator manuell starte gibt es keine Probleme und der Benutzer hat alle Rechte die benötigt werden.

Gruß Daniel
Bitte warten ..
Mitglied: Logan000
17.08.2011 um 14:50 Uhr
Moin

Ja wenn ich das Script direkt am Server als Administrator manuell starte gibt es keine Probleme
Dann wird es auch keine Probleme geben wenn du am Server einen Task einrichtest der unter den Konto des Administrators ausgeführt werden soll.

Falls es dennoch nicht laufen sollte
- schau im Ereignisprotokoll ob sich dort etwas findet.
- Prüfe ob der entsprechende Dienst läuft.

Gruß L.
Bitte warten ..
Mitglied: Skyemugen
17.08.2011 um 14:54 Uhr
Aloha,

19 Seiten an Kommentaren und ich find' den Thread nicht, wo dieses Problem oder war es zusammen mit dem Ruhezustand ... unter Windows 7 auftrat und ich herausfand, dass es an einer bestimmten Einstellung lag ..
Es war etwas banales bei den Einstellungen im Task / in der Aufgabe selber, leider fehlt mir momentan die Zeit noch einmal ganz genau danach zu suchen ...

... eventuell heute Abend, wenn ich mehr Zeit habe oder du probierst noch ein wenig mit den Optionen hin und her, ich glaube Ausführen unter Benutzer (Administrator) (oder so ähnlich, habe gerade nur XP-Rechner verfügbar) war damals der Knackpunkt, der nicht funktionierte aber ich weiß es gerade nicht sicher.

greetz André
Bitte warten ..
Mitglied: d.mayer
18.08.2011 um 14:26 Uhr
Im Ereignisprotokoll steht:

Task Scheduler failed to start "\sicherung" task for user "DOMÄNE\Administrator". Additional Data: Error Value: 2147750687.


Erforderliche Dienste laufen.

@Skyemugen Wäre super wenn du was passendes für mich hättest.

Danke an Alle
Bitte warten ..
Mitglied: Skyemugen
18.08.2011 um 14:41 Uhr
Aloha,

da ich gestern nicht mehr den Nerv dazu hatte (und heute Abend keine Zeit, sorry) - poste doch mal deine Taskeinstellungen, was du alles aktiviert / eingestellt hast, dann wissen wir schon einmal diese Fakten (höchste Privilegien etc. etc. Ausführen, wenn User logged in ist ...)

Der Fehlercode an sich könnte durchaus daraus hinauslaufen, dass du die Option whether the user is logged in or not oder so ähnlich, nicht aktiviert hast.

greetz André
Bitte warten ..
Mitglied: Skyemugen
18.08.2011 um 15:55 Uhr
Aloha,

gut, dann nimm' mal das Häkchen bei den highest privileges raus und evtl. noch auf Seite 5 bei run on demand. Bei den Privilegien weiß ich, dass dies ebenfalls einer der Knackpunkte das letzte Mal war, das andere kann ich nicht ganz sicher sagen, ob es Auswirkungen hat, weil ich es nie nutze

Sollte es wider Erwarten weiterhin regungslos bleiben, muss ich doch noch einmal den Thread suchen, denn da war noch irgendein Punkt in Sachen user, was sollte und was nicht aber außer dir zu sagen, die Häkchensetzung auf Seite 1 zu variieren, könnte ich dir sonst momentan nichts weiter schreiben.

greetz André
Bitte warten ..
Mitglied: d.mayer
19.08.2011 um 09:36 Uhr
Hat wurde leider wieder nicht aufgeführt.

@Skyemugen
Hast du vielleicht noch weitere Lösungsansätze?

Danke im Voraus.
Bitte warten ..
Mitglied: Logan000
22.08.2011 um 08:42 Uhr
Moin Moin

Im Ereignisprotokoll steht:
Task Scheduler failed to start "\sicherung" task for user "DOMÄNE\Administrator". Additional Data: Error Value: 2147750687.

Zu dieser Fehlermeldung habe ich diesen vielversprechenden Beitrag gefunden:
http://social.technet.microsoft.com/Forums/en/winservergen/thread/0c4e3 ...

Schau dir das mal genauer an.

Gruß L.
Bitte warten ..
Mitglied: d.mayer
23.08.2011 um 09:36 Uhr
Hat leider auch nicht geholfen aber vielen Dank.

Daniel
Bitte warten ..
Mitglied: d.mayer
30.08.2011 um 11:38 Uhr
Hat vielleicht sonst noch jemand eine Lösung?
Bitte warten ..
Mitglied: 99045
30.08.2011 um 12:54 Uhr
Zitat von d.mayer:
cmd /k robocopy w:\ D:\Backup\ /MIR /XN /R:1 /W:10

Hi,

wozu soll cmd /k gut sein?
Warum führst du den Task nicht einfach mit
01.
{kompletter Pfad zu\]robocopy{.exe} w:\ D:\Backup\ /MIR /XN /R:1 /W:10
aus?
Bitte warten ..
Mitglied: d.mayer
31.08.2011 um 14:50 Uhr
Werde ich testen.
Vielen Dank.
Bitte warten ..
Mitglied: d.mayer
01.09.2011 um 11:25 Uhr
Vielen Dank hat funktioniert.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...