Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch-Datei wird nicht komplett ausgeführt

Frage Microsoft Windows Tools

Mitglied: franc

franc (Level 2) - Jetzt verbinden

23.01.2009, aktualisiert 09:55 Uhr, 6292 Aufrufe, 16 Kommentare

Hallo,

ich habe ein Problem mit einer Batchdatei mit Parameter:
Ich sichere (mit snapshot) täglich (mit MS-Task) nacheinander mehrere Partitionen eines Servers, aber nach der ersten erfolgreichen Partitions-Sicherung hört der Batchauftrag einfach auf:

Aufruf der Batchdatei:

sichern.bat Montag

Der Inhalt der Batchdatei:

snapshot C: E:\%1\C-sicherung.sna
snapshot D: E:\%1\D-sicherung.sna

Laufwerk C: wird fehlerfrei gesichert, aber danach hört das Batchfile einfach auf. Die Ausgabe enthält aber auch überhaupt keinen Fehler, als ob es normal wäre, dass die zweite Zeile gar nicht ausgeführt werden müsste.

Wie kann ich nun herausfinden, warum die zweite Zeile nicht ausgeführt wird? Brauche ich vielleicht ein "Call" davor?
Das testen (mit snapshot) ist leider unheimlich langwierig, weil es 3 h dauert, bis eine Partition gesichert ist.

Danke, falls mir jemand hier in der Not hilft.

Gruß, franc
Mitglied: NetWolf
23.01.2009 um 10:17 Uhr
Hallo franc,

*Handbookreaderror*

wie du hier lesen kannst: http://www.drivesnapshot.de/de/commandline.htm

solltest du mal die Option -W probieren

Option -W [Wait]
Wenn Drive Snapshot gestartet wird, und beim Start befindet sich der Cursor ganz oben links, nimmt er an, dass er von einem Batchfile gestartet wurde, und wartet auf den <ANY KEY>, damit Sie das Ergebnis kontrollieren können.
Dieses Warten kann mit -W unterdrückt werden.

BTW könnte der Parameter deiner Batchdatei auch automatisch gesetzt werden (wenn es kein Ordner sein muss):

Erzeugen von Dateinamen mit Datum, Wochentag,...
wenn der gegebene Dateiname spezielle Kennungen enthält, werden ersetzt
$date Datum 6-stellig als JJMMTT
$computername der Computername
$type für differentielle Images --> 'dif'
$disk der Laufwerksbuchstabe (C,D,...)
$weekday Wochentag in 2 Buchstaben
$year 4-stellige Jahreszahl
$month Monat (1..12)
$day Tag (1..31)


Grüße aus Schönberg (Lübeck)
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: franc
23.01.2009 um 12:37 Uhr
Zitat von NetWolf:

solltest du mal die Option -W probieren


Leider leider leider hab ich das schon probiert mit dem Schalter -W
Es ändert nichts.
Außerdem würde "er" ja dann warten, auf eine Tastatureingabe, aber das macht er ja auch nicht.
Er hört einfach auf mit dem Batchfile, als ob das der letzte Eintrag gewesen wäre.

Brauch ich ein "call"?
Bitte warten ..
Mitglied: 60730
23.01.2009 um 15:13 Uhr
Servus,

-t ist nur für den Scheduler notwendig.

Ich vermute den Fehler nicht in der Batch, sondern woanders.

01.
snapshot C: E:\%1\C-sicherung.sna 
02.
echo Status: %errorlevel% 
03.
pause 
04.
snapshot D: E:\%1\D-sicherung.sna
Probiers mal so herum.

Uns als "Beweis" schicke ich auch gleich mal meine Asbachuralte - die 100% läuft (wenn genug Platz usw da ist)
Btw. Welche version setzt du ein?

01.
set %f=\\server\freigabe 
02.
@Title Backup von %computername% auf %f%\%computername% 
03.
if not exist %F%\%computername%\c_%computername%.hsh goto 1strunc 
04.
goto 2ndrunc 
05.
 
06.
:1strunc 
07.
if not exist %F%\%computername%\ md %F%\%computername% 
08.
cls 
09.
snapshot.exe c: %F%\%computername%\$disk-voll.sna -r -t  -l650 -o%F%\%computername%\c_$computername.hsh 
10.
:2ndrunc 
11.
snapshot.exe c: %F%\%computername%\$disk-$date-$hour.sna -h%F%\%computername%\c_$computername.hsh 
12.
 
13.
if exist d:\>nul md d:\test4write 
14.
if not exist d:\test4write\ goto end 
15.
rd /q d:\test4write  
16.
 
17.
if not exist %F%\%computername%\d_%computername%.hsh goto 1strund 
18.
goto 2ndrund 
19.
 
20.
:1strund 
21.
snapshot.exe d: %F%\%computername%\$disk-voll.sna -r -t  -l650 -o%F%\%computername%\d_$computername.hsh 
22.
 
23.
:2ndrund 
24.
c:\script\snapshot.exe d: %F%\%computername%\$disk-$date-$hour.sna -h%F%\%computername%\d_$computername.hsh 
25.
 
26.
:end
Die Batch sollte "selbsterklärend" sein - falls nicht gib Feedback.

Snapshot arbeitet ansich ein Script sauber ab. Wie geschrieben, daran liegt es nicht - sondern woanders.
Aber das kannst nur du rausfinden....

Gruß

edit:

NEIN bloos nicht als 2 Batche!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Ursache suchen und beheben - nicht rumdoktern

/edit
Bitte warten ..
Mitglied: NetWolf
23.01.2009 um 15:15 Uhr
ok, dann probiere es einfach mal mit Call aus!
dann aber mit einer zweiten Batch-Datei!

obwohl, dann könntest du die Aufrufe auch gleich als zwei Tasks eingeben
was u.U. vielleicht sowieso besser wäre?

Grüße aus Schönberg (Lübeck)
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: franc
23.01.2009 um 15:31 Uhr
Vielen Dank!

Zitat von 60730:
Btw. Welche version setzt du ein?


Die neueste Version 1.39

NEIN bloos nicht als 2
Batche!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Ursache suchen und beheben - nicht rumdoktern


Das ginge auch nicht wirklich. Weil ich ja nicht weiß, wann die erste Sicherung fertig ist.
Und wenn snapshot läuft, während eine andere Sicherung läuft, bricht es mit Fehler ab.
Außerdem muss ich sogar drei Partitionen sichern, der Einfachheit halber hab ich das aber hier reduziert.
Bitte warten ..
Mitglied: 60730
23.01.2009 um 16:06 Uhr
Servus again,
Das ginge auch nicht wirklich. Weil ich ja nicht weiß, wann die erste Sicherung fertig ist.
jaaaanz jenau Gefahr erkannt - Gefahr gebannt

Sag mal...
Sicherst du auf ein USB Drive?
Wenn ja - da liegt der Hund begraben....

Gruß
Bitte warten ..
Mitglied: franc
23.01.2009 um 16:09 Uhr
Sicherst du auf ein USB Drive?
Wenn ja - da liegt der Hund begraben....

JAAAAAA! Wo ist der HUND, der tote???
Bitte warten ..
Mitglied: 60730
23.01.2009 um 16:12 Uhr
Wo ist der HUND, der tote???
am Datenstrom vom Drivesnapshot, der abreisst -wenn die Daten via USB gedrückt werden.

Mies:
Daten -> USBController -> Usbport -> USB2xATAkonverter -> Festplatte
Besser:
Freigabe auf "Server" oder Einbau einer externen Sata Lösung.

Gruß
Bitte warten ..
Mitglied: franc
23.01.2009 um 16:21 Uhr
Ach so!
Aber was wäre davon zu halten:

Daten(Part1)->BAK-Part3
BAK-Part3-> USB-Platte

Daten(Part2)->BAK-Part3
BAK auf Part3 -> USB-Platte

Daten(Part3)->BAK-Part2
BAK auf Part2 -> USB-Platte

Also erst auf einer anderen Partition zwischenlagern und dann verschieben auf die USB-Platte.

Außerdem: kann das denn die Ursache dafür sein, dass der Batch-Auftrag nicht weiterläuft?
Bitte warten ..
Mitglied: 60730
23.01.2009 um 16:27 Uhr
Servus...

genauso mache ich das auch...

1. Sammeln der Daten auf einem Server (siehe obiges Script)
2. verschieben der Daten auf eine Sata Platte, die - wenn Sie voll ist in den Safe kommt via:
robocopy.exe X:\Backup f:\ /mov /e
der Job läuft allerdings auf dem Server, der die externe Platte angeschlossen hat!
Diese Zeile Nicht in die Batch einpflegen!

Also erst auf einer anderen Partition zwischenlagern und dann verschieben auf die USB-Platte.

Yupp - macht das Restore "schneller", denn so kannst du direkt aus Bart restoren, ohne das Netzwerk bemühen zu müssen.
Außerdem: kann das denn die Ursache dafür sein, dass der Batch-Auftrag nicht weiterläuft?
"woher" denkst du weiß ich das und habe dir die Frage gestellt, ob auf USB gesichert wird?
Trial and Error ist mein zweiter Name

Gruß
Bitte warten ..
Mitglied: franc
23.01.2009 um 16:51 Uhr
Zitat von 60730:
"woher" denkst du weiß ich das und habe dir die Frage
gestellt, ob auf USB gesichert wird?

Weiß nicht.

Also erst auf einer anderen Partition zwischenlagern und dann verschieben auf die USB-Platte.

Mist. Ich habe nicht genug Platz auf der dritten Partition (oder sonst einer).
Und es gibt zuverlässig nur diesen Server, der immer läuft im Netz.

Vielleicht mit Tricks, dass die snapshot Teile (z.B. 1,5 GB groß) sofort verschoben werden, geht das?
Bitte warten ..
Mitglied: 60730
23.01.2009 um 17:03 Uhr
Zitat von franc:
Weiß nicht.

..dann denk mal drüber nach

Vielleicht mit Tricks, dass die snapshot Teile (z.B. 1,5 GB
groß) sofort verschoben werden, geht das?

Nein - selbst wenn - beim Backup gebe ich nur gute Tipps, keine fummeleien weiter.

..denn:

Snapshot ist rel. schnell - das moven per robocopy auf USB dauert.
Solange muß das weitere Snappen warten und das geht einfach nicht.

Selbst wenn - der Platz muß für eine Partion reichen - mittendrin verschieben ist wie - sorry -mir fällt grade kein "fieserer" Vergleich als Den Ast auf dem man sitzt absägen - ein.

Ergo - besorg dir eine größere Platte für den Server und fertig ist der Lack.
Und es gibt zuverlässig nur diesen Server, der immer läuft im Netz.

Für den Zweck "passt" sogar ein Billich willich NAS von Lacie und Konsorten"
mach et rischdisch

"fummeln" macht nur im Kino Spass, nicht beim Backup

Gruß
Bitte warten ..
Mitglied: franc
23.01.2009 um 17:08 Uhr
Zitat von 60730:
..dann denk mal drüber nach

Das einzige was ich mir erklären kann ist, dass du mal Probleme bei einer Batchsicherung in Verbindung mit externen USB-Platten gehabt hast. Aber das ist keine technische Erklärung, sondern eine Vermutung.

Ergo - besorg dir eine größere Platte für den Server

Mist. Da muss ich dann extra hinfahren (300km einfach).
Keine andere Möglichkeit?
Bitte warten ..
Mitglied: 60730
23.01.2009 um 17:12 Uhr
Mist. Da muss ich dann extra hinfahren (300km einfach).
Keine andere Möglichkeit?

Doch kauf ein NAS von Lacie oder ein anderes sauberes mit Raid1 - vergib eine feste IP, die 300KM weiter weg frei ist für das Teil und schicke es per Overnight Kuriere (die passen besser auf die Pakete auf, als die gelben Jungs) und bitte jemanden in der Niederlassung das NAS dort anzuschliessen.

Das einzige was ich mir erklären kann ist..

Fast richtig - ich hab den Datenstrom "komplett" gemessen, dann die Kette (s. o.) verkürzt und bin der Ursache so auf den Grund gekommen.

Gruß
Bitte warten ..
Mitglied: franc
23.01.2009 um 17:58 Uhr
Kann das sein, dass diese USB-Sicherungsaktionen den Server zum Stillstand bringen?
Das ist nämlich ein viel größeres Problem, der Server bleibt, gerade gerne bei den Sicherungen, stehen. Die Maus läßt sich noch in bißchen bewegen, aber ansonsten reagiert er nicht mehr.
Netzwerkverkehr funktioniert auch noch ein bißchen.
Und er bleibt gerne bei 59% des Images von Platte C stehen (er hat ein Raid1 Verbund).
Bitte warten ..
Mitglied: franc
29.01.2009 um 01:50 Uhr
Ich habe das Problem schließlich, mit Hilfe des geduldigen Snapshot-Supports gefunden:

Ich hatte in meinem MS-Task-Auftrag unter:

Eigenschaften / Einstellungen / Task beenden nach: 1h

eingetragen (default: 72h) und das beendet dann die Batch bevor alle Befehle durchlaufen sind.
Weil jeder Test einige Stunden gedauert hatte, wars mir nicht aufgefallen.
Der Support hat mich dann irgendwann draufgebracht

Mit der externen USB-Platte hatte es dann gottlob doch nichts zu tun gehabt. So kann ich beruhigt und erfolgreich weiter auf diese Weise sichern. Uff.

Gruß, franc
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...