Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch funktioniert plötzlich nicht mehr

Frage Microsoft

Mitglied: amenne

amenne (Level 1) - Jetzt verbinden

18.04.2012 um 16:10 Uhr, 2465 Aufrufe, 3 Kommentare

for-Schleife wird nicht abgearbeitet

Hallo,

vielleicht hat jemend eine Lösung für mein neues Problem? Mein Script lief tadellos, dann habe ich ein bisserl herumprobiert (wollte Eingabe des Ordners über %1 ermöglichen), dann wieder zurück geändert und nun wird einfach die For-Schleife nicht abgearbeitet. Ohne Fehlermeldung. Woran könnte das liegen?

Script:

01.
@echo off & setlocal  EnableDelayedExpansion 
02.
for /d %%v in ("I:\Pat_Dat\testtest\*.*") do ( 
03.
	pushd "%%v" 
04.
	ECHO.working now in: 
05.
	ECHO.%%v 
06.
	for %%f in (*.*) do ( 
07.
		:: Directory mit Namen der Größe anlegen und Datei hineinkopieren 
08.
		set dateigroesse=%%~zf 
09.
		set /a "dateigroesse=!dateigroesse! /1024" 
10.
		if not exist "!dateigroesse!" md "!dateigroesse!" 
11.
		xcopy %%f "!dateigroesse!" 
12.
13.
	popd 
14.
)
Ratlose Grüße,

AM
Mitglied: amenne
18.04.2012 um 16:22 Uhr
Hi, sorry, hat sich erledigt. Wenn kein Ordner im Verzeichnis ist kann for /d natürlich auch nichts finden

Grüße, AM
Bitte warten ..
Mitglied: 106009
18.04.2012 um 16:22 Uhr
Hi
Ohne Fehlermeldung. Woran könnte das liegen?

An @echo off

Gruß
Bitte warten ..
Mitglied: amenne
18.04.2012 um 16:31 Uhr
Hi,

aber

ECHO.working now in:

würde trotzdem angezeigt werden, wenn zumindest die For-Schleife einmal durchlaufen würde.


Grüße
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
W-LAN funktioniert plötzlich nicht mehr wenn geschützt! (41)

Frage von PaddyCarlos zum Thema LAN, WAN, Wireless ...

Windows 10
Powercg-Einstellung wird zugewiesen aber funktioniert nicht (1)

Frage von PharIT zum Thema Windows 10 ...

C und C++
MVVM Button.IsEnabled binding funktioniert nicht

Frage von mayho33 zum Thema C und C ...

Exchange Server
Exchange 2010 DAG funktioniert nur teilweise (1)

Frage von apex.predator24 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (21)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (20)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (18)

Frage von Pandreas zum Thema Windows Userverwaltung ...

Exchange Server
gelöst MS Exchange 2016 - Basicconfig Fragen (16)

Frage von maddig zum Thema Exchange Server ...