Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch funktioniert plötzlich nicht mehr

Frage Microsoft

Mitglied: amenne

amenne (Level 1) - Jetzt verbinden

18.04.2012 um 16:10 Uhr, 2485 Aufrufe, 3 Kommentare

for-Schleife wird nicht abgearbeitet

Hallo,

vielleicht hat jemend eine Lösung für mein neues Problem? Mein Script lief tadellos, dann habe ich ein bisserl herumprobiert (wollte Eingabe des Ordners über %1 ermöglichen), dann wieder zurück geändert und nun wird einfach die For-Schleife nicht abgearbeitet. Ohne Fehlermeldung. Woran könnte das liegen?

Script:

01.
@echo off & setlocal  EnableDelayedExpansion 
02.
for /d %%v in ("I:\Pat_Dat\testtest\*.*") do ( 
03.
	pushd "%%v" 
04.
	ECHO.working now in: 
05.
	ECHO.%%v 
06.
	for %%f in (*.*) do ( 
07.
		:: Directory mit Namen der Größe anlegen und Datei hineinkopieren 
08.
		set dateigroesse=%%~zf 
09.
		set /a "dateigroesse=!dateigroesse! /1024" 
10.
		if not exist "!dateigroesse!" md "!dateigroesse!" 
11.
		xcopy %%f "!dateigroesse!" 
12.
13.
	popd 
14.
)
Ratlose Grüße,

AM
Mitglied: amenne
18.04.2012 um 16:22 Uhr
Hi, sorry, hat sich erledigt. Wenn kein Ordner im Verzeichnis ist kann for /d natürlich auch nichts finden

Grüße, AM
Bitte warten ..
Mitglied: 106009
18.04.2012 um 16:22 Uhr
Hi
Ohne Fehlermeldung. Woran könnte das liegen?

An @echo off

Gruß
Bitte warten ..
Mitglied: amenne
18.04.2012 um 16:31 Uhr
Hi,

aber

ECHO.working now in:

würde trotzdem angezeigt werden, wenn zumindest die For-Schleife einmal durchlaufen würde.


Grüße
Bitte warten ..
Ähnliche Inhalte
Netzwerke
NIC funktioniert plötzlich nicht mehr (36)

Frage von MegaGiga zum Thema Netzwerke ...

LAN, WAN, Wireless
W-LAN funktioniert plötzlich nicht mehr wenn geschützt! (41)

Frage von PaddyCarlos zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Batch- Datei: Netzwerkzugriff funktioniert nicht (14)

Frage von 133722 zum Thema Windows Netzwerk ...

Windows Server
Dateifreigabe plötzlich weg (7)

Frage von windows10 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Firewall
Richtige Grundeinstellungen der Pfsense für mein Netzwerk (15)

Frage von Spitzbube zum Thema Firewall ...

Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...