Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Batch per GPO verteilen - funktioniert bei 2 Usern nicht

Frage Microsoft Windows Server

Mitglied: schlumpfinchen

schlumpfinchen (Level 1) - Jetzt verbinden

02.04.2010, aktualisiert 10:27 Uhr, 7437 Aufrufe, 2 Kommentare

Hallöchen - ich schon wieder

ich bin derzeit noch in der Testphase, um 3 Desktopicons per Gruppenrichtline zu verteilen.

Es gibt also ein cmd-File mit Inhalt

01.
mkdir %systemroot%\system32\abc 
02.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\xxx.ico %systemroot%\system32\abc 
03.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\Icon.lnk "%homedrive%%homepath%\desktop"
Dieses cmd-File sowie die Files xxx.ico und Icon.lnk liegen unter der jeweiligen Policy im sysvol Verzeichnis.

Meine Tests waren erfolgreich - es wurde der Ordner in system32 sowie das Desktop-Icon richtig angelegt.
Nachdem ich nun 2 Echt-User in die jeweilge Berechtigungsgruppe hinterlegt habe, haben diese mir gesagt, dass das Icon nicht da sei (und nach meiner Kontrolle ist
auch der Ordner nicht erstellt worden).
Nun, dann habe ich mich auf einem weiteren Test-PC mit diesen beiden Usern angemeldet - dort hat die Ausführung sofort funktioniert.

Habt ihr eine Idee, woran ich hier scheitere?

Clients laufen unter XP, SP3
Server: AD auf 2003, SP2

Achja, das Script vom Sysvol-Ordner geöffnet funktioniert bei den beiden Usern tadellos ...

lg
schlumpfinchen
Mitglied: bastla
02.04.2010 um 17:48 Uhr
Hallo schlumpfinchen!

Da die Icons unterhalb von "System32" gespeichert werden sollen, dürfte es eine Frage der Berechtigungen sein ...

Die einfachste Lösung wäre es (abgesehen davon, einen anderen Speicherort zu wählen ), das Kopieren der Icons per "Start"- (Computerkonfiguration) und nicht per "Logon"-Script durchzuführen ...

BTW: Ein "copy" in einem Batch überschreibt vorhandene Dateien auch ohne "/y" ...

Grüße
bastla
Bitte warten ..
Mitglied: schlumpfinchen
15.04.2010 um 14:54 Uhr
Hallöchen

Danke für eure Inputs.
Hab den Speicherort umgestellt, funktioniert soweit ganz gut.

Ein Problem hab ich noch:
ich hab noch eine Abfrage gemacht in vbs, danach wird die cmd Datei aufgerufen.
Eigentlich sollte die vbs Datei beim Computer Startup starten (und ein Programm installieren) - leider tut's das nicht.
Händisch angeworfen funktioniert die Installation.

Ich hab die GPO erstellt, und das vbs File bei Startup angegeben. Im sysvol-Ordner der GPO liegen vbs und cmd Datei.


Dankeschön im Voraus für eure Hilfe
schlumpfinchen

edit: scheinbar läuft da doch irgendwas beim Startup - im eventlog bekomm ich Warnung 108 - Application Management: "Die Änderungen an den Softwareeinstellungen wurden nicht angewendet. Fehler: Die Gruppenrichtlinienumgebung sollte die Erweiterung in der synchronen Vordergrundrichtlinienaktualisierung aufrufen". ????
Bitte warten ..
Ähnliche Inhalte
Windows Server
Lokaler Benutzer über GPO verteilen (4)

Frage von staybb zum Thema Windows Server ...

Exchange Server
Spamliste für Exchange 2010 mit GPO verteilen? (10)

Frage von traubensaft zum Thema Exchange Server ...

Windows Server
gelöst GPO soll zwangsabmeldung von Usern ermöglichen (7)

Frage von LordNicon79 zum Thema Windows Server ...

Windows Server
gelöst Druckertreiber per GPO verteilen (10)

Frage von Hendrik2586 zum Thema Windows Server ...

Neue Wissensbeiträge
Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(6)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

LAN, WAN, Wireless

Neue Cisco Catalyst-Serie 9000

Information von Kuemmel zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows 10
Netzwerkkarte schaltet sich erst nach dem Logon ein (23)

Frage von DerWoWusste zum Thema Windows 10 ...

Windows Server
Seit IP Umstellung DC DNS Fehler (18)

Frage von Yaimael zum Thema Windows Server ...

Netzwerke
Mobile Einwahl IPSec VPN von iPhone iPad T-Mobile zur Pfsense (16)

Frage von Spitzbube zum Thema Netzwerke ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (15)

Frage von Voiper zum Thema Weiterbildung ...