Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Batch per GPO verteilen - funktioniert bei 2 Usern nicht

Frage Microsoft Windows Server

Mitglied: schlumpfinchen

schlumpfinchen (Level 1) - Jetzt verbinden

02.04.2010, aktualisiert 10:27 Uhr, 7442 Aufrufe, 2 Kommentare

Hallöchen - ich schon wieder

ich bin derzeit noch in der Testphase, um 3 Desktopicons per Gruppenrichtline zu verteilen.

Es gibt also ein cmd-File mit Inhalt

01.
mkdir %systemroot%\system32\abc 
02.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\xxx.ico %systemroot%\system32\abc 
03.
copy /Y \\domain.name\SysVol\domain.local\Policies\{D20050A5-3546-471A-AF5D-768309ED440D}\User\Scripts\Logon\Icon.lnk "%homedrive%%homepath%\desktop"
Dieses cmd-File sowie die Files xxx.ico und Icon.lnk liegen unter der jeweiligen Policy im sysvol Verzeichnis.

Meine Tests waren erfolgreich - es wurde der Ordner in system32 sowie das Desktop-Icon richtig angelegt.
Nachdem ich nun 2 Echt-User in die jeweilge Berechtigungsgruppe hinterlegt habe, haben diese mir gesagt, dass das Icon nicht da sei (und nach meiner Kontrolle ist
auch der Ordner nicht erstellt worden).
Nun, dann habe ich mich auf einem weiteren Test-PC mit diesen beiden Usern angemeldet - dort hat die Ausführung sofort funktioniert.

Habt ihr eine Idee, woran ich hier scheitere?

Clients laufen unter XP, SP3
Server: AD auf 2003, SP2

Achja, das Script vom Sysvol-Ordner geöffnet funktioniert bei den beiden Usern tadellos ...

lg
schlumpfinchen
Mitglied: bastla
02.04.2010 um 17:48 Uhr
Hallo schlumpfinchen!

Da die Icons unterhalb von "System32" gespeichert werden sollen, dürfte es eine Frage der Berechtigungen sein ...

Die einfachste Lösung wäre es (abgesehen davon, einen anderen Speicherort zu wählen ), das Kopieren der Icons per "Start"- (Computerkonfiguration) und nicht per "Logon"-Script durchzuführen ...

BTW: Ein "copy" in einem Batch überschreibt vorhandene Dateien auch ohne "/y" ...

Grüße
bastla
Bitte warten ..
Mitglied: schlumpfinchen
15.04.2010 um 14:54 Uhr
Hallöchen

Danke für eure Inputs.
Hab den Speicherort umgestellt, funktioniert soweit ganz gut.

Ein Problem hab ich noch:
ich hab noch eine Abfrage gemacht in vbs, danach wird die cmd Datei aufgerufen.
Eigentlich sollte die vbs Datei beim Computer Startup starten (und ein Programm installieren) - leider tut's das nicht.
Händisch angeworfen funktioniert die Installation.

Ich hab die GPO erstellt, und das vbs File bei Startup angegeben. Im sysvol-Ordner der GPO liegen vbs und cmd Datei.


Dankeschön im Voraus für eure Hilfe
schlumpfinchen

edit: scheinbar läuft da doch irgendwas beim Startup - im eventlog bekomm ich Warnung 108 - Application Management: "Die Änderungen an den Softwareeinstellungen wurden nicht angewendet. Fehler: Die Gruppenrichtlinienumgebung sollte die Erweiterung in der synchronen Vordergrundrichtlinienaktualisierung aufrufen". ????
Bitte warten ..
Ähnliche Inhalte
Windows Server
GPO soll zwangsabmeldung von Usern ermöglichen
gelöst Frage von LordNicon79Windows Server7 Kommentare

Hallo zusammen, ich suche grad die Möglichkeit über GPOs ein Zeitfenster zur Anmeldung von Usern zu definieren. Den Punkt ...

Windows Server
Scanner per GPO verteilen
gelöst Frage von BadgerWindows Server12 Kommentare

Hallo Leute, der Titel sollte eigentlich schon alles sagen: wie kann ich einen Scanner (ist ein Scanner eines HP ...

Windows Installation
Setup.exe per GPO verteilen
Frage von flulukWindows Installation9 Kommentare

Hallo, gibt es die Möglichkeit ein Programm zu verteilen, für das es keine MSI Datei gibt? Ich versuche OpenEdge ...

Windows Server
Lokaler Benutzer über GPO verteilen
Frage von staybbWindows Server4 Kommentare

Hallo, ich möchte auf einem Server 2012 mit AD DS Dienst und GPO-Richtlinien, eine neue GPO erstellen, welche einen ...

Neue Wissensbeiträge
Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 4 StundenLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 2 TagenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Heiß diskutierte Inhalte
Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...