Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch zur Gruppenabfrage

Frage Microsoft Windows Userverwaltung

Mitglied: 56223

56223 (Level 1)

11.08.2008, aktualisiert 18.10.2012, 4517 Aufrufe, 7 Kommentare

Hallo IT Freunde,

ich sollte eine Batch Datei haben die Prüft ob der User in einer Gruppe mitglied ist.

Wenn ja soll er den Netzwerkpfad verbinden. Es sollten nur die den Pfad angezeigt bekommen die auch nur in der Gruppe mitglieder sind.

Ifmember sollte vorkommen nur finde ich da nichts. Kann mir da jemand helfen ?
Mitglied: markus0873
11.08.2008 um 14:02 Uhr
Hallo,

schau mal hier, da bekommst du schonmal ein nettes Beispiel:

http://www.gruppenrichtlinien.de/index.html?/howto/Anmelde_Scripts.htm



Gruß

Markus
Bitte warten ..
Mitglied: 56223
11.08.2008 um 14:12 Uhr
Hallo Markus,

auf dieser Seite war ich als erstes. Nur wie gesagt blick ich da nichts. so ne kleine erklärung wäre sehr Hilfreich !
Bitte warten ..
Mitglied: bastla
11.08.2008, aktualisiert 18.10.2012
Hallo ITmali!

Sieh Dir einmal das Tutorial Laufwerksmapping für Gruppen unter Windows 2003 Server an ...

Grüße
bastla
Bitte warten ..
Mitglied: 56223
12.08.2008 um 09:30 Uhr
Also ich hab das mal zusammen gebaut. Das Netzlaufwerk wird bei allen verbunden. Es sollte jedoch nur bei den Usern verbunden werden die in Gruppe fs sind.

echo Fileserver wird Verbunden ...

rem FS
net use m: /delete 2> Null:
net use m: \\FS\FS 2>NUL:

\\1.2.3.4\NETLOGON\IFMEMBER /L "fs"
if %errorlevel%==1 (
net use m: \\1.2.3.4\fs\ /persistent:no
)
Bitte warten ..
Mitglied: bastla
12.08.2008 um 09:46 Uhr
Hallo ITmali!

Die Zeile
01.
net use m: \\FS\FS 2>NUL:
sorgt ja bereits vor der Abfrage für ein Verbinden des Laufwerkes - wenn Du sie weglässt, sollte es klappen.

Grüße
bastla
Bitte warten ..
Mitglied: 56223
12.08.2008 um 13:08 Uhr
Hallo Bastla,

danke noch mal für deine Hilfe.

Es funktioniert aber nicht zu 100 %. Er erkennt das der user zur Gruppe gehört. nur beim verbinden
\\1.2.3.4\NETLOGON\IFMEMBER "fs"
if %errorlevel%==1 (
net use m: \\fs\fs\ /persistent:no
)
kommt folgender fehler. Systemfehler 53. Netzwerkpfad wurde nicht gefunden.

hast du dazu ne lösung oder den Grund.

Ich hab es schon mit IP der Servers versucht und namen aber leider vergebens.
Bitte warten ..
Mitglied: bastla
12.08.2008 um 13:38 Uhr
Hallo ITmali!

Lass den "\" nach dem Freigabenamen weg ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Batch und Powershell (2)

Frage von michi-ffm zum Thema Batch & Shell ...

Batch & Shell
Batch Systemlaufzeitabfrage (3)

Frage von phil9678 zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch minimiert starten (3)

Frage von pdiddo zum Thema Batch & Shell ...

Neue Wissensbeiträge
Entwicklung

Exploit Development

Anleitung von burhanudinn123 zum Thema Entwicklung ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(1)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (14)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...