Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Batch im netzwerk als admin ausführen - wobei admin kein passwort hat...

Frage Entwicklung Batch & Shell

Mitglied: nightwishler

nightwishler (Level 2) - Jetzt verbinden

01.04.2010 um 22:09 Uhr, 5255 Aufrufe, 5 Kommentare

hi, habe mal wieder ein kleines problem.
in meinem netzwerk werden sehr oft rechner installiert, welche danach aber nicht "wiederkommen". d.h. es gibt keine domäne.
zurzeit war es so das ich xp draufgemacht habe, und dann auf dem server eine installations-batch hatte worüber dann adobe und andere kleinigkeiten installiert wurden.
außerdem wurden diverse registry-keys per batch gesetzt, die am ende wieder entfernt wurden.

seid vista/uac hab ich was das angeht leider so meine kleinen probleme.
ich bekomme die registry keys z.b. nicht mehr eingetragen, da ich zwar als admin eingelogt bin, aber die batch anscheinend ohne admin-rechte ausgeführt wird.
ein runas scheitert daran das ich kein admin passwort für die zu installierenden systeme habe, da keines existiert.

gibts jetzt irgendwo noch einen kleinen trick oder kniff, oder habe ich schlichtweg etwas übersehen?
ich möchte NICHT zu jedem pc gehen und irgendwas klicken/eintippen müßen... das wäre kontraproduktiv

ideen?

Mit freundlichen Grüßen und dank im voraus
Mitglied: manuel-r
01.04.2010 um 22:41 Uhr
Hast du es mal mit "Als Administrator ausführen..." probiert?
Bitte warten ..
Mitglied: nightwishler
01.04.2010 um 22:55 Uhr
es ist eine batch die automatisch startet...
es muß irgendwie sicher gestellt werden das die batch ALLEINE mit admin rechten startet...
wie gesagt, es sollte nicht manuell hand angelegt werden...
Bitte warten ..
Mitglied: manuel-r
01.04.2010 um 22:59 Uhr
Auf welchem Weg wird die Batch denn automatisch gestartet und wann?
Bitte warten ..
Mitglied: nightwishler
02.04.2010 um 11:49 Uhr
sie liegt meist im autostart, wird von einigen aber auch per hand über "ausführen..." gestartet... aber all das soll ja weg.
denkbar wäre auch eine lösung mit psexec vom server aus, welcher dann prüft ob ein gewisser zustand erreicht ist und wenn nicht dann halt datei x ausführt...

da bin ich nicht sonderlich festgefahren.
wichtig ist halt nur das ich es irgendwie automatisiert hinbekomme das die reg-keys geschrieben werden...
leider habe ich keine langzeiterfahrung darüber was passiert wenn ich einfach für die installation die UAC deaktiviere, neustarte und danach wieder aktiviere...
Bitte warten ..
Mitglied: manuel-r
02.04.2010 um 13:46 Uhr
Vorschlag:
Richte doch einen geplanten Task ein und lass den beim Systemstart oder beim Anmelden ausführen. Im Task setzt du dann den Haken für "mit maximalen Rechten ausführen".
Oder du nimmst dir die Eigenschaften der Verknüpfung im Autostart zur Brust. Dort sollte man auch einen Haken setzen können für "Immer als Administrator ausführen". Das geht aber nicht bei allen Dateitypen. Ob es mit BAT/CMD geht müsstest du testen.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Userverwaltung
gelöst Domain - Zugriff auf Rechner in Netzwerk ohne Administrator Passwort (14)

Frage von Aviator zum Thema Windows Userverwaltung ...

Batch & Shell
gelöst Powershell-Script als Admin über CMD ausführen (2)

Frage von Tobiased zum Thema Batch & Shell ...

Windows Server
Batch Script bei Start ausführen (3)

Frage von KEFHVDI zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...