Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch für Senden an Thunderbird (Anhang einer neuen eMail hinzufügen) hat Problem mit Umlauten

Frage Entwicklung Batch & Shell

Mitglied: TheDarkLord

TheDarkLord (Level 1) - Jetzt verbinden

31.01.2010, aktualisiert 16:14 Uhr, 8182 Aufrufe, 4 Kommentare

Hallo

Ich nutze folgende Batch (bzw. eine Verknüpfung zu der im SentTo-Ordner), um markierte Elemente mittels "Senden an" als eMail in Thunderbird zu verschicken, was auch soweit super funktioniert:
01.
if %1. == . exit 
02.
set PARAMS=file:///%1 
03.
:loop 
04.
   shift 
05.
   if %1. == . goto send 
06.
   set PARAMS=%PARAMS%,file:///%1 
07.
goto loop 
08.
:send 
09.
start thunderbird.exe -compose attachment='%PARAMS%'
Allerdings ist mir aufgefallen, dass
  1. die markierten Dateien keine Umlaute oder Sonderzeichen enthalten dürfen, sonst kommt der Fehler: "Temporäre Datei konnte nicht geöffnet werden, überprüfen Sie ihre Einstellung für Temporäre Ordner." wenn ich die eMail speichern oder verschicken möchte.
  2. ich nicht mehr als 19 Dateien anhängen kann, wenn ich mehr markiert habe, kommt es zu dem Fehler: "thunderbird.exe - Auf den angegebenen Pfad kann nicht zugegriffen werden, sie verfügen evtl. nicht über ausreichene Berechtigungen etc"
Fällt irgendwem auf die Schnelle auf/ein, warum das Verhalten so ist?
Der zweite Punkt ist nicht ganz so wichtig, so viele einzelne Dateien hänge ich eh eigentlich nie an, wenn dann pack ich sie in ein Archiv! Ausserdem ändert sich die Maximalmenge irgendwie auch von Zeit zu Zeit!?! Als ich das letzte mal "gezählt" habe, waren es 40 oder 41 Dateien, bevor der Fehler kam...
Aber das mit den Sonderzeichen ist schon nervig - vor allem weil der Fehler erst kommt, wenn man die eMail abschickt. Im Anhang beim eMail-Schreiben-Fenster ist sie normal zu sehen, aber irgendwie dann nicht richtig verlinkt/vorhanden...

Gruß Dark
Mitglied: bastla
31.01.2010 um 14:44 Uhr
Hallo TheDarkLord!

Du könntest es mit
chcp 1252>nul
(als neue Zeile 2 eingefügt) versuchen.

Grüße
bastla
Bitte warten ..
Mitglied: TheDarkLord
31.01.2010 um 16:13 Uhr
Bastla, Du hast mal wieder voll ins schwarze getroffen.
An die Codepage hab ich überhaupt nicht gedacht!

Vielen Dank ;)
Bitte warten ..
Mitglied: qberto
03.03.2010 um 09:50 Uhr
Ich klinke hier hier mal in die Diskussion ein, da ich das selbe Problem habe, das Einfügen der Codepage aber nicht Abhilfe schaffen konnte. Ich erhalte immer noch die Meldung wegen des temporären Ordners.
Bitte warten ..
Mitglied: bastla
04.03.2010 um 10:28 Uhr
Hallo qberto und willkommen im Forum!

Leider fällt mir dazu nix mehr ein ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
gelöst Thunderbird Senden an E-Mail-Empfänger (3)

Frage von DasWombat1993 zum Thema Outlook & Mail ...

VB for Applications
Einzelne PDFs aus Serienbrief an neue Email anhängen (1)

Frage von onkelsibb zum Thema VB for Applications ...

Exchange Server
gelöst Sender von einer Mail mit einem Anhang suchen (3)

Frage von TheHawk zum Thema Exchange Server ...

Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (19)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Windows Server
DC virtualisieren + wie sichern (SingleDC-Environment) (12)

Frage von KMUlife zum Thema Windows Server ...

Festplatten, SSD, Raid
RAID Controller mit Trim-Funktion, wie ermitteln (11)

Frage von pixel24 zum Thema Festplatten, SSD, Raid ...