Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

batch Supportinformation austauschen Vista

Frage Entwicklung Batch & Shell

Mitglied: DrSnoopy

DrSnoopy (Level 1) - Jetzt verbinden

01.05.2009, aktualisiert 16:12 Uhr, 3938 Aufrufe, 4 Kommentare

Hallo
Ich arbeite in einem PC-Shop und wir haben uns nun überlegt für Fertig PC's die Supportinformationen von uns einzutragen ...

Hallo
Ich arbeite in einem PC-Shop und wir haben uns nun überlegt für Fertig PC's die Supportinformationen von uns einzutragen.
Das hab ich unter Windows XP schon mit ner Batch Datei hinbekommen und dem normalem Copy befehl ( halt ne oeminfo.ini und ne oemlogo.bmp in %systemroot%\system32 kopieren)

ABER nun mein Problem da wir nicht nur XP sondern auch Vista PC's haben hab ich das Problem das ich dort das Firmenlogo nicht in den System32 Ordner bekomme.
Ich habe eine oeminfo.reg erstellt (wo dann die Shop Infos drin sind) die wird auch korrekt ausgeführt nach einem Neustart des Systems sind die Daten korrekt drin ( Firmenname - Online support geht auch usw.)
ABER das Logo übernimmt er nicht
bekomme da immer beim ausführen des befehls "xcopy oemlogo.bmp %SystemRoot%\System32\ /R" Zugriff verweigert selbst wenn ich die batch mit adminrechten ausführe

mit robiocopy hab ich das noch nicht probiert und blick da auch nicht ganz durch... vielleicht weiß einer von euch Rat

Vielen Dank schon mal
Mitglied: LotPings
01.05.2009 um 17:35 Uhr
Zitat von DrSnoopy:
ABER nun mein Problem da wir nicht nur XP sondern auch Vista PC's haben hab ich das Problem das ich dort das Firmenlogo nicht in den System32 Ordner bekomme.
DAs Logo darf max 120x120 Pixel haben muß und BMP Format haben.

Ich habe eine oeminfo.reg erstellt (wo dann die Shop Infos drin sind) die wird auch korrekt ausgeführt nach einem Neustart des Systems > sind die Daten korrekt drin ( Firmenname - Online support geht auch > usw.) ABER das Logo übernimmt er nicht bekomme da immer beim ausführen des befehls
"xcopy oemlogo.bmp %SystemRoot%\System32\ /R"
Zugriff verweigert selbst wenn ich die batch mit adminrechten ausführe
Ich habe das gerade nochmal selbst in einer Windows7 VM ausprobiert. Klappt ohne Probleme, vielleicht solltest du die CMDexe schon mit Rechtsklick und "Als Administrator ausführen" starten - so gings hier.

Gruß
LotPings

Edit: Du hast ja die Systemsteuerung/System geschlossen gehabt und auch ZUERST kopiert und dann die Reg Schlüssel importiert?
Bitte warten ..
Mitglied: DrSnoopy
01.05.2009 um 18:59 Uhr
also Logo ist bei mir 120x90 Pixel und liegt auch im bmp Format

meine oeminfovista.reg datei sieht folgender maßen aus:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\OEMInformation]
"Logo"="%SystemRoot%\System32\oemvista.bmp"
"Manufacturer"="Was du willst"
"Model"="Was du willst"
"SupportPhone"="Was du willst"
"SupportUrl"="Was du willst, wenn du auch E-Mail möglichkeit haben willst dann mailto:xxx@xxx.xxxr"
"SupportHours"="Was du willst"

ich habe eine batch datei erstellt in der ich folgende com drin habe:
Die Batch Datei soll also das Logo kopieren und anschließend die Reg ausführen was soweit ja auch klappt bis auf halt die Fehlermeldung beim kopieren oder hab ich da irgendwo
was falsch gemacht ? (passiert auch wenn ich die Datei als Admin ausführe)

xcopy oemlogo.bmp %SystemRoot%\System32\ /R

oeminfovista.reg
Bitte warten ..
Mitglied: LotPings
01.05.2009 um 19:46 Uhr
Zitat von DrSnoopy:
"Logo"="%SystemRoot%\System32\oemvista.bmp"
xcopy oemlogo.bmp %SystemRoot%\System32\ /R

Wie diese beiden Zeilen zusammenpassen sollen weiß ich nicht

EDIT: Wenn du glaubst es liegt an der UAC, schalte sie doch vorübergehend ab.
Bitte warten ..
Mitglied: DrSnoopy
02.05.2009 um 21:33 Uhr
Zitat von LotPings:
> Zitat von DrSnoopy:
> ----
> "Logo"="%SystemRoot%\System32\oemvista.bmp"
> xcopy oemlogo.bmp %SystemRoot%\System32\ /R

Wie diese beiden Zeilen zusammenpassen sollen weiß ich nicht


EDIT: Wenn du glaubst es liegt an der UAC, schalte sie doch
vorübergehend ab.



naja jedesmal die UAC ausschalten und nach dem kopieren dann wieder einschalten .. dann kann ich auch per hand das logo kopieren und das wollte ich halt vereinfachen mit der batch datei "einfach klicken und fertig"


Naja die beiden Zeilen haben den sinn das ich der das Logo kopiere deswegen steht es ja in meiner batch datei in oberster reihe dann führt die batch datei die reg datei aus und fügt die daten ein .. und somit wird auch der pfad des logos angegeben der dann in der regestrie eingetragen wird
Bitte warten ..
Ähnliche Inhalte
Datenbanken
gelöst Datenbank Austausch per Dateien (9)

Frage von griffin zum Thema Datenbanken ...

Netzwerke
gelöst Firewall Austausch (7)

Frage von UnbekannterNR1 zum Thema Netzwerke ...

Windows Server
Austausch Windows SBS Server 2008 (4)

Frage von BergEnte zum Thema Windows Server ...

Router & Routing
gelöst Nach Austausch FB 7270 gegen 7580 geht RDP über VPN nicht mehr (3)

Frage von kaktus4737 zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (13)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...