Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

BATCH User anlegen und in Gruppe verfrachten...

Frage Entwicklung Batch & Shell

Mitglied: yakazaa

yakazaa (Level 1) - Jetzt verbinden

02.04.2008, aktualisiert 16.04.2008, 8533 Aufrufe, 4 Kommentare

Hallo, habe bislang folgendes:

01.
REM Lokalen Benutzer anlegen 
02.
ECHO. 
03.
ECHO. 
04.
ECHO Benutzer wird angelegt! 
05.
ECHO. 
06.
NET ACCOUNTS /minpwlen:6 /maxpwage:unlimited 
07.
C:\%1\SYSTEM\SLEEP 20 /h 
08.
NET USER %2-%4 gam%3-%4 /ADD /comment:"WMS Client" /fullname:"%2-%4" /expires:never /passwordchg:no /passwordreq:yes 
09.
C:\%1\SYSTEM\SLEEP 30 /h 
10.
NET LOCALGROUP Administrators %2-%4 /ADD 
11.
rem NET LOCALGROUP Administratoren %2-%4 /ADD 
12.
ECHO Aktion abgeschlossen!
Leider klappt das Ganze aber nur "ab und an" mal...
Ich kann allerdings auch kein Muster erkennen um zu sagen "Immer wenn ich X mache..." oder sowas...

Sleep ist ein Programm das hervorragend NICHTS tun kann, die Zeitangabe erfolgt in Sekunden als Parameter..

Ich hoffe Ihr könnt mir helfen,

Gruß Dominik
Mitglied: Dani
02.04.2008 um 19:14 Uhr
Hi Dominik,
was genau steht den z.B. in %1, %2, %3, %4? Vllt. Zeichenketten mit Leerzeichen?? Dann solltestest du alle Variablen in ' " ' schreiben.


Grüße
Dani
Bitte warten ..
Mitglied: yakazaa
03.04.2008 um 20:37 Uhr
Hallo Dani !

In den Variablen steht z.B.: AMAZON SVS svs 1
Also der Kunde, der Name der Station in Großbuchstaben, der Name der Station in Kleinbuchstaben und die Stationsnummer -> keine Leerzeichen

Danke aber für den Tip !

Hat denn niemand sonst ne Idee wieso es so sporadisch klappt ?


Gruß, Dominik
Bitte warten ..
Mitglied: yakazaa
16.04.2008 um 13:01 Uhr
01.
NET ACCOUNTS /minpwlen:6 /maxpwage:unlimited 
02.
C:\%1\SYSTEM\SLEEP 60 /h 
03.
NET USER %2-%4 gam%3-%4 /ADD /comment:"WMS Client" /fullname:"%2-%4" /expires:never /passwordchg:no /passwordreq:yes 
04.
C:\%1\SYSTEM\SLEEP 90 /h 
05.
NET LOCALGROUP Administrators %2-%4 /ADD
So, hab die Sleep Zeiten mal höher gesetzt, allerdings bringt das leider nichts...
Außerdem scheint es da einen zusammenhang mit der Mehrstelligkeit zu geben, also wenn %4 >9 wird. Mit einstelligen Ziffern gibt es komischerweise (bislang) keinerlei Probleme, kann es daran liegen ?!
Bitte warten ..
Mitglied: yakazaa
16.04.2008 um 16:24 Uhr
Für alle die es interessiert:

So muss es in richtig aussehen:

NET LOCALGROUP Administrators %COMPUTERNAME%\%USERNAME% /ADD

Wieder was gelernt...
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Batch & Shell
Skripterstellung Lehrling (22)

Frage von 133119 zum Thema Batch & Shell ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...