Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Batch (WindowsXP) > pipe/input/eingabe problem

Frage Entwicklung Batch & Shell

Mitglied: hiddenfile

hiddenfile (Level 1) - Jetzt verbinden

12.08.2006, aktualisiert 21:19 Uhr, 8523 Aufrufe, 2 Kommentare

fehlermeldung: ungültige eingabe.

Ich habe bei mir im Keller einen kleinen Server eingerichtet mit einem im Intranet freigegebenen Ordner "Buffer". Ziel ist es, diesen Ordner auf anderen PCs als "Zwischenspeicher" zu nutzen. D.h. mal unwichtige .txt dateien / downloads zwischenzuspeichern die man nur kurzfristig braucht.

Jedenfalls führe ich per Cronjob folgendes aus damit der Ordner immer täglich geleert wird:

cd c:\Apps\sonstiges
ECHO J| net share buffer /DELETE
rd /S /Q c:\buffer\
mkdir c:\buffer
net share buffer=C:\buffer

leider löscht der befehl rd auch den ordner buffer mit selbst, sodass ich vorher den ordnerfreigabe wegnehmen und nach der erstellung wieder aktivieren muss (ohne diese "reaktivierung" ist zwar laut windows der ordner freigeben, zugriff geht aber nicht). mit dem del /S befehl kann ich hier leider nicht arbeiten da er zwar rekrusiv alle dateien löscht aber die verzeichnisse nicht.

problem: wenn im netzwerk jemand auf diesen "buffer" ordner zugreift kommt beim aufheben dieser freigabe eine warnmeldung mit j/n option. ich dachte eigentlich das man mit den pipe befehl "usereingaben" simulieren könnte. aber es kommt immer die fehlermeldung "unültige eingabe" und der skript wird einfach fortgesetzt.

im endeffekt: scheint es dennoch zu funktionieren. d.h. alle dateien und ordner werden gelöscht, der buffer ordner wird normal hergestellt und man kann es nach dieser aktion auch wieder ganz normal im intranet nutzen.

aber ich hätte dann doch gerne die fehlermeldungen weg, bzw. gewusst warum sie überhaupt auftauchen.

vielen dank für jede hilfe
Mitglied: rc-computer
12.08.2006 um 18:59 Uhr
Hi,

ich versteh zwar das ganze vom technischen her nicht, aber ein Abfrage (yes|no) kann man meistens mit /y als parameter beantworten.

bsp:
NET USE * /d /y 2>nul

Mit freundlichen Gruessen
- Johannes Matjeschk
Bitte warten ..
Mitglied: hiddenfile
12.08.2006 um 21:19 Uhr
ui klasse! wusste gar nicht das sowas geht.

jedenfalls klappt nun alles damit prima. DANKE!
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Grosses Variablen Problem ( Batch) (30)

Frage von clragon zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch Problem bei einer For Schleife (2)

Frage von Juergen42 zum Thema Batch & Shell ...

Batch & Shell
gelöst Windows 7: Problem mit CP in Batch (3)

Frage von Maik87 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...