Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Benutzerspezifische Startmenüs

Frage Microsoft Windows Server

Mitglied: Moonwalker09

Moonwalker09 (Level 1) - Jetzt verbinden

06.05.2009, aktualisiert 11:04 Uhr, 3198 Aufrufe, 9 Kommentare

Hallo zusammen,

ich hab schon einige Probleme im Voraus durch das Forum lösen können. Aber jetzt bin ich am Ende angekommen

Es geht um folgendes:

Ich möchte dass User nur bestimmte Verknüpfungen im Startmenü haben. Das ist durch ein Anmeldeskript auch kein weiteres Problem.
Mein Problem besteht jetzt darin, dass das Skript erst bei der zweiten Anmeldung auf dem Client funktioniert. Wäre im Prinzip nicht weiter
tragisch, nur soll es noch ein Abmeldeskipt geben, dass das lokale Profil des Users bei der Abmeldung löscht. Dies ist notwendig, da
sich jeder User an jedem Client anmelden kann. Zunächst kein sonderlich großes Problem, doch wenn auf einem Rechner nach kurzer
Zeit 100-200 Benutzerprofile liegen kratzt das doch irgendwie an den Grenzen

Server: Windows Server 2003 Enterprise Edition
Clients: Windows 2000 Prof

Da nicht jeder User auf jedes Programm zugreifen soll / darf ist das lokale Laufwerk C: ausgeblendet.
(Benutzerkonfiguration/Administrative Vorlagen/Windows-Komponenten/Windows Explorer/Diese angegebenen Datenträger im Fenster "Arbeitsplatz" ausblenden)
Dies funktioniert einwandfrei. Programme die im Startmenü verknüpft sind starten und laufen einwandfrei.

Per Skipt werden Abteilungs- und Homelaufwerke zugewiesen.
Dies funktioniert ebenfalls sauber.

Per Skript sollen unnötige Verknüpfungen von Programmen gelöscht werden.
Nun besteht mein Problem darin, dass ich die Verknüpfungen von den Usern im Startmenü bei der Erstanmeldung nicht löschen kann. Bei der Fehleranalyse haben wir
versucht eine Schleife einzubauen. Das Skript sollte prüfen ob eine Verknüpfung bereits existiert und erst wenn sie erstellt worden ist sollte das Skript weiterarbeiten.
Ergebnis war:
- Skript prüft ob die Verknüpfung "A" vorhanden ist
- Verknüpfung "A" gefunden
- Skript läuft los
- Verknüpfung "A" kann nicht gelöscht werden, da die Verknüpfung an dem angegebenen Ort nicht gefunden wurde.

Ich hab da jetzt schon ein paar Tage dran gesessen und auch schon versucht die Startmenüs per Gruppenrichtlinie umzuleiten für bestimmte Benutzergruppen. Das Ergebnis ist aber leider immer das selbe. Erst bei der zweiten Anmeldung werden die Verknüpfungen gelöscht.

Hat jemand eine Idee wie ich dieses kleine Problem lösen kann?

Mit freundlichen Grüßen

Chris
Mitglied: KWORandy
06.05.2009 um 11:31 Uhr
Hallo

Warum funktioniert das Script bei der erst Anmeldung nicht?
Ist das Profil schon ganz geladen, wenn das Script ausgeführt wird?
Bitte warten ..
Mitglied: Moonwalker09
06.05.2009 um 11:41 Uhr
Ich weiß nicht, warum das Script nicht funktioniert. Es findet die zu löschende Verknüpfung bei der Überprüfung kann sie aber anschließend nicht löschen, weil sie angeblich nicht existiert.

Ich bin nicht wirklich ein Profi darin...

Benutzerkonfiguration/Administrative Vorlagen/System/Scripts/Anmeldeskripts gleichzeitig ausführen
ist nicht konfiguriert.

Oder irre ich mich jetzt (wäre nicht verwunderlich ) und du meinst etwas ganz anderes?
Bitte warten ..
Mitglied: Logan000
06.05.2009 um 13:05 Uhr
Moin Moin

Ein Vorweg: Suchst Du Startmenüverknüpfungen unter %Username%/Startmenü oder unter AllUsers/Startmenü ?
Wo hast Du das Anmelde Skript hinterlegt? In der Benutzerverwaltung im AD oder läst du es per GPO ausführen?

Ich verstehe nicht wozu das Ganze? Wenn Du auf Programme auf einem PC installierst legst Du die Verknüpfungen unter AllUsers ab. Somit landen diese nicht im Servergespeicherten Profils des Anwenders und stehen auf jeden PC auf dem Das Programm installiert ist zur Verfügung. Fertig.
Falls Du jedoch alle Programme auf allen PC instaliert hast (über ein Image oder so), warum willst du nicht das die Anwender diese Programme auch ausführen (sag jetzt nicht Lizenzen)?

Gruß L.
Bitte warten ..
Mitglied: Moonwalker09
06.05.2009 um 13:19 Uhr
Die Verknüpfungen befinden sich unter %Username%/Startmenü.

Per
Benutzerkonfiguration/Administrative Vorlagen/Startmenü und Taskleiste/Standardprogrammgruppen aus dem Startmenü entfernen
müsste ich ihm eigentlich die Möglichkeit genommen haben Verknüpfungen aus AllUsers/Startmenü zu ziehen oder?
Das Skript wird per GPO zugewiesen und läuft ja ab der zweiten Anmeldung auch einwandfrei... aber leider nicht bei der Erstanmeldung. Und ja, es sind alle Programme auf allen Rechnern installiert.

Der Grund ist recht simpel... es kann sich jeder User an jedem Rechner anmelden. Aber es soll nicht jeder User auf alle Programme zugreifen. Und dabei geht es nicht um Lizenzen sondern vielmehr darum, dass die User in völlig verschiedenen Bereichen tätig sind und somit völlig verschiedene Programme zur Verfügung haben sollen... stört mich persönlich nicht weiter, aber es ist die Anweisung von oben, dass jeder User nur auf "seine" Programme zugreifen kann.

Vielleicht denke ich auch einfach viel zu kompliziert und es gibt einen viel einfacheren Weg dafür.

Gruß

Chris
Bitte warten ..
Mitglied: Logan000
06.05.2009 um 14:11 Uhr
Moin

Also da es bei der 2. Anmeldung funktioniert können wir wohl einen Skriptfehler ausschliessen.
Das Skript löscht die Verknüpfung im lokalen Profil nicht im servergespeicherten?

Das Skript wird per GPO zugewiesen und läuft ja ab der zweiten Anmeldung auch einwandfrei
Unter Benutzerkonfiguration/Windows-Einstellungen/Skripts/Anmelden?
Zum Ablauf. Du richtest die GPO ein und machst auf dem Client ein gpupdate /force und dennoch mus sich der User 2, mal anmelden damit die Verknüpfung verschwindet?

Vielleicht denke ich auch einfach viel zu kompliziert und es gibt einen viel einfacheren Weg dafür.
Naja ich denke eher die Aufgabenstellung ist kompliziert und würde diese auch nicht umsetzen ohne das Zweck und Nutzen feststehen und sich rechnen.

Gruß L.
Bitte warten ..
Mitglied: Moonwalker09
06.05.2009 um 14:21 Uhr
Das Skript löscht nur die Verknüpfungen im lokalen Profil ja. Und ja, das Skript liegt auch richtig

Die GPO ist eingerichtet, liegt auf der richtigen OU und keine weitere GPO funkt dazwischen. Selbst bei der Test OU, die wir erstellt haben und dort nur das Skript zugewiesen haben lief nüscht.

Zweck und Nutzen... ja... das ist so eine Sache. Es befinden sich auf den Rechnern 73 verschiedene Programme und die obere Etage ist halt der Meinung, dass die User bei dieser Menge an Programmen zu schnell verwirrt sind / sich zu schnell von ihren eigentlichen Aufgaben ablenken lassen

Aber da anscheinend das alles nicht so funktioniert, wie die das gerne hätten, muss ich mal schauen, ob wir nicht irgendwo einen Kompromis finden können.

Ich warte noch mal bis morgen ab, vielleicht hat ja doch noch jemand eine Idee, wie man das Ganze (vielleicht durch einen ganz anderen Weg) realisieren kann.

Gruß

Chris

(PS: Soll / muss ich den Beitrag dann auf "gelöst" setzen, auch wenn es keine Lösung gibt?)
Bitte warten ..
Mitglied: Logan000
07.05.2009 um 08:38 Uhr
Moin Moin

(PS: Soll / muss ich den Beitrag dann auf "gelöst" setzen, auch wenn es keine Lösung gibt?)
Du soltest vor allen Dingen die Flinte nicht so schnell ins Korn werfen.

Du hast doch in der GPMC den Punkt Richtlinienergebnisse. Überprüf doch damit mal ob die GPO angewendet wird.
Weiterhin könnten Rechte im Dateisystem fehlen (wenn auch eher unwahrscheinlich).

Folgende GPO Einstellung aktiviere ich immer gerne, wenn Skripte ausgeführt werden müssen:
Computerkonfiguration/Administrative Vorlagen/System/Anmeldung/Beim Neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten.
Probiers mal aus.

Du könntest auch mal dein Skriptcode posten. Evtl. findet sich da auch was.

Zweck und Nutzen... ja... das ist so eine Sache. Es befinden sich auf den Rechnern 73 verschiedene Programme und die obere Etage ist halt der Meinung, dass die User bei dieser Menge an Programmen zu schnell verwirrt sind / sich zu schnell von ihren eigentlichen Aufgaben ablenken lassen
Was ja auch nachvollziehbar wäre.
Ich warte noch mal bis morgen ab, vielleicht hat ja doch noch jemand eine Idee, wie man das Ganze (vielleicht durch einen ganz anderen Weg) realisieren kann.
Wir haben das bei uns mit Softwareverteilung via GPO realisiert. Das klappt ganz gut. Allerdings hat die Umstellung von "Alles auf dem Image" bis zu "Alles per GPO" ziemlich viel Zeit und Nerven gekostet, bei ca. 65 Anwendungen.

Gruß L.
Bitte warten ..
Mitglied: Moonwalker09
07.05.2009 um 08:56 Uhr
Zitat von Logan000:
> Du soltest vor allen Dingen die Flinte nicht so schnell ins Korn
werfen.

Naja... werd mal weiter dranbleiben^^

Du hast doch in der GPMC den Punkt Richtlinienergebnisse.
Überprüf doch damit mal ob die GPO angewendet wird.

Die GPO läuft einwandfrei durch. Bei jeder Anmeldung. Nur das Skript scheint bei der
Erstanmeldung (soll es ja bald immer sein) nicht zu funktionieren und löscht nicht
alle Verknüpfungen.

Weiterhin könnten Rechte im Dateisystem fehlen (wenn auch eher
unwahrscheinlich).

Hab es ausprobiert und einem Testuser auf einem Client "Vollzugriff" auf C: gewährt.
Das Ganze lief in einer Test OU auf der als GPO nur das Anmeldeskript liegt. Wie gehabt
bei der zweiten Anmeldung löscht das Skript sauber alle Verknüpfungen.

Folgende GPO Einstellung aktiviere ich immer gerne, wenn Skripte
ausgeführt werden müssen:
Computerkonfiguration/Administrative Vorlagen/System/Anmeldung/Beim
Neustart des Computers und bei der Anmeldung immer auf das Netzwerk
warten.
Probiers mal aus.

Werde ich gleich mal testen


Du könntest auch mal dein Skriptcode posten. Evtl. findet sich
da auch was.

Der Skriptcode ist gaaaaaaaaaanz simpel gestrickt:

del "%USERPROFILE%\Anwendungsdaten\...\*.lnk"
del "%USERPROFILE%\Startm~1\Programme\...\*.lnk"

und so weiter

Wir haben das bei uns mit Softwareverteilung via GPO realisiert. Das
klappt ganz gut. Allerdings hat die Umstellung von "Alles auf dem
Image" bis zu "Alles per GPO" ziemlich viel Zeit und
Nerven gekostet, bei ca. 65 Anwendungen.

Hm... glaube ich, dass das ziemlich viel Zeit und Nerven gekostet hat.

Gruß

Chris
Bitte warten ..
Mitglied: Moonwalker09
07.05.2009 um 09:06 Uhr
So, Test ausgeführt.
Leider war das Ergebnis das Gleiche. Erst bei der zweiten Anmeldung wurden die Verknüpfungen gelöscht.
Und ja, um das gleich mal vorweg zu nehmen, der entsprechende Client auf dem getestet wurde befindet sich in der richtigen OU, so dass die GPO ihn auch erreichen kann

Gruß

Chris
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Drucker und Scanner
Benutzerspezifische DruckerEinstellungen im Netzwerk verteilen

Frage von StefanKittel zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...