Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bestimmte Benutzer haben keinen Sound bei der Remotedesktopverbindung.

Frage Microsoft Windows Server

Mitglied: GerdPl

GerdPl (Level 1) - Jetzt verbinden

26.11.2012 um 18:19 Uhr, 3719 Aufrufe, 3 Kommentare

Bei meinem Kunden steht ein PC (XP-Pro), auf den ein Mitarbeiter aus seinem Homeoffice über ein VPN per RDP zugreift.
Auf diesem Rechner ist u.a. DAVID von Tobit installiert. Darüber kann der betreffende Mitarbeiter eingehende Anrufe abhören, also quasi ein Anrufbeantworter. Das hat immer gut geklappt und wurde daher nie geändert.

Nun ist das Mainboard des PC's kaputt gegangen und ich habe kurzerhand die Festplatte des Rechners als virtuelle Platte auf einem Hyper-V-Server (unter W2008 R2 Ent. im AD) als virtueller Computer eingerichtet.
Das hat auch gut geklappt, bis auf eine Kleinigkeit, die mir aber die Nerven raubt:

Der betreffende Mitarbeiter kommt jetzt wieder wie gewohnt per RDP auf den Rechner, nur dass er jetzt die Anrufe nicht mehr abhören kann. Es wird unten rechts zwar das Lautsprechersymbol angezeigt, aber auch wenn ich darüber z.B. die Lautstärke verändere, hört man nichts. Normalerweise kommt da ja ein "Pling" von Windows.

Die gängigen Einstellungen habe ich natürlich überprüft und die sind alle ok.

Melde ich mich vom Rechner des Mitarbeiters aus mit MEINEN Benutzerdaten an, dann hört man allerdings den Ton und man kann auch z.B. den AB abhören...

Das bedeutet für mich, dass Problem irgendwo lokal liegt oder an den Gruppenrichtlinien bzw. den Systemrechten liegen könnte. Hab alles überprüft, ohne Erfolg.

Nun habe ich testweise den betreffenden User in die Admin-Gruppe verlegt, so dass keine Gruppenrichtlinien ausgeführt werden und er alle Rechte hat, aber es ist trotzdem kein Sound zu hören. Also schließe ich auf ein lokales Problem.

Egal, mit welchem User ich mich anmelde, es wird das Lautsprecher-Symbol angezeigt.

Gehe ich mit meinen Zugangsdaten auf den Rechner, sehe ich in der Systemsteuerung unter "Sounds und Audiogeräte" den Microsoft RDP-Audiotreiber und kann dort z.B. die Lautstärke einstellen.

Gehe ich mit einem anderen User (z.B. als Administrator) auf den Rechner, dann wird mir unter "Sounds und Audiogeräte" weiterhin der Microsoft RDP-Audiotreiber angezeigt, allerdings kann ich die Lautstärke nicht verändern. Die Checkbox "Ton aus" ist angehakt. Nehme ich den Haken raus und schließe das Fenster, setzt sich der Haken für "Ton aus" von selbst wieder.

Lasse ich unter meinem Benutzer im dxdiag den Soundtest laufen, klappt dieser. Unter einem anderen User kommt der Fehler "DirectSound-Testergebnisse: Abbruch in 3 (DirectSoundCreate): HRESULT = 0x8878000a (Die Anforderung ist fehlgeschlagen, da die DirectSound-Ressourcen, wie z. B. die Prioritätsstufe, gerade verwendet wurden.)"

DirectX ist installiert.

So langsam fehlt mir eine Idee, woran das noch liegen könnte. Ich hoffe, hier weiß jemand mehr.








Mitglied: Schabersack
26.11.2012 um 18:37 Uhr
Hallo!

Schau mal bei der Verbindungskonfiguration. Da kann man lokale Resourcen konfigurieren und somit bestimmen ob Sound, Drucker, Laufwerke u.ä. bei der Sitzung mit übertragen werden...

Gruß
Schabersack
Bitte warten ..
Mitglied: GerdPl
27.11.2012 um 08:18 Uhr
Danke für den Tip, aber das war natürlich das Erste, was ich überprüft habe.

Ich habe mir eine Remote-Desktop-Verknüpfung für diesen Rechner auf den Desktop gelegt.
Melde ich mich mit dem Usernamen des MA an, geht's nicht, nehme ich meinen, geht's.
Die Einstellungen der Verbindung sind also gleich.
Bitte warten ..
Mitglied: GerdPl
27.11.2012 um 12:25 Uhr
Nach langem Suchen ist mir aufgefallen, dass auf dem virtuellen XP noch kein SP3 installiert war. Nach der Installation von diesem und allen weiteren Microsoft-Updates funktionierte auch der Sound.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Sicherheits-Tools
gelöst 2 faktor authentifizierung windows domäne nur bestimmte benutzer (7)

Frage von kal10bach zum Thema Sicherheits-Tools ...

Windows Server
gelöst Ausnahmeregeln in GPOs für bestimmte Benutzer in der Domäne priorisieren aber wie? (3)

Frage von ITCrowdSupporter zum Thema Windows Server ...

Windows Server
Windows 2012 RDS Server - Programme nur für bestimmte Benutzer? (2)

Frage von zersys zum Thema Windows Server ...

VB for Applications
gelöst Bestimmte Spalten aus CSV-Datei auslesen (VBS) (9)

Frage von Gurkenhobel zum Thema VB for Applications ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...