Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bestimmten Wert vergleichen mit Spalte von div. Werten. Wenn Wahr, dann einen Wert aus Vergleichstabelle ausgeben

Frage Microsoft Microsoft Office

Mitglied: PiWol73

PiWol73 (Level 1) - Jetzt verbinden

28.01.2009, aktualisiert 13:53 Uhr, 10122 Aufrufe, 2 Kommentare

Hallo

Ich komme nicht mehr weiter....

Gibt es in Excel eine Funktion, mit welcher ich folgendes machen kann.

Im Tabellenblatt "TAB1" habe ich ca. 4000 Zeilen, welche Zahlen mit verschiedenen Kennungsendzeichen Bsp: 123465A und noch anderen Spaltenwerten enthält.
Bsp:
TAB1:
Spalte1: Artikelnummer (123456A)
Spalte2: Bezeichnung
Spalte3: Sonstiges


TAB2:
Spalte1: Artikelnummer (123456A)
Spalte2: EAN-Code: (123456789)

Es soll nun verglichen werden, ob der Wert aus "Spalte1 TAB1" in "Spalte1 TAB2" vorhanden ist, und wenn ja soll mir der Eintrag "Spalte2 TAB2" auf "TAB1" kopiert werden.

Hoffe ihr versteht mein Problem und könnt mir helfen.

Gruss PiWol
Mitglied: bastla
28.01.2009 um 14:09 Uhr
Hallo PiWol73 und willkommen im Forum!

Klingt nach einem simplen SVERWEIS ...

Wenn die Werte in TAB1 zB ab Zeile 3 und in TAB2 ab Zeile 2, jeweils beginnend von Spalte A, eingetragen sind, sähe die Formel (für zB E3 in TAB1) etwa so aus:
=SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0)
Wird eine Artikelnummer aus TAB1 in TAB2 nicht gefunden, erhältst Du die (zugegebener Maßen nicht sehr hybsche) Fehlermeldung "#NV"; sollte das stören, dann etwa so:
01.
=WENN(ISTNV(SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0));"Artikel nicht gefunden!";SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0))
Diese Formel (welche auch immer) musst Du dann nur noch nach unten kopieren ...

Grüße
bastla
Bitte warten ..
Mitglied: PiWol73
28.01.2009 um 15:17 Uhr
Hey Bastla

Was soll ich sagen. Funz wie es sollte.

Besten Dank für die wirklich SUPERSCHNELLE Hilfe.

Gruss PiWol73
Bitte warten ..
Heiß diskutierte Inhalte
Exchange Server
gelöst Email in Exchange an 2ten Empfänger senden (18)

Frage von MultiStorm zum Thema Exchange Server ...

Weiterbildung
Gehaltsvorstellungen (14)

Frage von SYS64738 zum Thema Weiterbildung ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (13)

Frage von planetIT2016 zum Thema Windows Server ...

Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...