Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bestimmten Wert vergleichen mit Spalte von div. Werten. Wenn Wahr, dann einen Wert aus Vergleichstabelle ausgeben

Frage Microsoft Microsoft Office

Mitglied: PiWol73

PiWol73 (Level 1) - Jetzt verbinden

28.01.2009, aktualisiert 13:53 Uhr, 10208 Aufrufe, 2 Kommentare

Hallo

Ich komme nicht mehr weiter....

Gibt es in Excel eine Funktion, mit welcher ich folgendes machen kann.

Im Tabellenblatt "TAB1" habe ich ca. 4000 Zeilen, welche Zahlen mit verschiedenen Kennungsendzeichen Bsp: 123465A und noch anderen Spaltenwerten enthält.
Bsp:
TAB1:
Spalte1: Artikelnummer (123456A)
Spalte2: Bezeichnung
Spalte3: Sonstiges


TAB2:
Spalte1: Artikelnummer (123456A)
Spalte2: EAN-Code: (123456789)

Es soll nun verglichen werden, ob der Wert aus "Spalte1 TAB1" in "Spalte1 TAB2" vorhanden ist, und wenn ja soll mir der Eintrag "Spalte2 TAB2" auf "TAB1" kopiert werden.

Hoffe ihr versteht mein Problem und könnt mir helfen.

Gruss PiWol
Mitglied: bastla
28.01.2009 um 14:09 Uhr
Hallo PiWol73 und willkommen im Forum!

Klingt nach einem simplen SVERWEIS ...

Wenn die Werte in TAB1 zB ab Zeile 3 und in TAB2 ab Zeile 2, jeweils beginnend von Spalte A, eingetragen sind, sähe die Formel (für zB E3 in TAB1) etwa so aus:
=SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0)
Wird eine Artikelnummer aus TAB1 in TAB2 nicht gefunden, erhältst Du die (zugegebener Maßen nicht sehr hybsche) Fehlermeldung "#NV"; sollte das stören, dann etwa so:
01.
=WENN(ISTNV(SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0));"Artikel nicht gefunden!";SVERWEIS(TAB1!A3;TAB2!$A$2:$B$4000;2;0))
Diese Formel (welche auch immer) musst Du dann nur noch nach unten kopieren ...

Grüße
bastla
Bitte warten ..
Mitglied: PiWol73
28.01.2009 um 15:17 Uhr
Hey Bastla

Was soll ich sagen. Funz wie es sollte.

Besten Dank für die wirklich SUPERSCHNELLE Hilfe.

Gruss PiWol73
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Wie speichere ich von einer "Grundbatchdatei" einen bestimmten Wert? (5)

Frage von IchBins01000010 zum Thema Batch & Shell ...

Microsoft Office
gelöst Excel: Wenn Wert in Spalte A dann kopiere Zeile (8)

Frage von michi1983 zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel: Wert aus mehreren Zeilen vergleichen (2)

Frage von Nicolaas zum Thema Microsoft Office ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
PC stellt nach dem Bios ab (19)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

iOS
16 iPads zentrall verwalten (18)

Frage von simonlohr zum Thema iOS ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...

Microsoft Office
gelöst VBA Excel Problem mit UserForm, ListBox und TextBox (12)

Frage von abuelito zum Thema Microsoft Office ...