Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Bild nach Boot ohne Monitor

Frage Hardware Grafikkarten & Monitore

Mitglied: netadm

netadm (Level 1) - Jetzt verbinden

28.09.2011 um 07:52 Uhr, 3789 Aufrufe, 7 Kommentare

Hallo,

ich habe folgendes Problem,bei dem ich auch über die Suchfunktion noch nichts passendes finden konnte. Ich habe einen PC mit folgender Konfiguration:

- Asus-Desktopboard (Intel P55 Chipsatz)
- VGA Asus EN210 SILENT DI PCI-E

Installiert ist hierauf Opensuse 11.3 64bit mit Kernel 2.6.34.12. Gestartet wird das System ohne grafische Oberfläche im Runlevel 3.

Es funktioniert alles einwandfrei, solange während des Bootvorgangs ein Monitor angeschlossen ist. Wird dieser jedoch erst nach dem Bootvorgang angeschlossen, so bleibt dieser schwarz und lässt sich nicht zum Leben erwecken. Ich habe dies schon mit dem VGA- und dem DVI-Port getestet. Aber leider der gleiche Effekt.

Gibt es eine Lösung, dass der Monitor auch an geht, wenn er erst im Nachhinein angeschlossen wird?

Viele Grüße
Mitglied: 64748
28.09.2011 um 08:17 Uhr
Guten Morgen,

wichtig wäre zu wissen, woran es scheitert. Eine Idee ist, das Linux irgendein (oder mehrere) Module nur lädt, wenn ein Monitor angeschlossen ist.
Schreib das Kommando
lsmod | sort > lsmod_ohne_Monitor.txt
in eine Textdatei, und speichere das ganze so, dass Du es bei schwarzem Bildschirm ausführen kannst, oder lass es beim shutdown automatisch ausführen (chmod 755 nicht vergessen! falls Du das Kommando als Datei abspeicherst).
Dann vergleiche die geladenen Module bei schwarzem Monitor mit den Modulen mit funktionierendem Monitor.
Falls es sich jedoch um ein Feature der Grafikkarte handelt, dann wird das nichts nutzen.

Außerdem kannst Du die Xorg.log Dateien für beide Fälle vergleichen.


Markus
Bitte warten ..
Mitglied: netadm
01.10.2011 um 17:35 Uhr
Schönen guten Abend,

vielen Dank für den schnellen Tip. Ich vermute da liegt auch schon das Problem. Beim Boot ohne Monitor wird das Modul namens "nouveau" nicht geladen. Dies scheint ein nVidia- Treibermodul zu sein.

Könnte ich dies testweise während des Betriebs z.B. per ssh nachladen? Dann müsste der Monitor ja theoretisch angehen oder funktioniert das nicht? Mit welchem Kommando würde dies denn funktionieren? Mit modprobe ? Und wenn dies das Problem wäre, kann ich OpenSuSE dazu bringen, das Modul immer zu laden, unabhängig davon, ob ein Monitor angeschlossen ist?

Xorg- Logs kann ich keine finden. Aber kann es bei mir überhaupt welche geben, wenn ich im Runlevel 3 ohne grafische Oberfläche arbeite?

Viele Grüße
Bitte warten ..
Mitglied: 64748
01.10.2011 um 18:37 Uhr
Hallo,

mit
modprobe nouveau
in der rc.local sollte das Module bei jedem Systemstart geladen werden.

Die lofiles sind normalerweise in /var/log aber ich kenn mich mit Suse nicht aus.

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 21:43 Uhr
Hallo nochmal,

also mein Problem ist nun zur Hälfte gelöst.

Ich bekomme den Monitor mit

 
modprobe nouveau 
den Monitor wieder an. Jedoch erst nachdem ich das Modul einmal entladen und neu geladen habe.
Gibt es evtl. eine Möglichkeit, dies automatisch beim Bootvorgang zu machen?
Bitte warten ..
Mitglied: 64748
05.10.2011 um 21:44 Uhr
Du meinst, Du musst es laden, dann wieder entladen und dann nochmal laden?

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 22:00 Uhr
Nicht ganz.

Wenn ich ohne Monitor boote, dann wird das Modul erstmal nicht mit geladen. Somit bleibt der Monitor auch dunkel.

Mache ich nun jedoch

 modprobe -v nouveau 


so tut sich überhaupt nichts. Erst nach

 modprobe -r nouveau 

 modprobe -v nouveau 


werden das nouveau-Modul und die zugehörigen Module neu geladen und der Monitor geht an.
Bitte warten ..
Mitglied: 64748
05.10.2011 um 22:08 Uhr
Du solltest mal die Dokumentation zu Suse zu Rate ziehen. Dort steht auch, wie man bestimmte Module beim Systemstart laden kann. Ich würde es in der rc.local machen. Allerdings gibt's auch ein Verzeichnis /etc/modprobe.d in dem solche Dinge gesteuert werden. So ähnlich wird's bei Suse auch sein.

Zur Not schreibst Du ein Skript:
#!bin/sh 
modprobe nouveau 
sleep 2 
rmmod nouveau 
sleep 2 
modprobe nouveau
und lässt es in der rc.local ausführen.

Markus
Bitte warten ..
Ähnliche Inhalte
Grafik
gelöst Bild auf 4k Monitor vollständig anzeigen (8)

Frage von flotaut zum Thema Grafik ...

Grafikkarten & Monitore
gelöst Monitor geräusche bei Schwarz und Weiss Bildern (6)

Frage von CamperGuy zum Thema Grafikkarten & Monitore ...

Windows 10
Windows 10 zweiter Monitor bleibt nach BIOS booten aus (6)

Frage von Pille-63 zum Thema Windows 10 ...

Grafikkarten & Monitore
älterer Compaq Laptop mit Windows 10 bei Anschluss HDMI Monitor Bild weg (4)

Frage von Andy1805 zum Thema Grafikkarten & Monitore ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...

Windows 10
Windows 10 Fall Creators Update Fehler (13)

Frage von ZeroCool23 zum Thema Windows 10 ...