Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Binärdatei startet nicht

Frage Entwicklung Pascal und Delphi

Mitglied: JuMa2906

JuMa2906 (Level 1) - Jetzt verbinden

12.11.2011 um 22:33 Uhr, 3955 Aufrufe, 8 Kommentare

Ich habe nur ein Icon eingesetzt und schon will die Binärdatei nicht starten.

Hallo, liebe Admins.

Das Problem mit den Forms hat sich geklärt. Das neue Problem: Ich habe ein Icon in mein Projekt eingebaut und nach dem Compilen will die Binärdatei sich nicht öffnen! Im Task-Mamager erscheint kurz der Name des Programmes, aber danach schließt es sich sofort wieder. Ich hoffe, ihr könnt mir helfen.

MfG Maximilian J.
Mitglied: AndreasHoster
13.11.2011 um 09:21 Uhr
Ich habe nur ein Icon eingesetzt und schon will die Binärdatei nicht starten.
Dann wäre doch der erste logische Versuch, daß Icon wieder rauszunehmen und zu schauen obs wieder geht.
Wenn ja, dann hat man beim Einbinden einen Fehler gemacht oder das Icon hat möglicherweise eine nicht supportetes Format.
Da könnte man dann testen, ob es mit einem anderen Icon geht.
Bitte warten ..
Mitglied: JuMa2906
13.11.2011 um 12:19 Uhr
Gesagt, getan, gemacht - nichts passiert: lässt sich nicht starten.

Sorry, Andreas Hoster. Logisch ist es, aber funktioniert trotzdem nicht.
Bitte warten ..
Mitglied: mrtux
13.11.2011 um 12:45 Uhr
Hi !

Das hatte ich auch schon! Lass die IDE mal das gesamte Projekt komplett neu compilieren und linken oder wenn das auch nicht hilft, dann kommentiere mal das Resourcefile aus bzw. lege ein leeres File an..Vielleicht hilft ja das....

mrtux
Bitte warten ..
Mitglied: JuMa2906
13.11.2011 um 12:54 Uhr
Nach dem "Alles compilen" - Binärdatei öffnet sich immer noch nicht! Das Resourcefile ist bereits auskommentiert und das Property visible hat als Preset false. Selbst auf true gestellt läuft nichts ... ich denke daran, das Ganze erneut zu schreiben. Es wird zwar nervig werden, alle 120 Grafiken pro Formular einzusetzen, aber das wäre ein Ansatz.

MfG Maximilian J.
Bitte warten ..
Mitglied: mrtux
13.11.2011 um 13:02 Uhr
Hi !

Zitat von JuMa2906:
Nach dem "Alles compilen" - Binärdatei öffnet sich immer noch nicht! Das Resourcefile ist bereits
auskommentiert und das Property visible hat als Preset false. Selbst auf true gestellt läuft nichts ... ich denke

Stimmt! Mir ist gerade eingefallen, dass das Property visible im Mainform normalerweise ignoriert wird, zumindest wenn es im Projektfile mittels Application.CreateForm() automatisch erzeugt wird. Daher habe das schnell wieder aus meinem Kommentar entfernt.

Jetzt aber noch eine ganz blöde Frage: Die Delphi-IDE mal komplett geschlossen und am besten gleich mal den Rechner neu gestartet hast Du aber schon versucht oder?

mrtux
Bitte warten ..
Mitglied: JuMa2906
13.11.2011 um 13:04 Uhr
Ach so, du gingst von DELPHI aus?? Das habe ich wohl vergessen, zu sagen: ich nutze Lazarus (die Testversion von Delphi geht aus komplexen Gründen nicht). Ja, ich habe die IDE schon komplett geschlossen und den Rechner neu gestartet.
Bitte warten ..
Mitglied: JuMa2906
13.11.2011 um 13:16 Uhr
Ich habe das Problem dann doch selbst gelöst. Trotzdem, auch wenn das Problem gelöst ist, will ich das offen schreiben, für die, die möglicherweise das selbe Problem haben. Ich habe meine LPR-Datei mit einer Preset-LPR-Datei verglichen und es kam raus, dass durch irgendein Zufall der Befehl

Application.Initialize;

gefehlt hat. Trotzdem danke an alle, die versucht haben, mein Problem zu lösen.

MfG Maximilian J.
Bitte warten ..
Mitglied: mrtux
13.11.2011 um 13:31 Uhr
Hi !

Zitat von JuMa2906:
> Application.Initialize;

gefehlt hat. Trotzdem danke an alle, die versucht haben, mein Problem zu lösen.

Das wäre meine nächste Frage gewesen, ob Du nicht mal das Projektfile posten kannst....
Wenn Application.Initialize fehlt, fehlt quasi alles, was mit der Unit Forms zu tun hat und logischerweise wird dann dein Projekt nur als Textkonsolen-Anwendung gestartet und sofort wieder beendet.

Aber bei der Lazarus IDE kannst Du dir grundsätzlich nie sicher sein. Im Vergleich zum FPC Compiler selbst, hat die IDE ja noch so einige Macken und hat mich beim Debuggen auch schon aufs Glatteis geführt, da hilft es manchmal eine Pause zu machen, um etwas Abstand zu gewinnen und den Kopf wieder frei zu bekommen.

Ich verwende momentan Lazarus auch öfter als Delphi, zwecks Plattform Unabhängigkeit.

mrtux
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Grafikkarten & Monitore
PC startet, aber kein Bild (10)

Frage von Linuxguru zum Thema Grafikkarten & Monitore ...

Windows 7
Microsoft startet Abschiedskampagne für Windows 7 (13)

Link von Frank zum Thema Windows 7 ...

Mac OS X
Malware startet DoS-Angriffe gegen Macs

Link von transocean zum Thema Mac OS X ...

Windows Server
Windows server 2012 r2 hyper v vm startet nur schwarz (5)

Frage von meister00 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Windows Server
Probleme mit Client Software Zugriff auf Windows Server 2012 (8)

Frage von it-kolli zum Thema Windows Server ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (7)

Frage von DerFurrer zum Thema Windows Installation ...