Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Blat mit Exchange 2007 Probleme

Frage Entwicklung Batch & Shell

Mitglied: Razfaz

Razfaz (Level 1) - Jetzt verbinden

11.11.2010 um 14:58 Uhr, 5844 Aufrufe, 1 Kommentar

Hallo,

ich bin am verzweifeln.
Folgende Sache.
Ich möchte gerne eine Mail mit Blat per Batch Datei verschicken.
Wir nutzen einen exchange Server 2007.
Wenn ich intern eine Mail über diese Batch verschicke, klappt das wunderbar.
Das will ich aber nicht, denn diese Mail soll an eine externe Adresse gehen.

Erstmal meine Batch Datei:
cd /d C:\blat262\full 
 
Blat -install mail.exchangeserver.de xxx@exchangeserver.de 
Blat "C:\Test\Test1\test1.txt" ^ 
-to xxx@kabelmail.de -server exchangeserver.de -u username -pw passwort ^ 
-debug -timestamp -log blatSMTPlog.txt ^ 
-subject "Backup auf Server-1"
Als Usernamen habe ich meine AD Anmeldung genommen und das dazugehörige Passwort.

Dies bekomme ich dann in der log Datei als FM:
2010.11.11 14:44:55 (Thu)------------Start of Session----------------- 
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19) 
2010.11.11 14:44:55 (Thu): <<<getline<<< 220 S-EBS2.exchangeserver.local ESMTP Service ready 
2010.11.11 14:44:55 (Thu): >>>putline>>> EHLO R213.exchangeserver.de 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-Requested mail action okay, completed 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-SIZE 0 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-AUTH NTLM 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-8BITMIME 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-BINARYMIME 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-CHUNKING 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250 OK 
2010.11.11 14:44:57 (Thu): Sending C:\Test\Test1\test1.txt to xxx@kabelmail.de 
2010.11.11 14:44:57 (Thu): Subject: Backup auf Server-1 
2010.11.11 14:44:57 (Thu): Login name is xxx@exchangeserver.de 
2010.11.11 14:44:57 (Thu): >>>putline>>> AUTH LOGIN 
2010.11.11 14:45:02 (Thu): <<<getline<<< 504 Command parameter not implemented 
2010.11.11 14:45:02 (Thu): The SMTP server does not require AUTH LOGIN. 
Are you sure server supports AUTH? 
2010.11.11 14:45:02 (Thu): >>>putline>>> MAIL FROM:<xxx@exchangeserver.de> 
2010.11.11 14:45:02 (Thu): <<<getline<<< 250 Requested mail action okay, completed 
2010.11.11 14:45:02 (Thu): >>>putline>>> RCPT TO:<xxx@kabelmail.de> 
2010.11.11 14:45:07 (Thu): <<<getline<<< 550 Requested action not taken: mailbox unavailable 
2010.11.11 14:45:07 (Thu): The SMTP server does not like the name xxx@kabelmail.de. 
Have you set the 'To:' field correctly, or do you need authorization (-u/-pw) ? 
2010.11.11 14:45:07 (Thu): The SMTP server response was -> 550 Requested action not taken: mailbox unavailable 
2010.11.11 14:45:07 (Thu): >>>putline>>> QUIT 
2010.11.11 14:45:07 (Thu): <<<getline<<< 221 Service closing transmission channel 
2010.11.11 14:45:07 (Thu)-------------End of Session------------------
Wo liegt da mein Fehler?
(Der Name exchangeserver habe ich gegen unseren Domänennamen ausgetauscht)
Mitglied: filippg
11.11.2010 um 21:23 Uhr
Hallo,

dein Server erlaubt kein Relaying (was auch gut ist). Suche nach Exchange 2007 Relay Connector.
Workaround: Richte für den externen Nutzer eine Kontakt ein. Der hat dann auch eine interne Adresse, und an die solltest du schicken können ohne die Relay-Einstellunge zu ändern (und Exchange schickt es dann an die externe).

Gruß

Filipp
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

DSL, VDSL
Fritzbox Exchange 2007 UM Gateway mit Freetz (2)

Frage von Herbrich19 zum Thema DSL, VDSL ...

Exchange Server
gelöst Zertifikatsfehler nach Migration von Exchange 2007 zu Exchange 2013 (2)

Frage von Tommy1983 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 Migration auf Exchange 2016 (3)

Frage von Tommy1983 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...