Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Blat mit Exchange 2007 Probleme

Frage Entwicklung Batch & Shell

Mitglied: Razfaz

Razfaz (Level 1) - Jetzt verbinden

11.11.2010 um 14:58 Uhr, 5928 Aufrufe, 1 Kommentar

Hallo,

ich bin am verzweifeln.
Folgende Sache.
Ich möchte gerne eine Mail mit Blat per Batch Datei verschicken.
Wir nutzen einen exchange Server 2007.
Wenn ich intern eine Mail über diese Batch verschicke, klappt das wunderbar.
Das will ich aber nicht, denn diese Mail soll an eine externe Adresse gehen.

Erstmal meine Batch Datei:
cd /d C:\blat262\full 
 
Blat -install mail.exchangeserver.de xxx@exchangeserver.de 
Blat "C:\Test\Test1\test1.txt" ^ 
-to xxx@kabelmail.de -server exchangeserver.de -u username -pw passwort ^ 
-debug -timestamp -log blatSMTPlog.txt ^ 
-subject "Backup auf Server-1"
Als Usernamen habe ich meine AD Anmeldung genommen und das dazugehörige Passwort.

Dies bekomme ich dann in der log Datei als FM:
2010.11.11 14:44:55 (Thu)------------Start of Session----------------- 
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19) 
2010.11.11 14:44:55 (Thu): <<<getline<<< 220 S-EBS2.exchangeserver.local ESMTP Service ready 
2010.11.11 14:44:55 (Thu): >>>putline>>> EHLO R213.exchangeserver.de 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-Requested mail action okay, completed 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-SIZE 0 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-AUTH NTLM 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-8BITMIME 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-BINARYMIME 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250-CHUNKING 
2010.11.11 14:44:55 (Thu): <<<getline<<< 250 OK 
2010.11.11 14:44:57 (Thu): Sending C:\Test\Test1\test1.txt to xxx@kabelmail.de 
2010.11.11 14:44:57 (Thu): Subject: Backup auf Server-1 
2010.11.11 14:44:57 (Thu): Login name is xxx@exchangeserver.de 
2010.11.11 14:44:57 (Thu): >>>putline>>> AUTH LOGIN 
2010.11.11 14:45:02 (Thu): <<<getline<<< 504 Command parameter not implemented 
2010.11.11 14:45:02 (Thu): The SMTP server does not require AUTH LOGIN. 
Are you sure server supports AUTH? 
2010.11.11 14:45:02 (Thu): >>>putline>>> MAIL FROM:<xxx@exchangeserver.de> 
2010.11.11 14:45:02 (Thu): <<<getline<<< 250 Requested mail action okay, completed 
2010.11.11 14:45:02 (Thu): >>>putline>>> RCPT TO:<xxx@kabelmail.de> 
2010.11.11 14:45:07 (Thu): <<<getline<<< 550 Requested action not taken: mailbox unavailable 
2010.11.11 14:45:07 (Thu): The SMTP server does not like the name xxx@kabelmail.de. 
Have you set the 'To:' field correctly, or do you need authorization (-u/-pw) ? 
2010.11.11 14:45:07 (Thu): The SMTP server response was -> 550 Requested action not taken: mailbox unavailable 
2010.11.11 14:45:07 (Thu): >>>putline>>> QUIT 
2010.11.11 14:45:07 (Thu): <<<getline<<< 221 Service closing transmission channel 
2010.11.11 14:45:07 (Thu)-------------End of Session------------------
Wo liegt da mein Fehler?
(Der Name exchangeserver habe ich gegen unseren Domänennamen ausgetauscht)
Mitglied: filippg
11.11.2010 um 21:23 Uhr
Hallo,

dein Server erlaubt kein Relaying (was auch gut ist). Suche nach Exchange 2007 Relay Connector.
Workaround: Richte für den externen Nutzer eine Kontakt ein. Der hat dann auch eine interne Adresse, und an die solltest du schicken können ohne die Relay-Einstellunge zu ändern (und Exchange schickt es dann an die externe).

Gruß

Filipp
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 Probleme - Autodiscover oder noch mehr? (2)

Frage von PowlFruit zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 und 2010 Koexistenz - Transportprobleme (3)

Frage von john-doe zum Thema Exchange Server ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
NTFS und die Defragmentierung (26)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Zwei Subnetze mit je eigenem Router und Internetzugang verbinden (18)

Frage von hannsgmaulwurf zum Thema LAN, WAN, Wireless ...

Windows Server
WIndows Server 2016 core auf dem Intel NUC NUC5i5RYK i5 5250U (17)

Frage von IxxZett zum Thema Windows Server ...