Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

In der boot.ini drei Betriebssysteme eingetragen. Zwei laufen, aber beim dritten wird der Laufwerksbuchstabe nicht auf C geändert

Frage Microsoft

Mitglied: derElch

derElch (Level 1) - Jetzt verbinden

27.03.2012, aktualisiert 15:00 Uhr, 2400 Aufrufe, 9 Kommentare

Hallo,

ich habe folgende boot.ini geschrieben
01.
[boot loader] 
02.
timeout=30 
03.
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS 
04.
[operating systems] 
05.
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="XP Professional STARTER" /noexecute=optin /fastdetect 
06.
multi(0)disk(0)rdisk(0)partition(1)\Windows="XP Professinoal SIMOTION die zweite" /noexecute=optin /fastdetect 
07.
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="XP Professional SIMOTION" /noexecute=optin /fastdetect
Die Partitionen „XP Professional STARTER“ und „XP Professional SIMOTION“ starten ohne Probleme und der Laufwerksbuchstabe wird auf C geändert.
Die Partition „XP Professional SIMOTION die zweite startet“ zwar, aber der Laufwerksbuchstabe wird nicht auf C geändert. Dadurch
laufen die Programme nicht korrekt.
Hat einer von euch eine Idee, woran das liegen könnte und was ich machen muss, damit auch bei der Partition „XP Professional SIMOTION die zweite“
der Laufwerksbuchstabe auf C geändert wird?

Hintergrund ist, das ich verschieden Softwaren habe, die nicht zusammen auf einem Betriebssystem laufen. Eine VM kann ich nicht
nutzten da ich dann vom Hersteller keinen Support mehr bekomme, da die Software nicht für eine VM freigegeben ist. Bisher hatte ich zwei einzelne
Festplatte, wo jeweils ein Betriebssystem drauf lief, ohne Probleme. Jetzt habe ich eine Festplatte durch eine SSD getauscht und
möchte dort beide Betriebsystem drauf laufen lassen. Dann würde auch der Eintrag für die Partition „XP Professional SIMOTION“ wieder
gelöscht

Danke.

Gruß

David
Mitglied: mak-xxl
27.03.2012 um 15:19 Uhr
Moin David,

das änderst Du am schnellsten in der Registry des betroffenen Systems: Nach dem String '\DOSDEVICES\#:' suchen - dabei das '#' durch den Buchstaben ersetzen, den Dein Bootlaufwerk fälschlicherweise bekommt - wenn gefunden, dann C tauschen/eintragen (C ist momentan ein anderes LW bei Dir?!). Aufpassen, dass <pagefile.sys> auf einem LW liegt, das beim Start seinen Buchstaben behält, sonst schlägt die Anmeldung fehl.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: cardisch
27.03.2012 um 16:11 Uhr
Tach

Ich hatte das in ähnlicher Art auch schon, aber ein einfacher Registryeintrag zum ändern des Laufwerksbuchstaben hat mir noch nie geholfen.
Vielleicht lag es bei mir daran, dass ich zwei Klone in einem System hatte und vom einen der Systemordner genommen wurde, vonm anderen die Pagefile.sys und die Bootdateien...
Aber selbst eine Fehlinstallation mit aktiviertem Kartenleser hat mich noch nie eine solche Systemumstellung vornehmen lassen....
Ich befürchte da hast du keine Chance...
Gruß

Carsten
Bitte warten ..
Mitglied: derElch
28.03.2012 um 08:06 Uhr
Hallo Mario,

meine DOSDEVICES, auf der betroffenen Partition, sieht wir folgt aus:

\DosDevices\C:
\DosDevices\D:
\DosDevices\E:
\DosDevices\F:
\DosDevices\G:
\DosDevices\H:
\DosDevices\I:
\DosDevices\J:

Zu Deiner Frage in (). Im dem Moment wo die betroffenen Partition nicht C ist, ist aber schon eine andere Partition, ebenfalls mit Betriebssytem schon C.

Die Datei pagefile.sys gibt es bei mir auf zwei Laufwerken einmal auf C, E und F. Das sind jeweils die drei Partitionen, wo auch ein Betriebssytem installiert ist.

Ich bin mir jetzt nicht sicher, was ich in der Registry ändern soll?

Gruß

David
Bitte warten ..
Mitglied: mak-xxl
28.03.2012 um 08:20 Uhr
Moin David,

angenommen (Du hast es leider nicht erwähnt), das aktuelle Systemlaufwerk trägt den Buchstaben 'F' (vgl. das sicherheitshalber in der ->Datenträgerverwaltung!). Dann so:

- '\DosDevices\F:' ändern in '\DosDevices\Fx:'
- '\DosDevices\C:' ändern in '\DosDevices\F:'
- '\DosDevices\Fx:' ändern in '\DosDevices\C:'
- Registry schließen und neu starten.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: derElch
30.03.2012 um 07:50 Uhr
Hallo Mario,

ich habe das jetzt versucht. Leider ohne Erfolg. Ich kann zwar die DosDevices umbenennen, aber nach dem Neustart ist wieder alles beim alten. Also wieder auf F gebootet. Hast Du noch eine Idee? Oder könnte es was mit der pagefile.sys zu tun haben, da ich diese auf jedem der drei Bootfähigen Partitionen finde?

Danke.

Gruß

David
Bitte warten ..
Mitglied: mak-xxl
30.03.2012 um 08:17 Uhr
Moin David,

mach doch bitte mal einen (ausreichend großen) Screenshot aller fraglichen HDDs aus der Datenträgerverwaltung und hänge da die Ausgabe von
01.
mountvol > hdd.dat
an - das Ganze u.U. per PM, wenn es datenkritisch sein sollte.

Mit der Datei <pagefile.sys> hat das Buchstabenproblem nichts zu tun - andersrum: Wenn XP beim Hochfahren wegen Umbenennung der Laufwerke keinen der Laufwerksbuchstaben vorfindet, die für das Anlegen einer Auslagerungsdatei angegeben sind, kannst Du Dich evtl. nicht anmelden, weil XP dann in eine Endlosschleife fällt. Bei mehreren Partitionen im Rechner ist das aber kein Problem.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: derElch
30.03.2012 um 09:02 Uhr
Hallo Mario,

eine Screenshot habe ich gemacht. Würde ich gerne auch Online stellen bzw. Dir schicken, aber wie? Den Rest "01. mountvol > hdd.dat an - das Ganze u.U. per PM, wenn es datenkritisch sein sollte." verstehe ich leider nicht.

Gruß

David
Bitte warten ..
Mitglied: mak-xxl
30.03.2012 um 10:27 Uhr
Moin David,

mit datenkritisch war gemeint, dass aus einem Screenshot i.e. aus den Volumebezeichnungen Firmen- bzw. Verwendungshinweise entnehmbar sind und der Hilfesuchende vermeiden möchte, dass diese öffentlich einsehbar sind. Eine PM kannst Du üblicherweise versenden, indem Du im Profil auf 'Schreibe eine persönliche Nachricht an ...' klickst - das habe ich soeben getan (in Deinem Profil), Du kannst also bereits mit Anhängen antworten.
Mit dem Befehl (auf der Kommandozeile)
01.
mountvol > hdd.dat
wird eine Datei <hdd.dat> erzeugt, die Du samt Screenshot schickst.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: 106009
30.03.2012 um 12:20 Uhr
Sorry, nicht richtig gelesen, gelöscht.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Linux
LTSP: PXE Boot funktioniert nicht (22)

Frage von Fenris14 zum Thema Linux ...

Windows Server
Windows-Update für Secure-Boot-Fehler macht BIOS-Updates erforderlich (2)

Link von Penny.Cilin zum Thema Windows Server ...

Windows Installation
PXE Boot-Von CD Starten (2)

Frage von STITDK zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...