Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bootproblem - PCI SATA Card immer vor integriertem MB SCSI Controller

Frage Hardware

Mitglied: 49044

49044 (Level 1)

03.06.2007, aktualisiert 04.06.2007, 7518 Aufrufe, 3 Kommentare

Konfig:
MB K7N2 Delta ILSR
OS: Win XP Prof. SP2
2 x 160 GB (3 Partitionen, XP auf 1 Partition installiert) im Stripe 0 an Promise 20376 Serial ATA-Interface
?(Unterstützung für 2 serielle ATA plus 1 ATA133
- Unterstützung für RAID 0 oder 1
- RAID-Funktion steht für w/ATA133+SATA H/D oder 2 SATA H/D zur
Verfügung)
1 x 500 GB SATA an Promise SATA300 TX4302 - PCI Karte

Hallo Zusammen,

nachdem ich mich durch sämtliche Storage - Raid - MSI Foren gewühlt habe und auch hier schon mehrfach gesucht habe, versuche ich mal mittels eines Beitrags einen Lösungsansatz für mein Problem zu bekommen.

Problem:
Die o. g. PCI SATA Karte von Promise möchte generell als erste Platte starten. Da dort nur Files liegen und kein OS installiert ist, funktioniert das natürlich nicht.
Ich möchte entweder, dass der interne Promise mit dem RAID Verbund zuerst startet und die PCI Karte beim booten nicht berücksichtigt wird, oder aber vielleicht einen Startverweis (Boot.ini??) auf der externen Platte steht, der die Anweisung gibt über den internen Promise zu booten.

Die Erkennung beider SCSI Controller funktioniert - Alle Platten werden erkannt. Schalte ich die externe Platte beim Start aus, kommt die Meldung "BIOS not installed" (...der Controller wird sozusagen übersprungen) und dann wird XP ganz normal vom internen Promise gebootet.

Was ich bereits probiert habe:
- Sämtliche Bootreihenfolgen im MB durchzutesten - Fakt, der interne SCSI hat immer Vorrang, egal welchen PCI Slot ich für die SATA PCI Karte verwende.
- Keine Partition auf der externen Platte als aktiv zu markieren - Läuft nicht auf die aktive Partition am internen Promise weiter, sondern bleibt stehen.
- BIOS der SATA PCI Karte ändern - Geht nicht und Einstellmöglichkeiten gibt es auch nicht.
(Evtl. Methode ggfs. BIOS ändern, abder damit kenne ich mich überhaupt nicht aus! )
- 1ste Partition auf extener Platte als aktiv gesetzt, ntldr, ntdetect kopiert und boot.ini wie nachstehend geändert:

Original:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /noexecute=optin /fastdetect

Geändert:
[boot loader]
timeout=30
default=multi(0)disk(2)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(2)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /noexecute=optin /fastdetect

...ich glaube das war's bis jetzt.

Also für mich wäre jetzt erste Wahl die Variante mit der boot.ini. Aber bisher hat die nicht geklappt - vielleicht auch weil ich es falsch gemacht habe.

Vielen Dank vorab für Eure Hilfe!

Lucky-Striker
Mitglied: Klugscheisserman
04.06.2007 um 07:30 Uhr
Moin,
Wenn ich dich richtig verstehe, versuchst du in einem System, in dem sowohl SCSI als auch IDE Festplatten verbaut sind, von SCSI zu booten ( Ob S-ATA oder P-ATA, is egal, ist beides IDE).
Dies ist afaik nicht möglich, beim booten wird IDE grundsätzlich bevorzugt.

Auch wenns wahrscheinlich nicht hilfreich war

Gruß von mir
Bitte warten ..
Mitglied: 49044
04.06.2007 um 09:07 Uhr
Guten Morgen,

naja, nicht wirklich.
Die Promise PCI SATA Karte wird nur als "SCSI" angesprochen und der interne auf dem MB verbaute Promise Controller (RAID 0 / 1) ebenfalls. Defacto keine wirklichen SCSI Controller.
Es hängen ausschließlich SATA Platten dran.
Und das Booten einer IDE Platte kann ich ja über das MB abfangen, dass wäre nicht das Problem.
Prinzipiell ist es ganz einfach, wie bekomme ich es hin, dass der PCI Controller generell nach dem internen Controller angesprochen wird => Bootsequenz.
Da ich nicht der einzige mit diesem Problem bin und ich nicht glaube, diese Sequenz so ändern zu können, denke ich, das ein Bootverweis auf der Platte am PCI Controller ein ganz guter Workaround wäre. Nur - wie funktioniert das!

Gruss Lucky-Striker
Bitte warten ..
Mitglied: woodlanddragon
28.10.2009 um 20:47 Uhr
Hallo zusammen,

ich schieb das hier mal nach oben, da ich genau vor dem selben Problem stehe. Ein Raid 1 ist am Motherboard Raid Controller (ist ein Sil 3112a auf einem ASUS a7n8x deluxe) voll funktionsfähig. Das Betriebssystem startet einwandfrei. Als ich jedoch heute meinen Sil 3114 SATA Raid Controller in den PCI Slot steckte und ein DVD-RW anschloss kam die nette Nachricht:

DISK BOOT FAILURE PLEASE INSERT SYSTEM DISK AND PRESS ENTER

Nach längerem Suchen kam mir die Erleuchtung es müsse sich um den Eintrag in der boot.ini handeln.

Bis her habe ich ausprobiert:

multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(1)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(1)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

also eigentlich alles durch.

Leider kenn ich mich mit der boot.ini nicht so gut aus. Vorallem was SCSI Einstellungen angeht. Vielleicht aber kann mir hier jemand einen Tip geben wie ich die boot.ini ändern muss, damit das Betriebssystem wieder anspringt.

Oder liegt es vielleicht garnicht an der boot.ini?

Vielgruß
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Gibt es PCI-E Karte für Hardware Acceleration bei Gzip (o.Ä.) ? (15)

Frage von mm1492 zum Thema Server-Hardware ...

Exchange Server
SBS2011: POP3-Connector 10 MB Grenze Email Benachrichtigung (20)

Frage von bogi1102 zum Thema Exchange Server ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...

Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (15)

Frage von marshall75000 zum Thema Router & Routing ...

Microsoft Office
Saubere HTML aus Word-Dokument (15)

Frage von peterpa zum Thema Microsoft Office ...

Hosting & Housing
gelöst Webserver bei WIX, aber DNS Server wo anders (9)

Frage von laster zum Thema Hosting & Housing ...