Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Bridge mit mehreren VLANS in der selben Broadcast Domäne

Frage Sonstige Systeme MikroTik RouterOS

Mitglied: specialguest

specialguest (Level 1) - Jetzt verbinden

08.02.2015, aktualisiert 16:49 Uhr, 1837 Aufrufe, 5 Kommentare, 1 Danke

Hallo Zusammen,

ich habe da aktuell eine kleine Schwierigkeit bei der ich nicht weiterkomme.

Ich habe ein Mikrotik Router an dem ein TP-Link WLAN AP hängt. Dieser ist MultiSSID fähig und kann diese auch mit VLAN Tag an den Mikrotik weitergeben.

Zu diesem Zweck habe ich auf dem TP-Link 2 SSID mit den VLANID's 100 und 200 eingerichtet.
Diese liegen beide am Interface 9 meines Mikrotik an. Auf Interface 9 habe ich nun analog ein VLAN100 und ein VLAN200 eingerichtet.
Beide VLAN's sollen nun zusammen mit einem weiterem Interface (welches als Switch-Master fungiert) in eine gemeinsame Bridge.
Auf dieser Bridge hängt dann ein DHCP-Server der alle 3 Bridgeports mit einem Scope versorgen soll.

Hintergrund für diese Konstellation und die Anforderung alles in einer Broadcast Domäne zu haben ist ein Heimnetzwerk das privaten und Gast-WLAN-Zugang trennen soll und gemeinsam Sonos nutzen können soll was ja bekanntlich nur in der selben Broadcast Domäne funktioniert.

Hat jemand eine Idee wie man das bewerkstelligen kann. Meine Versuche waren bisher leider nicht
von Erfolg gekrönt.

Die aktuelle -nicht funktionierende - Konfiguration sieht wie folgt aus:
An dem e9-wlan hängt im Übrigen der TP-Link AP. Sonos hängt mit am Switch "sw1" (siehe unten).

  1. feb/08/2015 13:36:10 by RouterOS 6.26
  2. software id = Y4D4-VXI8

/interface ethernet
set [ find default-name=ether1 ] name=e1-sw1-master
set [ find default-name=ether2 ] master-port=e1-sw1-master name=e2-sw1
set [ find default-name=ether3 ] master-port=e1-sw1-master name=e3-sw1
set [ find default-name=ether4 ] master-port=e1-sw1-master name=e4-sw1
set [ find default-name=ether5 ] master-port=e1-sw1-master name=e5-sw1
set [ find default-name=ether9 ] name=e9-wlan
set [ find default-name=ether10 ] name=e10-internet
set [ find default-name=ether6 ] disabled=yes
set [ find default-name=ether7 ] disabled=yes
set [ find default-name=ether8 ] disabled=yes
set [ find default-name=sfp1 ] disabled=yes

/interface bridge
add name=br1

/interface vlan
add interface=e9-wlan l2mtu=1594 name=vlan100 vlan-id=100
add interface=e9-wlan l2mtu=1594 name=vlan200 vlan-id=200

/ip pool
add name=dhcp_pool1 ranges=192.168.10.50-192.168.10.100

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 disabled=no interface=br1 lease-time=1d name=dhcp1

/interface bridge port
add bridge=br1 interface=e1-sw1-master
add bridge=br1 interface=vlan100
add bridge=br1 interface=vlan200

/ip address
add address=192.168.10.1/24 interface=br1 network=192.168.10.0

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=e10-internet

/ip dhcp-server network
add address=192.168.10.0/24 gateway=192.168.10.1

/ip dns
set allow-remote-requests=yes

/ip firewall nat
add action=masquerade chain=srcnat out-interface=e10-internet

Viele Grüße
S.
Mitglied: colinardo
LÖSUNG 08.02.2015, aktualisiert um 16:49 Uhr
Hallo specialguest, Willkommen auf Administrator.de!
Das solltest du mit einem IGMP-Proxy auf dem Mikrotik abfackeln können, dann benötigst du die Netze nicht in einer gemeinsamen Broadcast-Domain, denn das ganze basiert auf Multicast-Basis, und die Broadcasts lassen sich mit einem IGMP-Proxy in die entsprechenden Netze weiterleiten: http://wiki.mikrotik.com/wiki/Manual:Routing/IGMP-Proxy
Dazu musst du noch das Package multicast auf dem Mikrotik nachinstallieren, und in der Firewall nicht vergessen Multicast-Traffic zwischen den Netzen zu erlauben.

Grüße Uwe
Bitte warten ..
Mitglied: specialguest
08.02.2015 um 14:39 Uhr
Hallo Uwe,

besten Dank für die schnelle Antwort. Sehr gute Idee, das würde das Gesamtkonstrukt sogar etwas
sauberer trennen.. Dein Vorschlag würde also lauten, mehrere Subnetze und dazwischen ein IGMP-Proxy?
Das würde die Bridge dann ja m.E. auch überflüssig machen.
Das Package habe ich gerade installiert. Werde mir das mal anschauen.

Grüße
Silvio
Bitte warten ..
Mitglied: colinardo
08.02.2015, aktualisiert um 15:03 Uhr
Dein Vorschlag würde also lauten, mehrere Subnetze und dazwischen ein IGMP-Proxy?
Ja ... bei einem Gastnetz das in der selben BC-Domain wie das normale LAN läuft mir nämlich ein kalter Schauer den Rücken runter

Ob das für die SONOS Teile ausreicht musst du testen, kenne die Geräte jetzt nicht persönlich, aber normalerweise sollte das damit laufen. Ansonsten hilft ein Wireshark-Trace weiter.
Bitte warten ..
Mitglied: specialguest
08.02.2015, aktualisiert um 17:01 Uhr
So, geschafft. Der Tipp war auf jeden Fall die richtige Richtung. Leider hat der IGMP Proxy aber nicht ganz wie gehofft sein Werk getan. Ich kann nicht genau sagen, was konkret beim Proxy nicht sauber läuft aber funktionieren tut es erst mit dem großen Bruder "PIM" (http://wiki.mikrotik.com/wiki/Manual:Routing/Multicast#Protocol_indepen ...).
Habe nun die gesamte Konfiguration einmal übern Haufen geworfen und nochmal sauber und getrennt aufgebaut.

Habe zum Schluss dann erstmal alle relevanten Interfaces in den PIM rein geworfen und schwupp... gings!
Der vorherige Weg mit einer Broadcast-Domäne war auch nicht mein Favorit aber ich hatte gerade keine Alternativen im Kopf.

Werde nun noch mit der Firewall für die nötige Isolation sorgen.

Danke nochmal.

Und hier die Konfig für die Nachwelt:

/export compact
  1. feb/08/2015 16:52:30 by RouterOS 6.26
  2. software id = Y4D4-VXI8

/interface ethernet
set [ find default-name=ether1 ] name=e1-sw1-master-nas
set [ find default-name=ether2 ] master-port=e1-sw1-master-nas name=e2-sw1-slave-sonos
set [ find default-name=ether3 ] name=e3-arbeitszimmer
set [ find default-name=ether9 ] name=e9-wlan
set [ find default-name=ether10 ] name=e10-internet

/interface vlan
add interface=e9-wlan l2mtu=1594 name=vlan910-wlan-privat vlan-id=910
add interface=e9-wlan l2mtu=1594 name=vlan920-wlan-gast vlan-id=920

/ip pool
add name=dhcp_pool1 ranges=10.0.3.40-10.0.3.50
add name=dhcp_pool2 ranges=10.0.1.40-10.0.1.45
add name=dhcp_pool3 ranges=10.0.9.100-10.0.9.105
add name=dhcp_pool4 ranges=10.0.91.40-10.0.91.70
add name=dhcp_pool5 ranges=10.0.92.40-10.0.92.50

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 disabled=no interface=e3-arbeitszimmer lease-time=5d name=dhcp1
add add-arp=yes address-pool=dhcp_pool2 disabled=no interface=e1-sw1-master-nas lease-time=3d name=dhcp2
add add-arp=yes address-pool=dhcp_pool3 disabled=no interface=e9-wlan lease-time=3d name=dhcp3
add add-arp=yes address-pool=dhcp_pool4 disabled=no interface=vlan910-wlan-privat lease-time=1d name=dhcp4
add add-arp=yes address-pool=dhcp_pool5 disabled=no interface=vlan920-wlan-gast lease-time=12h name=dhcp5

/ip address
add address=10.0.1.1/24 interface=e1-sw1-master-nas network=10.0.1.0
add address=10.0.3.1/24 interface=e3-arbeitszimmer network=10.0.3.0
add address=10.0.9.1/24 interface=e9-wlan network=10.0.9.0
add address=10.0.91.1/24 interface=vlan910-wlan-privat network=10.0.91.0
add address=10.0.92.1/24 interface=vlan920-wlan-gast network=10.0.92.0

/ip dhcp-client add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=e10-internet

/ip dhcp-server network
add address=10.0.1.0/24 gateway=10.0.1.1
add address=10.0.3.0/24 gateway=10.0.3.1
add address=10.0.9.0/24 gateway=10.0.9.1
add address=10.0.91.0/24 gateway=10.0.91.1
add address=10.0.92.0/24 gateway=10.0.92.1

/ip dns set allow-remote-requests=yes

/ip firewall nat add action=masquerade chain=srcnat out-interface=e10-internet

/routing pim interface add igmp-version=IGMPv3 interface=e1-sw1-master-nas add interface=e9-wlan add interface=e3-arbeitszimmer add interface=vlan920-wlan-gast
Bitte warten ..
Mitglied: colinardo
08.02.2015, aktualisiert um 18:12 Uhr
Alles klar. Danke für deine positive Rückmeldung. Kannte die Protokolle der SONOS Dinger nicht, deswegen hatte ich erst mal die "harmlose" Variante des Proxies gewählt, die hat wohl nicht ausgereicht

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
VLANs Bridge
gelöst Frage von kicki44LAN, WAN, Wireless7 Kommentare

Hi, ich habe zwei Swichtes mit je drei VLANs eingerichtet. Nun möchte ich beide Switche mit einer Bridge verbinden. ...

LAN, WAN, Wireless
Broadcast-Strom VLAN-übergreifend?
Frage von ITgustelLAN, WAN, Wireless4 Kommentare

Hi, eine Frage, wir haben versuchsweise mal einen Broadcast-Strom in einem VLAN provoziert. Dabei ist uns aufgefallen, dass dann ...

Router & Routing
Vlan Verbindungsproblem mit WLAN Bridge
Frage von MackDaddyRouter & Routing6 Kommentare

Hallo mein Problem ist das Vlan2 nicht auf den Fileserver zugreifen kann. Im Switch sind die Vlans eingerichtet und ...

MikroTik RouterOS
Mikrotik Wireless Bridge + VLAN
gelöst Frage von whitbreadMikroTik RouterOS2 Kommentare

Ich habe inzwischen 3 Mikrotik Router hier stehen. Einer dient zur PPOE- Einwahl, der zweite trennt mir die einzelnen ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Sicherheitslücke Spectre und Meltdown: Status prüfen

Anleitung von Frank vor 5 StundenErkennung und -Abwehr1 Kommentar

Nach all den Updates der letzten Woche sollte man unbedingt auch den Status prüfen, ob die Sicherheitslücke Spectre und ...

Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office9 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner15 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...