Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Buffer Overflow bei SCSI Befehl

Frage Hardware Peripheriegeräte

Mitglied: MCKiller

MCKiller (Level 1) - Jetzt verbinden

31.03.2007, aktualisiert 26.09.2007, 5525 Aufrufe, 2 Kommentare

Symantec Backup Exec 11d auf w2k3 SBS liefert ein buffer overflow von meinem Bandlaufwerk Certance Dat72 an Adaptec 2000S RAID Controller

Hallo Leute,

ich habe da ein Problem mit meinem neu eingerichteten W2k3 Server:

  • Controller ist ein Adaptec 2000S Raid
  • Bandlaufwerk ist ein SCSI Certance Dat72 intern und nicht als Endgerät am SCSI Bus
  • 2 SCSI Festplatten als RAID 1 konfiguriert.
  • Backupsoftware ist Symantec BAckup Exec 11d

Wenn ich nun z.B. ein Tape über die Backupsoftware löschen möchte, bekomme ich folgende Fehlermeldung:

Der Treiber hat einen Controllerfehler auf \Device\Scsi\dpti2o1 gefunden.
Ein Trace auf dem SCSI Bus ergab folgendes Ergebnis:

Event: 3219 Start: 1447.890 Stop: 0.000 Type: SRB event
SCSI Address: 02:00:04:00
Function SRB_FUNCTION_EXECUTE_SCSI
SRB Status SRB_STATUS_DATA_OVERRUN
SCSI Status SCSISTAT_GOOD
Flags SRB_FLAGS_DISABLE_SYNCH_TRANSFER
SRB_FLAGS_DATA_IN
SRB_FLAGS_NO_QUEUE_FREEZE
Sense Length 18
Data Length 12
Driver Result STATUS_BUFFER_OVERFLOW

Raw CDB
1A 08 11 00 0E 00 ......

CDB Operation MODE_SENSE6
LUN 0
DBD True
Page Code Current Values(0)
Alloc Length 14
Control 0x00
Data
0B 35 10 00 11 06 01 00 10 03 00 00 .5..........


Aber die Backupsoftware schreibt, dass der JOB richtig ausgeführt wurde und keine Fehler enthält.
Das Analyse Tool von Certance "xTalk" zeigt mir jedoch keinerlei Fehler mit dem Bandlaufwerk an.

Jetzt zu meinen Fragen:

  • Sollte man es vermeiden ein Bandlaufwerk an einem Raid Controller anzuschliene? Hab das mal gehört. Was ist da dran?
  • Kann ich den Fehler ignorieren oder kann es hier zu Datenverlust kommen?
  • Muss ich am SCSI Controller was umkonfigurieren? Oder am Bandlaufwerk?

THX
Heiko
Mitglied: MCKiller
01.04.2007 um 00:41 Uhr
Ahhrg...

Habe den Fehler selber gefunden.
Aber ganz umsonst war der Eintrag hier nicht, da ich genau beim schreiben auf die Lösung gekommen bin.

Windows 2k3 Server hat meinen Controller also Adaptec 2000S erkannt. Es ist aber ein 2100S.

Ich dachte der Microsoft Treiber ist aktueller als der von Adaptec, weil der Controller schon etwas älter ist.

Nachdem ich mir die Treiber gezogen habe, erkannte Windows den Controller auch richtig und siehe da.....

Keine Fehlermeldung mehr.

Mano. Ein echter Newb - Fehler

Gruß
Heiko
Bitte warten ..
Mitglied: chrischa
26.09.2007 um 08:27 Uhr
Hallo Heiko,

ich habe das selbe Problem bei einem Kunden.

Das mit den Treibern werde ich mal ausprobieren. Gut das du diesen Beitrag begonnen hast. ;)

Gruß chrischa
Bitte warten ..
Ähnliche Inhalte
Windows 7
Link auf Desktop um CMD Befehl auszuführen (7)

Frage von XPFanUwe zum Thema Windows 7 ...

Batch & Shell
gelöst Batch-Befehl oder Windows-Freeware-Tool gesucht zum Wandeln von ASCII in ANSI (8)

Frage von Sinzal zum Thema Batch & Shell ...

Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Batch & Shell
gelöst Powershell Befehl für IPv4 Adresse und DNS automatisch beziehen (5)

Frage von Airine zum Thema Batch & Shell ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Viren und Trojaner
Ransomware .nm4 (15)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

iOS
16 iPads zentrall verwalten (14)

Frage von simonlohr zum Thema iOS ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...