Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bug oder Userproblem?

Frage Microsoft

Mitglied: Tranministrator

Tranministrator (Level 1) - Jetzt verbinden

03.12.2007, aktualisiert 20:53 Uhr, 3775 Aufrufe, 5 Kommentare

Hallo an alle Computer-Nutzer!

Ich hoffe ihr könnt mir ein wenig helfen, seit längerem beschäftigt mich ein Thema was eigentlich harmlos wie eine Mücke ist.
Ich starte heut das 2te mal einen Batch vom Desktop:

"C:\Dokumente und Einstellungen\Administrator\Desktop\subst.cmd"

Dieser Batch beinhaltet:


subst v: c:\Futura

Und nun das Problem, anscheinend wird dieser wiederholt, doch ohne jegliche Ausführung.

Nicht mal mein IT Lehrer konnte mir da auf die Sprünge und jetzt treffe ich wieder auf dieses Problem,
hoffe ihr könnt mir da ne plausible Antwort geben, dankee und tschüüüss

Robs
Mitglied: jato11
03.12.2007 um 16:46 Uhr
Hallo Robs,
ich würde den Dateinamen mal ändern in x.cmd

Viele Grüße
Torsten
Bitte warten ..
Mitglied: Tranministrator
03.12.2007 um 17:18 Uhr
hohoho, vielen dank, hat gepasst.
Jetzt kommt mir auch wieder alles hoch, hatte das schon mal.
Hast du da auch eine Ahnung warum er beim selben Dateinamen wie der Befehl abschmiert?
Danke nochmal bybye
Viele Grüße zurück
Bitte warten ..
Mitglied: VW
03.12.2007 um 17:40 Uhr
Moin,

ich habe leider auch nur eine Vermutung.

Der eigentliche Befehl wird von der cmd leider in dem Fall als Dateiname betrachtet, da die Datei im selben Verzeichnis liegt und damit eine höhere Priorität als die Dateien/Befehle in der %PATH% hat.

Dadurch führt sich die cmd-Datei immer wieder selbst aus, wobei "v: c:\Futura" als Parameter übergeben wird.

Noch zu testen wäre das Verhalten, wenn man einen anderen Befehl ausführt, zu dem aber auch eine gleichnamige Datei im gleichen Verzeichnis liegt, die z.B. eine Datei erstellt, um anzuzeigen, dass sie ausgeführt wurde.

Mit freundlichen Grüßen,
VW
Bitte warten ..
Mitglied: VW
03.12.2007 um 17:46 Uhr
Moin schon wieder,

ich konnte das Verhalten leider gerade weder mit der Datei, die den befehlsnamen hat, der ausgeführt wird, noch mit der o.g. zweiten Datei nachstellen.

Vielleicht kannst du meinen vorgeschlagenen Versuch selber durchführen und das Ergebnis posten?
Würde mich ja mal interessieren.

Mit freundlichen Grüßen,
VW

[edit]
Mit dem Befehl "subst" habe ich auch eine Schleife.
Begründung: "subst" ist eine Datei innerhalb der %PATH%, während echo (mein vorheriger Test) direkt als Befehl in der cmd implementiert ist.

Der Test mit 2 Dateien:
Wenn beide Befehle als *.exe in %PATH% existieren und nicht direkt von der cmd implementiert sind, funktioniert es (getestet mit wuauclt und subst)
[/edit]
Bitte warten ..
Mitglied: jato11
03.12.2007 um 20:53 Uhr
hohoho, vielen dank, hat gepasst.
Jetzt kommt mir auch wieder alles hoch,
hatte das schon mal.
Hast du da auch eine Ahnung warum er beim
selben Dateinamen wie der Befehl abschmiert?
Nein, kann ich auch nicht genau sagen, aber das war
früher schon zu DOS-Zeiten nicht unproblematisch.

Deshalb vermeide ich Namen die genauso lauten wie interen Befehle.

Du könntest um eine Beziehung zum Inhalt hertzustellen den Namen erweitern
z.B. xsubst.cmd. Dann steht "x" für eigenes Programm.


Viele Grüße
Torsten
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Administrator.de Feedback
Bug? "m f g" (ohne Leerzeichen) wird auch in URL ersetzt (4)

Frage von emeriks zum Thema Administrator.de Feedback ...

Administrator.de Feedback
gelöst Bug beim Übernehmen der Überschriften-Texte von Links? (2)

Frage von Lochkartenstanzer zum Thema Administrator.de Feedback ...

Administrator.de Feedback
gelöst Bug bei Textanzeige im Tab (Browser) (3)

Frage von Alexander.Schmitt zum Thema Administrator.de Feedback ...

Administrator.de Feedback
Bug beim Antwortcounter? (5)

Frage von Sheogorath zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...