Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bug oder Userproblem?

Frage Microsoft

Mitglied: Tranministrator

Tranministrator (Level 1) - Jetzt verbinden

03.12.2007, aktualisiert 20:53 Uhr, 3795 Aufrufe, 5 Kommentare

Hallo an alle Computer-Nutzer!

Ich hoffe ihr könnt mir ein wenig helfen, seit längerem beschäftigt mich ein Thema was eigentlich harmlos wie eine Mücke ist.
Ich starte heut das 2te mal einen Batch vom Desktop:

"C:\Dokumente und Einstellungen\Administrator\Desktop\subst.cmd"

Dieser Batch beinhaltet:


subst v: c:\Futura

Und nun das Problem, anscheinend wird dieser wiederholt, doch ohne jegliche Ausführung.

Nicht mal mein IT Lehrer konnte mir da auf die Sprünge und jetzt treffe ich wieder auf dieses Problem,
hoffe ihr könnt mir da ne plausible Antwort geben, dankee und tschüüüss

Robs
Mitglied: jato11
03.12.2007 um 16:46 Uhr
Hallo Robs,
ich würde den Dateinamen mal ändern in x.cmd

Viele Grüße
Torsten
Bitte warten ..
Mitglied: Tranministrator
03.12.2007 um 17:18 Uhr
hohoho, vielen dank, hat gepasst.
Jetzt kommt mir auch wieder alles hoch, hatte das schon mal.
Hast du da auch eine Ahnung warum er beim selben Dateinamen wie der Befehl abschmiert?
Danke nochmal bybye
Viele Grüße zurück
Bitte warten ..
Mitglied: VW
03.12.2007 um 17:40 Uhr
Moin,

ich habe leider auch nur eine Vermutung.

Der eigentliche Befehl wird von der cmd leider in dem Fall als Dateiname betrachtet, da die Datei im selben Verzeichnis liegt und damit eine höhere Priorität als die Dateien/Befehle in der %PATH% hat.

Dadurch führt sich die cmd-Datei immer wieder selbst aus, wobei "v: c:\Futura" als Parameter übergeben wird.

Noch zu testen wäre das Verhalten, wenn man einen anderen Befehl ausführt, zu dem aber auch eine gleichnamige Datei im gleichen Verzeichnis liegt, die z.B. eine Datei erstellt, um anzuzeigen, dass sie ausgeführt wurde.

MfG,
VW
Bitte warten ..
Mitglied: VW
03.12.2007 um 17:46 Uhr
Moin schon wieder,

ich konnte das Verhalten leider gerade weder mit der Datei, die den befehlsnamen hat, der ausgeführt wird, noch mit der o.g. zweiten Datei nachstellen.

Vielleicht kannst du meinen vorgeschlagenen Versuch selber durchführen und das Ergebnis posten?
Würde mich ja mal interessieren.

MfG,
VW

[edit]
Mit dem Befehl "subst" habe ich auch eine Schleife.
Begründung: "subst" ist eine Datei innerhalb der %PATH%, während echo (mein vorheriger Test) direkt als Befehl in der cmd implementiert ist.

Der Test mit 2 Dateien:
Wenn beide Befehle als *.exe in %PATH% existieren und nicht direkt von der cmd implementiert sind, funktioniert es (getestet mit wuauclt und subst)
[/edit]
Bitte warten ..
Mitglied: jato11
03.12.2007 um 20:53 Uhr
hohoho, vielen dank, hat gepasst.
Jetzt kommt mir auch wieder alles hoch,
hatte das schon mal.
Hast du da auch eine Ahnung warum er beim
selben Dateinamen wie der Befehl abschmiert?
Nein, kann ich auch nicht genau sagen, aber das war
früher schon zu DOS-Zeiten nicht unproblematisch.

Deshalb vermeide ich Namen die genauso lauten wie interen Befehle.

Du könntest um eine Beziehung zum Inhalt hertzustellen den Namen erweitern
z.B. xsubst.cmd. Dann steht "x" für eigenes Programm.


Viele Grüße
Torsten
Bitte warten ..
Ähnliche Inhalte
Erkennung und -Abwehr
Dishwasher has directory traversal bug The Register (3)

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Administrator.de Feedback
gelöst Bug in einzelnen Threads: Antwortübersicht fehlerhaft bzw. unvollständig (4)

Frage von em-pie zum Thema Administrator.de Feedback ...

Tipps & Tricks
Incident report on memory leak caused by parser bug (2)

Link von Sheogorath zum Thema Tipps & Tricks ...

Sicherheit
Open Bug Bounty: Sicherheitslücken gegen Prämie

Link von ashnod zum Thema Sicherheit ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit Shorewall, ISC-DHCP Server konfigurieren für Android Devices (24)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Hardware
16-20 Port POE Switch mit VLAN (19)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
Exchange HyperV Prozessorlast (18)

Frage von theoberlin zum Thema Windows Server ...