Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

CD-DVD-Laufwerk wird nicht mehr angezeigt

Frage Linux

Mitglied: Franzmann

Franzmann (Level 1) - Jetzt verbinden

06.02.2008, aktualisiert 07.02.2008, 9529 Aufrufe, 12 Kommentare

Hallo,
ich habe das Problem das mein CD-/DVD-Laufwerk nicht mehr erkannt werden.
Ich benutze SLES 10.2. Da ich gerade diverse Dinge von einer CD installieren wollte,
fiel es mir auf.
Wenn ich den Befehl "mount" eingebe, erscheint folgendes:
/dev/sda1 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/fs/vmblock/mountPoint type vmblock (rw)
/root on /root/ftp type none (rw,bind)
Bei den Befehlen:
ls -l /dev/cdrom bzw. ls -l /dev/dvd
bekomme ich folgendes:
lrwxrwxrwx 1 root root 3 Jan 9 15:50 /dev/cdrom -> sr0
lrwxrwxrwx 1 root root 3 Jan 9 15:50 /dev/dvd -> sr0
So sieht meine fstab-Datei aus:
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1DP717336-part1 / reiserfs acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ13P512511-part1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ13P512511-part3 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/root/ /root/ftp auto bind 1 1

Wie bekomme ich das wieder in den Gang ?
Danke..
Mitglied: 39916
06.02.2008 um 17:34 Uhr
Hallo Franzmann,

Dir fehlt der Eintrag für Dein optisches Laufwerk in der fstab. Vorgehensweise:

1.) Stelle fest, wo das Laufwerk physikalisch angeschlossen ist: ide (prim/sek/master/slave), sata
2.) Versuche das Laufwerk händisch zu mounten.
3.) Trage die entsprechenden Parameter in die fstab ein.

Dann sollte alles wieder gehen.

Gruß,

Martin
Bitte warten ..
Mitglied: Franzmann
06.02.2008 um 23:36 Uhr
Hallo Franzmann,

Dir fehlt der Eintrag für Dein
optisches Laufwerk in der fstab.
Vorgehensweise:

1.) Stelle fest, wo das Laufwerk
physikalisch angeschlossen ist: ide
(prim/sek/master/slave), sata
Primär IDE
2.) Versuche das Laufwerk händisch zu
mounten.
Was bedeutet das ;) ?
Per mount -f .. ? Wie genau muss der Befehl aussehen ?!
3.) Trage die entsprechenden Parameter in
die fstab ein.
Wie genau müssen die aussehen.
Habe bisher nur unterschiedliche angaben dazu im Netz gefunden !
Danke..

Dann sollte alles wieder gehen.

Gruß,

Martin
Bitte warten ..
Mitglied: 39916
06.02.2008 um 23:42 Uhr
Eintrag in fstab sollte so aussehen:

/dev/hda /media/cdrom iso9660 ro,user,noauto 0 0

Dann ein mount -a.

Evtl. musst Du hinter cdrom eine Zahl angeben (cdrom0..)

Gruß,

Martin
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 08:45 Uhr
Eintrag in fstab sollte so aussehen:

/dev/hda /media/cdrom iso9660
ro,user,noauto 0 0

Dann ein mount -a.

Evtl. musst Du hinter cdrom eine Zahl
angeben (cdrom0..)

Hey,
habs ausprobiert.
Es werden auch Laufwerke gemountet, doch kann ich nicht drauf zu greifen.
Unable to mount the selected volume
mount: mount point /media/cdrom does not exist
So ein Käse ;(
Bitte warten ..
Mitglied: 39916
07.02.2008 um 08:48 Uhr
Das Verzeichnis existiert nicht! Du musst es entweder vorher anlegen (Rechte beachten) oder einen anderen Mount-Point auswählen.

Bsp.: mkdir /tmp/dvd

Dann heißt der Eintrag

/dev/hda /tmp/dvd iso9660 ro,user,noauto 0 0

Gruß.
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 09:05 Uhr
Das Verzeichnis existiert nicht! Du musst es
entweder vorher anlegen (Rechte beachten)
oder einen anderen Mount-Point
auswählen.

Bsp.: mkdir /tmp/dvd

Dann heißt der Eintrag

/dev/hda /tmp/dvd iso9660 ro,user,noauto 0
0

Ok, unter /dev liegt jeweils nen Mountpoint cdrom und dvd
Habs jetzt mal so probiert
/dev/hda /media/cdrom iso9660 ro,user,noauto 0 0
Ohne Erfolg.
Welche Rechte müssen Mountpoints haben ?
Und gibt es ne Möglichkeit Laufwerke automatisch neu erkennen zu lassen ?
Bitte warten ..
Mitglied: 39916
07.02.2008 um 09:14 Uhr
Dein Laufwerk sollte immer automatisch erkannt werden! Wenn es das nicht wird, dann hast Du ein anderes Problem. Das Verzeichnis /dev/cdrom sollte ein Sym-Link auf Dein hda sein, das Verzeichnis /media/cdrom hat die Rechte 755.
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 09:18 Uhr
Dein Laufwerk sollte immer automatisch
erkannt werden! Wenn es das nicht wird, dann
hast Du ein anderes Problem. Das Verzeichnis
/dev/cdrom sollte ein Sym-Link auf Dein hda
sein, das Verzeichnis /media/cdrom hat die
Rechte 755.
Danke, werde die Kiste mal aufschrauben und das Laufwerk anders anschliessen !
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 10:00 Uhr
Hab gerade festgestellt das ich ja das Laufwerk getauscht hatte und nu ein SATA Laufwerk drin habe. Macht das bei der Angabe der Parameter in der fstab nen Unterschied ?
Bitte warten ..
Mitglied: 39916
07.02.2008 um 10:03 Uhr
Ja klar, S-ATA wird unter Linux als SCSI angesprochen, also sda oder so.
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 10:23 Uhr
Ja klar, S-ATA wird unter Linux als SCSI
angesprochen, also sda oder so.
Ist auf dem Board auf SATA3 angeschlossen.
Habe jetzt alle Varianten einmal durch:
Es gibt nämlich bei mir:
sda sda1 sdb sdb1 sdb2 sdb3 sdb4 sdb5 sdb6
gemountet mit:
/dev/sd* /media/cdrom iso...
  • = a, b oder 1..wie oben angegeben..
Hmm ich bin zu blöde glaub ich ;)
Bitte warten ..
Mitglied: Franzmann
07.02.2008 um 11:35 Uhr
Jetzt gehts:
/dev/sr0 on /media/SLES100_001 type iso9660 (ro,nosuid,nodev,utf8,uid=0)
/dev/sr1 on /media/SLES100_001 type iso9660 (ro,nosuid,nodev,utf8,uid=0)
und noch nen reboot hinterher und dann liefs...
Aber genau verstehen tu ichs immer noch net :D
Danke bubbafish ;) < >
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 10
DVD-Laufwerk auf einmal verschwunden (19)

Frage von Swister zum Thema Windows 10 ...

Audio
Der lästige Windows Media Player und das DVD Laufwerk (6)

Frage von Stefan007 zum Thema Audio ...

Windows 10
DVD-Laufwerk unter Windows 10 verschwunden (14)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Notebook & Zubehör
gelöst HP Pavilion DV9700 bootet nicht vom DVD-Laufwerk (13)

Frage von achklein zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...