Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Centreon check wmi plus.pl checknetwork Funktioniert nicht

Frage Netzwerke Monitoring

Mitglied: rotewolke

rotewolke (Level 1) - Jetzt verbinden

16.11.2012 um 10:50 Uhr, 3756 Aufrufe, 4 Kommentare

Centreon Monitoring Software
PLUGIN: check_wmi_plus.pl

Hallo

Meine frage dazu ist was ist das Problem wenn unter Konfiguration Befehle ich die Prüfung Bearbeite und dort Live Teste ich eine Antwort erhalte und wenn ich unter Services den Service Aktiviere ich die Antwort so erhalte:

UNKNOWN - Permission denied when trying to store the state data. Sometimes this happens if you have been testing the plugin from the command line as a different user to the Nagios process user. You will need to change the permissions on the file or remove

Genau das gleiche erhalte ich bei der Abfrage vom checkcpu

Hat da jemand Erfahrung?

meine Abfrage lautet so:
01.
$USER1$/check_wmi_plus.pl -H $HOSTADDRESS$ -u DOMAIN/USER -p PASSWORT -m checknetwork -a $ARG1$
Ich nehme dann die Option LAN-VERBINDUNG in den Service Einstellung. Wenn ich keinen Eintrag habe, erhalte ich eine Antwort!

Mitglied: AB-Sys
16.11.2012 um 12:35 Uhr
Im Grunde steht dort bereits die Ursache und die Lösung:

Permission denied when trying to store the state data. Sometimes this happens if you have been testing the plugin from the command line as a different user to the Nagios process user. You will need to change the permissions on the file or remove

Das Ergebnis des Checks wird in eine Statusdatei geschrieben und der Prozess unter der Centreon läuft, darf nicht in die Datei schreiben.
Korrigiere die Berechtigungen der Datei, dann sollte es gehen.
Bitte warten ..
Mitglied: rotewolke
16.11.2012 um 12:49 Uhr
ok... und welche Datei ist das?

Verstehe das nicht so ganz den wenn ich den Wert LAN-Verbindung rausnehme bekomme ich ja Infos von allen Netzwerkadaptern.
Bitte warten ..
Mitglied: AB-Sys
16.11.2012 um 12:57 Uhr
Ich kenne deine Konfiguration nicht.
Ggf. /tmp ?
Bitte warten ..
Mitglied: rotewolke
16.11.2012 um 13:15 Uhr
Ja stimmt... im /tmp hatte er kein Erlaubnis. Danke!
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Router & Routing
TPLink Router Standard admin Passwort funktioniert nicht (12)

Frage von Emmy2437 zum Thema Router & Routing ...

E-Mail
Spam-Check über DNS (7)

Frage von Philipp711 zum Thema E-Mail ...

Exchange Server
gelöst SBS 2003 Exchange deaktiviert - E-Mail-Versand untereinander funktioniert nicht (3)

Frage von Wirdnoch zum Thema Exchange Server ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (10)

Frage von Akcent zum Thema Hyper-V ...

Netzwerke
Abisolierwerkzeug (9)

Frage von SarekHL zum Thema Netzwerke ...