Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Chinese Zeichen falsch dargestellt/MySQL

Frage Entwicklung

Mitglied: pendragon302

pendragon302 (Level 1) - Jetzt verbinden

14.12.2006, aktualisiert 21:34 Uhr, 6047 Aufrufe, 1 Kommentar

Hallo zusammen,

mich plagt momentan ein Problem mit der Speicherung von chinesischen Schriftzeichen in einer MySQL Tabelle. Habe auf dem Webserver (IIS6) die Unterstützung von ostasiatischen Sprachen installiert. Desweiteren hab ich dies auch auf meinem Heim PC installiert.

Um zu testen ob alles mit den chinesishcen Schriftzeichen klappt, habe ich ein PHP Script geschrieben, dass die Zeichen in die DB speichert und auch wieder einliesst. Nun hat sich aber folgende Tücke ergeben:
Speicher ich die Schriftzeichen per PHP-Script so werden diese dort auch wieder richtig angezeigt, aber wenn ich mir die Tabelle mit phpMyAdmin anschaue dann sind dort keine chinesischen Schriftzeichen sondern ganz andere Zeichen, sie scheinen irgendwie codiert zu sein.

Speicher ich chinesischen Text manuell per phpMyAdmin so werden sie dort auch richtig angezeigt, will ich sie aber mit nem php-Script wieder auslesen, so erscheinen lediglich Fragezeichen anstelle der chin. Schriftzeichen. Woran kann das liegen? Welche Einstellung hab ich vergessen?

Das folgende Bild zeigt die Struktur der MySQL Tabelle
<img src=http://pendragon302.pe.funpic.de/bild1.jpg>;

Die das Feld in das die chin Einträge reinkommen sollen, hat die Kollation utf8_unicode_ci

Das Bild zeigt die beiden Einträge
<img src=http://pendragon302.pe.funpic.de/bild2.jpg>;
Der erste wurde mit PHP-Scrpt eingefügt und der zweite manuell per phpMyAdmin.

Als Ergebnis bekomme ich beim Auslesen folgendes:
<img src=http://pendragon302.pe.funpic.de/bild3.jpg>;

Woran liegt das?

Gruß
Mitglied: pendragon302
14.12.2006 um 21:34 Uhr
Mein Problem hat sich soeben gelöst.

Es fehlte nur ein mysql_query("SET names 'utf8'");

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Verschlüsselung & Zertifikate
Zugriff auf mySQL-DB mit ODBC und SSL (2)

Frage von Titan24 zum Thema Verschlüsselung & Zertifikate ...

LAN, WAN, Wireless
Fritzbox Landingpage - haben Nutzungsbedingungen ein Limit von 200 Zeichen? (7)

Frage von DerWoWusste zum Thema LAN, WAN, Wireless ...

Cluster
Brauche hilfe beim einrichten von Galera Cluster for MySQL

Frage von akadawa zum Thema Cluster ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...