Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Chromium - Mit Javascript Audio-Datei abspielen funktioniert nicht

Frage Entwicklung JavaScript

Mitglied: mabue88

mabue88 (Level 2) - Jetzt verbinden

31.07.2014, aktualisiert 09:50 Uhr, 1275 Aufrufe, 3 Kommentare

Hallo,

innerhalb eines Webfrontends soll beim Aktualisieren der dargestellten Informationen ein Gong abgespielt werden.

Dafür verwende ich bisher folgenden Javascript-Code:
01.
var playing = false; 
02.
 
03.
function PlayBell(){ 
04.
    if(!playing){ 
05.
        playing = true; 
06.
         
07.
        var audio = new Audio("sound.mp3"); 
08.
        audio.play(); 
09.
 
10.
        playing = false; 
11.
12.
}
Innerhalb von Firefox und Chrom funktioniert das wunderbar. Das Problem habe ich nur mit Chromium. Er spielt die Datei nicht ab. Auch nicht wenn ich anstelle der MP3- eine OGG-Datei verwende.

Edit: Es liegt daran, dass Chromium HTML5 nicht unterstützt. Die Pakete chromium-codecs-ffmpeg und chromium-codecs-ffmpgeg-extra können über apt-get nicht installiert werden. Das Ganze läuft auf einem Raspberry Pi unter Raspbian.

Danke
mabue
Mitglied: colinardo
31.07.2014, aktualisiert um 10:42 Uhr
Hi mabue,
hast du schon mal probiert die *.so Bibliothek aus einem Chrome manuell in das Chromium Verzeichnis auf dem Raspi zu kopieren:
http://downloadsquad.switched.com/2010/06/24/play-embedded-mp3-audio-fi ...

Grüße Uwe
Bitte warten ..
Mitglied: mabue88
02.08.2014 um 17:13 Uhr
Hallo colinardo,

dein Tipp könnte hilfreich sein.
Das einzige was mir fehlt ist der Installationspfad von Chromium, damit ich die Datei libffmpegsumo.so dort einfügen kann.
Bislang konnte ich weder im Terminal noch mit WinSCP einen Ordner finden, der entsprechende Programmdateien beinhaltet.

Danke!

Gruss
mabue
Bitte warten ..
Mitglied: mabue88
13.08.2014 um 08:22 Uhr
Hallo zusammen,

ich habe das Problem jetzt anders gelöst. Auf meinem Raspberry Pi läuft jetzt ein kleiner Webserver. Der Audioplayer wird mittels AJAX direkt auf dem Raspberry Pi ausgeführt.

Gruss
mabue
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Batch & Shell
gelöst Powershell Datei kopieren mit ACL Script funktioniert nicht (4)

Frage von xpxy15 zum Thema Batch & Shell ...

Router & Routing
TPLink Router Standard admin Passwort funktioniert nicht (12)

Frage von Emmy2437 zum Thema Router & Routing ...

Windows Server
gelöst Windows 2012R2 kann Datei nicht löschen (2)

Frage von Akcent zum Thema Windows Server ...

Exchange Server
gelöst SBS 2003 Exchange deaktiviert - E-Mail-Versand untereinander funktioniert nicht (3)

Frage von Wirdnoch zum Thema Exchange Server ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (24)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Netzwerke
Abisolierwerkzeug (11)

Frage von SarekHL zum Thema Netzwerke ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (11)

Frage von Akcent zum Thema Hyper-V ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...