Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 1801 mit externen Modem

Frage Netzwerke

Mitglied: 81005

81005 (Level 1)

24.07.2009, aktualisiert 13:41 Uhr, 4032 Aufrufe, 7 Kommentare

Benötige Hilfe in der Konfiguration eines Cisco 1801 Routers mit einem externen DSL Modem.

Ich bin glücklicher(?) Besitzer eines Cisco 1801 Routers, der in Deutschland nicht als DSL Modem funktioniert, da hierzulande nur Annex B vorhanden ist.
Jetzt wollte ich diesen Router dennoch in Betrieb mit einem externen Modem nehmen, das die Einwahl und den Datenverkehr ins Internet übernimmt.

Allerdings bekomme ich keine startup-config hin, die es ermöglicht, dass der Router den Verkehr im internen Netz (192.168.2.0) regelt und alle anderen
Anfragen über das Modem leitet.

Kann mir bitte jemand helfen.
Mitglied: aqui
24.07.2009 um 14:15 Uhr
Wer hier suchet der findet....
Dieser Thread sollte dein "Problem" im Handumdrehen lösen: !

http://www.administrator.de/Cisco_1700_ADSL_konfigurieren.html

oder hier der 2te Vorschlag wenn wenn dir die VPN Konfig wegdenkst !
http://www.administrator.de/Vernetzung_zweier_Standorte_mit_Cisco_876_R ...
Bitte warten ..
Mitglied: 81005
24.07.2009 um 14:28 Uhr
Vielen Dank schon mal für die schnelle Hilfe.

Allerdings löst das nicht mein Problem. Denn der 1801er kann nicht mit dem deutschen DSL-Netz. Mein externes Modem übernimmt schon die Einwahl in das DSL Netz.
Ich möchte ein Interface nutzen, um es mit dem DSL Modem zu verbinden und so konfigurieren, dass sämtliche Anfragen, die nicht ins interne Netz (192.168.2.0) gehen,
an dieses Interface geleitet werden.

Da stellt sich mir schon eine neue Frage, wer übernimmt dann das NAT, der Router oder das DSL Modem (Linksys ADSL2-Gateway).

Oder habe ich deinen Tipp falsch verstanden?
Bitte warten ..
Mitglied: 81007
24.07.2009 um 14:50 Uhr
Eventuell übernehmen bei das Nat.

Also du schaltest nat beim Router aus, das Modem übernimmt das schon.

Du musst noch eine Route erstellen!

geh in die console vom cisco.

in den config terminal modus.
Aktiviere RIP version 2 und geb dein internes Netz an, sowie das netz des ISPs
Bitte warten ..
Mitglied: aqui
24.07.2009 um 15:48 Uhr
@81005
Scheinbar bist du nichtmal in der Lage Threads die dir helfen richtig zu lesen. Wenn es daran schon scheitert dann hast du generell ein Problem.

Wenn du dir also einmal wirklich die beiden o.a. Threads durchliest dann wirst auch du (hoffentlich) erkennen das die Cisco Konfig eine ganz normale banale PPPoE Konfig ist mit der ein DSL Zugang überall möglich ist im gesamten deutschen DSL Netz bei jeglichem Provider !

Hier nochmal eine Zeichnung für Dummies damit es dann hoffentlich klappt:

1ce577aa43a757299cdc8ff140b13865-cisco - Klicke auf das Bild, um es zu vergrößern

Die Konfig sagt doch ganz klar:

interface Ethernet0/1
description PPPoE Verbindung z. DSL Provider

Und eine Modem Konfig ist weit und breit nicht zu sehen...oder ??
Und: Natürlich macht der Router NAT so wie es sich auch gehört !! Sieh in die Konfig, dann siehst du es !:
"ip nat inside source list 101 interface Dialer1 overload "
Was oben steht ist Unsinn, denn ein reines DSL Modem ist ein passiver Medienwandler der niemals routen kann geschweige denn sowas wie NAT könnte !!
Wir reden hier von einem DSL Modem und keinem Router !!!
Das wird aber von vielen Laien hier im Forum immer und immer wieder falsch beschrieben.
Ebenso ein dynmaiches Routing Protokoll wie oben vorgeschalgen ist vollkommener Unsinn. In deinem Banalnetz reicht eine einfache statische Route
"ip route 0.0.0.0 0.0.0.0 Dialer1 "
wie sie ja auch in der Konfig steht !!

Also: erst richtig Lesen, konfigurieren, zusammenstecken...dann meckern ! (Wenns denn nicht klappen sollte !)
Bitte warten ..
Mitglied: 81005
27.07.2009 um 13:44 Uhr
Jetzt habe ich deinen Beitrag genauestens gelesen und habe deine config geändert und auf den Router überspielt, dennoch funktioniert es nicht:
Mein Modem kann PPPoE Passthrough (Linksys ADSL2 Gateway)

01.
service timestamps debug datetime localtime 
02.
service timestamps log datetime localtime 
03.
04.
hostname Router 
05.
06.
clock timezone MET 1 
07.
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00 
08.
ip subnet-zero 
09.
10.
username admin privilege 15 password 7 XXXXXXXXXXXXXXXXXX 
11.
12.
vpdn enable 
13.
14.
vpdn-group pppoe 
15.
 request-dialin 
16.
  protocol pppoe 
17.
18.
interface FastEthernet0 
19.
 description Lokales LAN 
20.
 ip address 192.168.2.1 255.255.255.0 
21.
 ip nat inside 
22.
23.
interface FastEthernet8 
24.
 description PPPoE Verbindung z. DSL Provider 
25.
 no ip address 
26.
 full-duplex 
27.
 pppoe enable 
28.
 pppoe-client dial-pool-number 1 
29.
30.
interface Dialer1 
31.
 description  DSL Provider Dialin 
32.
 ip address negotiated 
33.
 ip mtu 1492 
34.
 ip nat outside 
35.
 encapsulation ppp 
36.
 dialer pool 1 
37.
 dialer-group 1 
38.
 no cdp enable 
39.
 ppp authentication pap callin 
40.
 ppp pap sent-username XXXXXXXXXXXXXXXXXXXXXXXX#0001@t-online.de password XXXXXXXX 
41.
!											 														 
42.
ip nat inside source list 101 interface Dialer1 overload 
43.
ip classless 
44.
ip route 0.0.0.0 0.0.0.0 Dialer1 
45.
ip http server 
46.
47.
access-list 101 permit ip 192.168.2.0 0.0.0.255 any 
48.
dialer-list 1 protocol ip list 101 
49.
50.
line con 0 
51.
line aux 0 
52.
line vty 0 4 
53.
 password 7 XXXXXXXXXXXXXXXXXX 
54.
 login 
55.
line vty 5 15 
56.
 login 
57.
58.
end
Bitte warten ..
Mitglied: aqui
05.08.2009 um 14:21 Uhr
Nur mal nebenbei gefragt:
Ist dein DSL Provider überhaupt T-Online ???
Wenn nicht, dann kann es sein das ein alternativer Provider natürlich ein anderen Usernamen und Passort erzwingt oder das das Authetisierungsprotokoll CHAP ist statt PAP.
Außerdem ist dein PAP User/Password String falsch. Dei T-Online muss er so lauten:

ppp pap sent-username XXXXXXXXXXXXXXXXXXXXXXXX0001@t-online.de password XXXXXXXX

Und das auch nur bei Privat Anschlüssen. Bei einem Business DSL lautet der wie bei anderen Providern völlig anders !!
Da wären weitere Infos sehr hilfreich für eine Lösung ! Leider leiferst du die ja nicht

Denke ferner daran das der Cisco so in der o.a. Konfig KEIN DNS Proxy ist !!!
Um also Namen in IP Adressen aufzulösen MUSS dein Client den IP DNS Server des Providers konfiguriert haben !!! Sonst klappt es nicht.
Wenn du eine neuere IOS Version drauf hast kann der Cisco auch DNS Proxy sein und auch DHCP Server. Dafür fehlt allerdings in deiner geposteten Konfig die folgenden Zeilen !!:

DHCP Server (mit Range von .2.150 bis .2.169):
ip dhcp excluded-address 192.168.2.1 192.168.2.149
ip dhcp excluded-address 192.168.2.170 192.168.2.254
!
ip dhcp pool router
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1 (Achtung: Ohne aktivierten DNS Proxy muss hier unbedingt die DNS IP des Providers statt die des Routers stehen !!)

DNS Proxy:
interface Dialer 1
ppp ipcp dns request
ppp ipcp mask request
!
ip dns server

Der Cisco hat ansonsten sehr gute Debug Möglichkeiten !!

Wenn du an der sereillen Konsole hängst gib doch einfach mal ein:
debug dialer packet
und
debug ppp authentication
sowie debug pppoe ?

Dann siehst du sofort auf Schlag wo dein Problem liegt und kannst das sofort besetigen !

Wenn du eine Telnet Session auf den Router hast musst du zusätzlich terminal monitor eingeben um die Debug Meldungen zu sehen.

Wenn alles rennt solltest du zum Schluss immer mit undebug all alles Debugging abschalten !

Die Konfig ist ansonsten richtig und sollte absolut problemlos mit T-Online (und nur mit denen !) funktionieren !
Bitte warten ..
Mitglied: 81005
05.09.2009 um 16:55 Uhr
Schließe ich das Modem direkt an einen PC und richte eine PPPoE Verbindung ein; funktioniert die Internetverbindung einwandfrei. Schalte ich den Router dazwischen, dann geht da leider gar nichts mehr.
Auf obige Anfrage und in der Hoffnung diese Geschichte endlich abzuschließen, poste ich mal meine komplette running config.
Debugging hat erbracht, dass ich wahrscheinlich das gleiche Problem habe wie in diesem Beitrag geschildert: padi timer expired

01.
!This is the running config of the router: 192.168.2.1 
02.
!---------------------------------------------------------------------------- 
03.
!version 12.4 
04.
service timestamps debug datetime localtime 
05.
service timestamps log datetime localtime 
06.
no service password-encryption 
07.
08.
hostname Router 
09.
10.
boot-start-marker 
11.
boot-end-marker 
12.
13.
14.
no aaa new-model 
15.
clock timezone MET 1 
16.
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00 
17.
18.
19.
dot11 syslog 
20.
21.
22.
ip cef 
23.
no ip dhcp use vrf connected 
24.
ip dhcp excluded-address 192.168.2.1 192.168.2.59 
25.
ip dhcp excluded-address 192.168.2.100 192.168.2.254 
26.
27.
ip dhcp pool router 
28.
   network 192.168.2.0 255.255.255.0 
29.
   default-router 192.168.2.1  
30.
   dns-server 217.0.43.113  
31.
32.
33.
ip auth-proxy max-nodata-conns 3 
34.
ip admission max-nodata-conns 3 
35.
36.
multilink bundle-name authenticated 
37.
vpdn enable 
38.
39.
vpdn-group pppoe 
40.
 request-dialin 
41.
  protocol pppoe 
42.
 l2tp tunnel receive-window 256 
43.
44.
45.
46.
username admin privilege 15 password 7 XXXXXXXXXXXXXX 
47.
!  
48.
49.
archive 
50.
 log config 
51.
  hidekeys 
52.
53.
54.
55.
56.
bba-group pppoe global 
57.
58.
59.
interface FastEthernet0 
60.
 description Lokales LAN 
61.
 ip address 192.168.2.1 255.255.255.0 
62.
 ip nat inside 
63.
 ip virtual-reassembly 
64.
 duplex auto 
65.
 speed auto 
66.
67.
interface BRI0 
68.
 no ip address 
69.
 encapsulation hdlc 
70.
 shutdown 
71.
72.
interface FastEthernet1 
73.
 description Lokales LAN 
74.
75.
interface FastEthernet2 
76.
 description Lokales LAN 
77.
78.
interface FastEthernet3 
79.
 description Lokales LAN 
80.
81.
interface FastEthernet4 
82.
 description Lokales LAN 
83.
84.
interface FastEthernet5 
85.
 description Lokales LAN 
86.
87.
interface FastEthernet6 
88.
 description Lokales LAN 
89.
90.
interface FastEthernet7 
91.
 description Lokales LAN 
92.
93.
interface FastEthernet8 
94.
 description PPPoE Verbindung z. DSL Provider 
95.
 pppoe enable group global 
96.
 pppoe-client dial-pool-number 1 
97.
98.
interface ATM0 
99.
 no ip address 
100.
 shutdown 
101.
 no atm ilmi-keepalive 
102.
 dsl operating-mode auto  
103.
104.
interface Vlan1 
105.
 no ip address 
106.
107.
interface Dialer1 
108.
 description DSL Provider Dialin 
109.
 ip address negotiated 
110.
 ip mtu 1492 
111.
 ip nat outside 
112.
 ip virtual-reassembly 
113.
 encapsulation ppp 
114.
 dialer pool 1 
115.
 dialer-group 1 
116.
 no cdp enable 
117.
 ppp authentication pap callin 
118.
 ppp pap sent-username XXXXXXXXXXXXXXXXXXXXXXXXXXXX0001@t-online.de password 0 XXXXXXXXXXXXXXXXXXX  
119.
 ppp ipcp dns request 
120.
 ppp ipcp mask request 
121.
122.
ip forward-protocol nd 
123.
ip route 0.0.0.0 0.0.0.0 Dialer1 
124.
125.
126.
ip http server 
127.
no ip http secure-server 
128.
ip dns server 
129.
ip nat inside source list 101 interface Dialer1 overload 
130.
131.
access-list 101 permit ip 192.168.2.0 0.0.0.255 any 
132.
dialer-list 1 protocol ip list 101 
133.
134.
135.
136.
137.
138.
139.
control-plane 
140.
141.
142.
line con 0 
143.
line aux 0 
144.
line vty 0 4 
145.
 password 7 XXXXXXXXXXXXXXXXXXXX 
146.
 login 
147.
line vty 5 15 
148.
 login 
149.
150.
end
Bitte warten ..
Ähnliche Inhalte
TK-Netze & Geräte
Externes USB Modem zum Faxen
Frage von tsunamiTK-Netze & Geräte7 Kommentare

Hallo, ich möchte ein externes Modem zum Faxen nutzen. Modem eingesteckt, wurde automatsich erkannt. Wunderbar. Windows Fax und Scan ...

UMTS, EDGE & GPRS
LTE Modem für alle Frequenzbereiche mit externe Antenne
gelöst Frage von istike2UMTS, EDGE & GPRS20 Kommentare

Hallo, bei einem Freund würden wir gerne einen LTE Modem einsetzen und den Empfang mit externer Antenne optimieren. Als ...

DSL, VDSL
Cisco 866VAE-K9 neue Modem Firmware Frage
gelöst Frage von LightiDSL, VDSL6 Kommentare

Hallo Leute, ich habe einen Cisco 866VAE-K9 bei mir privat im Einsatz und bin soweit auch sehr zufrieden damit. ...

LAN, WAN, Wireless
Externer Zugriff auf IP Arcor Speed Modem 200
gelöst Frage von bloedernameLAN, WAN, Wireless17 Kommentare

Hallo, ich würde gern eine IP Kamera anschließen und komme nicht weiter. Bei mir zu Hause funktioniert alles tadellos ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 15 StundenMikroTik RouterOS6 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 15 StundenSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 18 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 22 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Festplatten, SSD, Raid
USB Stick recovery
Frage von petereFestplatten, SSD, Raid15 Kommentare

Hallo, ich habe einen defekten USB-Stick, der nicht mehr lesbar ist. Er wird in WIN als unbekanntes Volume mit ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...